Bug 11762 - No video after resume from RAM without X
No video after resume from RAM without X
Status: REJECTED WILL_NOT_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-10-14 18:48 UTC by Luis Diaz
Modified: 2009-03-18 19:38 UTC (History)
0 users

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: ---


Attachments

Description Luis Diaz 2008-10-14 18:48:42 UTC
Latest working kernel version: none
Earliest failing kernel version: NA
Distribution: Ubuntu 8.04
Hardware Environment: HP Pavilion DV6950 (MCP67 / Geforce 6150m )
Software Environment: - 
Problem Description: 
Running GNU/Linux without starting (console ony) X i can dont get video after a susend to ram, if im on X and press suspend the system will come back

Steps to reproduce:
echo 3 > /proc.....
press power button


One thing to notice is that if i do startx the video is NOT restored, but checking the logs the notebook LCD is not detected by the nvidia module instead it show info about CRT and TV...
i do have a working terminal and SSH acces however, only no video...

Note: i had the problem before compiling the nvidia driver....

i dont know what info to provide....
Comment 1 Rafael J. Wysocki 2008-10-15 14:37:57 UTC
Well, you can try s2ram (http://en.opensuse.org/s2ram) with various combinations of options.

Do I understand correctly that the box resumes successfully when it's suspended from under X, but it doesn't when it's suspended from a console?
Comment 2 Luis Diaz 2008-10-15 14:45:51 UTC
I did not try to suspend from console with X running...just without even running X

does s2ram anything special?
Comment 3 Rafael J. Wysocki 2008-10-15 14:52:17 UTC
(In reply to comment #2)
> I did not try to suspend from console with X running...just without even
> running X

OK, but I understand that you tried from under X and the resume worked?

> does s2ram anything special?

It can, depending on the options you pass to it.
Comment 4 Zhang Rui 2008-11-04 21:39:46 UTC
it seems that this is just the know S3 video issue.
what if you startx and switch back to console, and then try to suspend to ram in console? I think that should also work, right?
then, do you know what's the graphics driver for nvidia in Linux?
what if you load these modules manually in console mode and try suspend to ram again?
Comment 5 Luis Diaz 2008-11-05 03:18:27 UTC
so, u mean that i should startx and go back to console without closing X ?

Xorg is using nvidia (binary) driver, but i noticed the problem even before compiling it
Suspend from console does NOT work, even tough the module is loaded or not.
in console im using vesa, but i also used vga=normal without any luck
Comment 6 Zhang Rui 2008-12-08 19:35:18 UTC
then you should try s2ram per Rafael's suggestion. :)

Note You need to log in before you can comment on or make changes to this bug.