Bug 11719 - another HP laptop to blacklist with thermal trip points with insanely low values
another HP laptop to blacklist with thermal trip points with insanely low values
Status: RESOLVED DUPLICATE of bug 11516
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-10-08 06:47 UTC by Fabio
Modified: 2008-10-11 04:59 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc9
Tree: Mainline
Regression: ---


Attachments
General fix for the issue (2.20 KB, patch)
2008-10-10 15:33 UTC, Rafael J. Wysocki
Details | Diff

Description Fabio 2008-10-08 06:47:40 UTC
Distribution: Ubuntu 8.10

Hardware Environment: HP Compaq 6715s

Problem Description: in 2.6.27-rc9 I noticed a fix/blacklist (commit e84956f92a846246b09b34f2a728329c386d250f) for two ATI laptop that set thermal trip points to insanely low values.
I am using current Ubuntu LiveCD which ships kernel 2.6.27-6.9 (2.6.27-rc9 based) and I noticed a similar problem on my HP Compaq 6715s (with latest BIOS F.0D 08/20/2008).

Steps to reproduce: run current LiveCD (downloaded from http://cdimage.ubuntu.com/daily-live/). The system is really slow, the fan is always active, but ouput fresh air.

If can be useful, running the following command as found here: http://marc.info/?l=linux-acpi&m=121396447214047&w=4
I get:
$ cat /proc/acpi/thermal_zone/TZ*/trip_points
critical (S5):           105 C
passive:                 16 C: tc1=1 tc2=2 tsp=100 devices=C000 C001 
active[0]:               16 C: devices=C39B 
active[1]:               16 C: devices=C39C 
active[2]:               16 C: devices=C39D 
active[3]:               16 C: devices=C39E 

Maybe it should blacklisted also this hardware?

Thanks
Comment 1 Andrew Morton 2008-10-10 14:16:01 UTC
It would really help things along if you could email a tested patch to

Andrew Morton <akpm@linux-foundation.org>
"Rafael J. Wysocki" <rjw@sisk.pl>
linux-kernel@vger.kernel.org

Thanks.
Comment 2 Rafael J. Wysocki 2008-10-10 15:33:18 UTC
Created attachment 18257 [details]
General fix for the issue

In fact the attached patch from Andreas Herrmann should fix all of these boxes at once (already in the Ingo's tree).
Comment 3 Rafael J. Wysocki 2008-10-11 04:59:29 UTC

*** This bug has been marked as a duplicate of bug 11516 ***

Note You need to log in before you can comment on or make changes to this bug.