Bug 11717 - Pressing suspend button suspends, but does not wakes up on Itautec Note N8320
Pressing suspend button suspends, but does not wakes up on Itautec Note N8320
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Aaron Lu
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-10-07 23:01 UTC by Rogério Brito
Modified: 2014-10-28 05:14 UTC (History)
10 users (show)

See Also:
Kernel Version: 2.6.27-rc*
Tree: Mainline
Regression: No


Attachments
acpi dump (152.81 KB, text/plain)
2008-10-10 13:14 UTC, Rogério Brito
Details
dmesg of the machne (33.41 KB, text/plain)
2008-10-10 13:14 UTC, Rogério Brito
Details
output of lshw (16.12 KB, text/plain)
2008-10-10 13:15 UTC, Rogério Brito
Details
output of lspci (plain) (2.19 KB, text/plain)
2008-10-10 13:15 UTC, Rogério Brito
Details
output of lscpi -n (756 bytes, text/plain)
2008-10-10 13:16 UTC, Rogério Brito
Details
output of lspci -v (9.04 KB, text/plain)
2008-10-10 13:16 UTC, Rogério Brito
Details
output of lsusb (339 bytes, text/plain)
2008-10-10 13:17 UTC, Rogério Brito
Details
dmesg after the echo's (57.91 KB, text/plain)
2008-10-10 16:05 UTC, Rogério Brito
Details
new dmesg (44.48 KB, text/plain)
2008-10-18 03:28 UTC, Rogério Brito
Details
Another new dmesg log (45.05 KB, text/plain)
2008-10-28 21:35 UTC, Rogério Brito
Details
Contents from /proc/acpi (1.16 KB, application/x-gzip)
2009-06-22 17:46 UTC, Rogério Brito
Details
New dmesg of the machine (46.81 KB, text/plain)
2009-06-22 17:47 UTC, Rogério Brito
Details
output of dmidecode (8.01 KB, text/plain)
2009-06-22 17:48 UTC, Rogério Brito
Details
original dsdt from the notebook (22.69 KB, application/x-ns-proxy-autoconfig)
2009-06-22 17:49 UTC, Rogério Brito
Details
output from lshw (18.01 KB, text/plain)
2009-06-22 17:50 UTC, Rogério Brito
Details
output from lsmod (2.33 KB, text/plain)
2009-06-22 17:51 UTC, Rogério Brito
Details
a more verbose lspci output (43.56 KB, text/plain)
2009-06-22 17:51 UTC, Rogério Brito
Details
output from uname -a (96 bytes, text/plain)
2009-06-22 17:52 UTC, Rogério Brito
Details
dmesg of kernel 2.6.33-rc2 (63.87 KB, text/plain)
2010-01-06 00:13 UTC, Rogério Brito
Details
My current 2.6.33-rc2 config (64.38 KB, text/plain)
2010-01-06 00:15 UTC, Rogério Brito
Details
dmesg with KMS disabled (61.53 KB, text/plain)
2010-01-06 21:26 UTC, Rogério Brito
Details
Output from acpidump (33.33 KB, application/x-bzip)
2011-04-22 09:45 UTC, Rogério Brito
Details
Compressed dmesg from before the test (31.34 KB, application/x-bzip)
2011-04-22 09:47 UTC, Rogério Brito
Details
Compressed dmesg from after the test (41.83 KB, application/x-bzip)
2011-04-22 09:49 UTC, Rogério Brito
Details

Description Rogério Brito 2008-10-07 23:01:35 UTC
Latest working kernel version: none
Earliest failing kernel version: 2.6.24
Distribution: Ubuntu Intrepid alphas
Hardware Environment: Itautec Note N8320
Software Environment: Ubuntu userland
Problem Description:

I just bougth a small notebook that is based on the ICH8 chipset with a Core 2 Duo T7250 processor and it came bundled with Windows Vista.

Under Windows Vista (now, uninstalled), when I press the suspend button, it suspends the machine and when I press the suspend button a second time, the machine wakes up as expected.

Unfortunately, with kernels available in Ubuntu (hardy, intrepid), if I press the suspend button, the machine will go to suspend mode, but if I press the button again, the machine powers off.

Despite the fact that I'm using a range of Ubuntu kernels, I can install the stock kernel.org (actually, I plan on installing a vanilla Debian with my own compiled kernel) and I can provide as much information is needed (logs, etc).

Steps to reproduce: Press the suspend button. Press the suspend button again.


Thanks in advance, Rogério Brito.
Comment 1 ykzhao 2008-10-10 00:26:12 UTC
Will you please attach the output of acpidump?

Will you please do the following test on the latest kernel?
   a. echo core > /sys/powe/pm_test
   b. echo mem > /sys/power/state and wait for some time to confirm whether the system can be resumed?(Unncessary to press the power button).

After the test, please attach the output of dmesg.

Thanks.
Comment 2 Rogério Brito 2008-10-10 13:14:15 UTC
Created attachment 18247 [details]
acpi dump

Thanks for the reply.

I'm still using Ubuntu's kernel, but I can switch (and, in fact, will switch) to a newer kernel (actually, using a Debian userland with my own compiled kernel).

Here are some pieces of information that may be useful (attached).
Comment 3 Rogério Brito 2008-10-10 13:14:43 UTC
Created attachment 18248 [details]
dmesg of the machne
Comment 4 Rogério Brito 2008-10-10 13:15:16 UTC
Created attachment 18249 [details]
output of lshw
Comment 5 Rogério Brito 2008-10-10 13:15:47 UTC
Created attachment 18250 [details]
output of lspci (plain)
Comment 6 Rogério Brito 2008-10-10 13:16:21 UTC
Created attachment 18251 [details]
output of lscpi -n
Comment 7 Rogério Brito 2008-10-10 13:16:56 UTC
Created attachment 18252 [details]
output of lspci -v
Comment 8 Rogério Brito 2008-10-10 13:17:32 UTC
Created attachment 18253 [details]
output of lsusb
Comment 9 Rogério Brito 2008-10-10 16:05:16 UTC
Created attachment 18258 [details]
dmesg after the echo's

Here is the dmesg after

echo core > /sys/power/pm_test
echo mem > /sys/power/state

Please, note the call trace there. Is it expected?

I can upload a small movie of my machine showing what happens when I press the button, if desired (compressed with h.264 and no audio).

Thanks, Rogério Brito.
Comment 10 Rogério Brito 2008-10-13 15:35:53 UTC
Ping.
Comment 11 ykzhao 2008-10-13 23:16:20 UTC
Thanks for the test and confirmation that the system can return successfully if echo core > /sys/power/pm_test. Maybe this issue is related with the BIOS.
   Will you please add the boot option of "acpi_sleep=s3_beep" and confirm whether the beep voice can be heared when pressing the power button after the system enters S3 sleeping state?

    If there is no beep, will you please do the following test?
    a. echo 1 > /sys/power/pm_trace (If there doesn't exist the /sys/power/pm_trace, please enable "CONFIG_PM_TRACE" in kernel configuration)
    b. echo mem > /sys/power/state; reboot; 
    c. press the power button and see whether the system is rebooted( had better wait for some time).
    d. If the system is not rebooted, please press power button for several seconds to reboot the system and look at the dmesg output for things like(It will be great if you can attach the output of dmesg after reboot).
        Magic number: 4:156:725
        hash matches drivers/base/power/resume.c:28
        hash matches device 0000:01:00.0
    
   Thanks.
    
Comment 12 Rogério Brito 2008-10-18 03:27:25 UTC
Hi.

I am extremely sorry for not replying earlier this week. I will try to be more responsive, since I really want to improve the general status of the kernel, so that it works with as many machines as possible.

Anyway, I booted with acpi_sleep=s3_beep and put the machine to suspend. I heard no sound, but I don't really know if the speaker needs to be enabled. I also don't hear any beep on this machine when I'm working on the shell (the pcspkr module is loaded but it shows a use count of zero).

Anyway, I proceeded to the other tests.

1. echo 1 > /sys/power/pm_trace was ok

2. echo mem > /sys/power/state <- here the machine went to suspend automatically, without me pressing any button. I did not have a chance to type reboot or anything else.

3. I pressed the power button so that the machine would wake up, but it almost woke up and then turned off itself.

4. I rebooted the system pressing the power button and I looked at the dmesg. While there was a line with the "Magic number" value, there was no lines matching "hash matches" according to a quick grep.

I'm posting the whole dmesg here so that you can help me getting this issue solved.

Thanks, Rogério Brito.
Comment 13 Rogério Brito 2008-10-18 03:28:33 UTC
Created attachment 18359 [details]
new dmesg
Comment 14 Rogério Brito 2008-10-18 04:02:34 UTC
Please, see on the video at <http://www.ime.usp.br/~rbrito/linux/notebook.mp4> that when I press the power button, the machine goes to sleep and the led on the power button starts blinking.

Then, if I press it again to wake it up, it turns itself off. Then, surprisingly, it turns on again, but the machine is completely unusable. There is no way to change to any virtual terminal, no way to wake it up (I pressed many things in the hope that a screensaver would be executing).

Not even magic sysrq works. The only way to use it again is to press the power button for many seconds and boot it again. All the previous work was lost.

Thanks for any help, Rogério Brito.
Comment 15 ykzhao 2008-10-28 19:31:04 UTC
Will you please kill the process which is using /proc/acpi/event when doing the test? (You can use the command of "lsof /proc/acpi/event" to get the process which is using /proc/acpi/event).
   
   Thanks.
   
Comment 16 Rogério Brito 2008-10-28 21:01:06 UTC
Hi, Yakui.

On Oct 28 2008, bugme-daemon@bugzilla.kernel.org wrote:
> Will you please kill the process which is using /proc/acpi/event when doing the
> test? (You can use the command of "lsof /proc/acpi/event" to get the process
> which is using /proc/acpi/event).

I tested to see which process was using /proc/acpi/event and it was only
acpid. Nevertheless, I killed it and tried to follow the steps:

       echo 1 > /sys/power/pm_trace
       echo mem > /sys/power/state

At this point, I don't have any chance of typing reboot, as you
indicated in a previous message. The machine already goes to sleep.

If I press the power button expecting the wake up, it turns off the
laptop, then wakes up (as in the video that I linked before) and nothing
responds to keypresses.

The behavior is exactly what I get when I filmed the video. :-(

I'm updating the laptop to the latest packages and I will try the tests
again. Then, I will attach the dmesg log.


Thanks, Rogério Brito.

Comment 17 Rogério Brito 2008-10-28 21:35:43 UTC
Created attachment 18486 [details]
Another new dmesg log

Here is another dmesg.

Please, notice that there is no line matching "hash matches", like was told in an earlier message.

Help, please.
Comment 18 Rogério Brito 2008-10-29 00:26:03 UTC
Any further information??
Comment 19 Rogério Brito 2008-10-31 19:58:44 UTC
Any further information desired? Please let me know. I will do my best to
make this machine work.

BTW, I just tried to make it hibernate and it sometimes gets stuck in the
process of suspending. :-(

So, this means that I neither can suspend nor hibernate this laptop with
confidence. :-(


Please, help.
Comment 20 Rogério Brito 2008-11-06 11:48:09 UTC
Hi, all.

I have already filed a bug on bugzilla, but it seems that that hasn't
generated too much attention and I am willing to do as many tests as
possible to get things working fine here.

Here is my first post to bugzilla, just to give you some context:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Latest working kernel version: none
Earliest failing kernel version: 2.6.24
Distribution: Ubuntu Intrepid alphas
Hardware Environment: Itautec Note N8320
Software Environment: Ubuntu userland
Problem Description:

I just bougth a small notebook that is based on the ICH8 chipset with a
Core 2 Duo T7250 processor and it came bundled with Windows Vista.

Under Windows Vista (now, uninstalled), when I press the suspend button, it
suspends the machine and when I press the suspend button a second time, the
machine wakes up as expected.

Unfortunately, with kernels available in Ubuntu (hardy, intrepid), if I
press the suspend button, the machine will go to suspend mode, but if I
press the button again, the machine powers off.

Despite the fact that I'm using a range of Ubuntu kernels, I can install
the stock kernel.org (actually, I plan on installing a vanilla Debian with
my own compiled kernel) and I can provide as much information is needed
(logs, etc).

Steps to reproduce: Press the suspend button. Press the suspend button
again.


Thanks in advance, Rog
Comment 21 Rogério Brito 2008-11-06 17:45:52 UTC
If any further information is needed, please let me know.

Oh, and please keep me on the CC'ies.

On Nov 06 2008, Rog
Comment 22 Rogério Brito 2008-11-07 00:00:59 UTC
Hi.

Some more information that may prove to be useful.

Quoting Rog
Comment 23 Rogério Brito 2008-11-07 23:50:58 UTC
Hi once again.

On Nov 07 2008, Rogerio Theodoro de Brito wrote:
> Quoting Rog
Comment 24 Justin P. Mattock 2008-11-08 00:20:09 UTC
On Fri, Nov 7, 2008 at 11:50 PM, Rog
Comment 25 Rogério Brito 2008-11-08 18:45:31 UTC
Hi, Justin and others.

On Nov 08 2008, Justin Mattock wrote:
> On Fri, Nov 7, 2008 at 11:50 PM, Rog
Comment 26 Justin P. Mattock 2008-11-08 20:39:43 UTC
Appologize if this is quite brief
(sending from phone);
For the long delay try comment #2
Of:
http://bugzilla.kernel.org/show_bug.cgi?id=11220
Keep in mind msi.c might have been changed since then, so it might not  
work

justin P. Mattock



On Nov 8, 2008, at 6:45 PM, Rogério Brito <rbrito@ime.usp.br> wrote:

> Hi, Justin and others.
>
> On Nov 08 2008, Justin Mattock wrote:
>> On Fri, Nov 7, 2008 at 11:50 PM, Rogério Brito <rbrito@ime.usp.br> 
>>  wrote:
>>> I think that I have some more information regarding the suspend/ 
>>> hibernate
>>> issue: with Ubuntu's 2.6.27 kernel, I can't hibernate my laptop,  
>>> but with
>>> vanilla 2.6.28-rc3, I can hibernate (I have not tested it much,  
>>> but it
>>> seems to work).
>
> Just some extra information here: while I can hibernate with vanilla
> 2.6.28-rc3, upon resuming, it takes *minutes* (I don't know how many
> minutes, but probably something like 5 minutes or so!) for the  
> desktop to
> have any effect (despite the fact that I can move the mouse without  
> any
> problems).
>
> A new reboot is *much* faster than what I get with hibernate.
>
> I can film that if desired.
>
>>> But seeing the behaviour of this in comparison with Windows Vista,  
>>> two
>>> things still stand out:
>>>
>>> 1 - pressing the suspend button suspends the machine, but upon a  
>>> second
>>>   press, the machine still turns itself off and all work is  
>>> lost. :-(
>
> This problem still persists.
>
>>> 2 - closing the lid, no matter what I program in GNOME's Power  
>>> Preferences,
>>>   doesn't even blackens the screen, let alone suspend or hibernate  
>>> the
>>>   notebook.
>
> A correction here: when I close the lid, the laptop suspends. I can  
> try to
> see if it hibernates.
>
>>> Again, for those that I just included in the carbon copies now, I  
>>> have
>>> given extensive information on the bugzilla report, but I can  
>>> recompile
>>> kernels, get dumps of debugging information, get dumps under  
>>> Windows (if
>>> that helps and if I am instructed how to do that). You name it. I  
>>> am really
>>> willing to help as much as possible with all efforts that are  
>>> possible to
>>> me.
>
> Again, I am willing to get any debugging information or anything  
> that is
> asked me. I am testing things and I still don't have any production  
> data on
> that notebook.
>
> BTW, I installed Windows Vista with a dual boot. I'm feeling tainted
> now. :-(
>
>> I think you might be experiencing the dreaded black screen upon
>> wakeup.(after seeing you're quick video);
>
> Nice that the video proved useful to demonstrate the issue. I can take
> another video to show the current behaviour with 2.6.28-rc3.
>
>> I was having the same with my macbook pro, when running
>> radeonhd(haven't tried s2ram yet to see if this resolves the issue).
>> Although was told it should fix the issue.
>
> Right. Just for further information, this notebook here has a plain  
> ICH8
> chipset. The only thing that I think that is not from intel is the  
> gigabit
> ethernet, which is a Realtek one (it seems that the r8169 driver is  
> loaded,
> but I still have not tested wired connections).
>
>> Did have the same(black screen of death wakeup); with a dell
>> inspiron, but then realized my graphics modules weren't configured
>> properly.
>
> Weird. I have a Dell Latitude D520 here (which I'm using for this e- 
> mail)
> and everything that I tried works fine (suspend, wifi, hibernation  
> and even
> the compiz stuff---which I promptly disable). It has a broadcom  
> ethernet
> that seems to use the b44 driver, but I have also not used the wired
> connection here.
>
> I'm streaming audio via daap to this notebook from a Kurobox  
> (powerpc box)
> with kernel 2.6.27 kernel (and my patches that were included in
> 2.6.28-rc3).
>
>> As for the pressing of buttons, the initial pressing of the power  
>> button send's
>> shutdown to the machine for me, but when suspending the system, the  
>> power button
>> wakes the machine up, or closing and opening the lid.
>
> For me, nothing like this works. :-( I can open the lid and it still  
> stays
> sleeping. Pressing the suspend (poweron/poweroff?) button while  
> suspended
> only turns off the machine. :-(
>
>
> Thanks again for any feedback, Rogério Brito.
>
> -- 
> Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAE 
> B8
> http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
> Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org

Comment 27 Pavel Machek 2008-11-09 03:32:30 UTC
On Sun 2008-11-09 00:45:14, Rog
Comment 28 Rafael J. Wysocki 2008-11-09 05:03:18 UTC
On Sunday, 9 of November 2008, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11717
> 
> 
> 
> 
> 
> ------- Comment #25 from rbrito@ime.usp.br  2008-11-08 18:45 -------
> Hi, Justin and others.
> 
> On Nov 08 2008, Justin Mattock wrote:
> > On Fri, Nov 7, 2008 at 11:50 PM, Rog
Comment 29 Zhang Rui 2008-11-09 19:34:52 UTC
there are two problems here.

First is the suspend/resume problem.

Second is the suspend button issue, which is really confusing unless we've fixed the suspend/resume bug first.

let's focus on the suspend/resume problem in this bug entry.
So please stop using suspend button or lid button to do suspend/resume test.
You can use "echo mem > /sys/power/state" to suspend and use power button to resume to see how suspend/resume works on your laptop.
Comment 30 Justin P. Mattock 2008-11-09 21:17:45 UTC
On Sun, Nov 9, 2008 at 3:33 AM, Pavel Machek <pavel@suse.cz> wrote:
> On Sun 2008-11-09 00:45:14, Rog
Comment 31 Pavel Machek 2008-11-09 23:45:24 UTC
> On Sun, Nov 9, 2008 at 3:33 AM, Pavel Machek <pavel@suse.cz> wrote:
> > On Sun 2008-11-09 00:45:14, Rog
Comment 32 Rogério Brito 2008-11-10 06:06:52 UTC
Hi, Justin.

On Nov 08 2008, Justin P. Mattock wrote:
> Appologize if this is quite brief
> (sending from phone);
> For the long delay try comment #2
> Of:
> http://bugzilla.kernel.org/show_bug.cgi?id=11220
> Keep in mind msi.c might have been changed since then, so it might not  
> work

I checked this patch and it seems to be already incorporated into
2.6.28-rc3 (with a dry-run, it told me that it was already applied).

Thanks for the feedback anyway. I appreciate any help that I can take.


Thanks, Rog
Comment 33 Rogério Brito 2008-11-10 06:16:27 UTC
Hi, Pavel.

On Nov 09 2008, Pavel Machek wrote:
> On Sun 2008-11-09 00:45:14, Rog
Comment 34 Justin P. Mattock 2008-11-10 07:01:40 UTC
2008/11/9 Pavel Machek <pavel@suse.cz>:
>> On Sun, Nov 9, 2008 at 3:33 AM, Pavel Machek <pavel@suse.cz> wrote:
>> > On Sun 2008-11-09 00:45:14, Rog
Comment 35 Rogério Brito 2008-11-11 01:38:43 UTC
Hi, all.

On Nov 10 2008, Justin Mattock wrote:
> using the manual(echo mem > /sys/power/state)
> approach is not so good though
> i.g. black screen when waking up
> for a few seconds, then a automatic reboot.

To answer Zhang Rui's question, what I get is an approximation of what
Justin's posted here.

Zhang Rui wrote:
> let's focus on the suspend/resume problem in this bug entry.
> So please stop using suspend button or lid button to do suspend/resume
> test.
> You can use "echo mem > /sys/power/state" to suspend and use power button
> to resume to see how suspend/resume works on your laptop.

What I get when I use this is that the notebook goes to suspend state and
the only button that it has (power button) has a blue light that starts
blinking.

When I press the power button, as per your instructions, the machine powers
itself off and then, suddenly, it powers itself on again! (yes, that's
strange).

I'm filming this so that you can see for yourselves. The movie is at
<http://www.ime.usp.br/~rbrito/linux/notebook-02.mp4>.


Thanks for all your help, Rog
Comment 36 Pavel Machek 2008-11-11 04:50:48 UTC
On Mon 2008-11-10 12:15:50, Rog
Comment 37 Justin P. Mattock 2008-11-11 07:23:00 UTC
On Tue, Nov 11, 2008 at 1:53 AM, Pavel Machek <pavel@suse.cz> wrote:
> On Mon 2008-11-10 12:15:50, Rog
Comment 38 ykzhao 2008-12-23 23:32:53 UTC
Hi,Rogerio
    Sorry for the late response.
    Will you please use the command of "echo mem > /sys/power/state; dmesg >dmesg_after; sync; reboot"?
    After the system enters the sleeping state, please press the power button. 
    After the system is rebooted again, please check whether there exists the file of "dmesg_after".
    If yes, please attach the output of dmesg_after. 
    It is noted that you should kill the process which is using the /proc/acpi/event. 
    thanks.
Comment 39 Zhang Rui 2009-03-18 19:36:03 UTC
ping Rogerio. :)
Comment 40 Rogério Brito 2009-03-20 01:46:01 UTC
Hi, Rui and others.

On Wed, Mar 18, 2009 at 11:36 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> ping Rogerio. :)

Just for your information, I'm still seeing the problem with a recent
2.6.29-rc6 kernel on the notebook (those compiled by the Ubuntu folks,
without any of their patches).

In the mean time, I found a Windows utility that was able to gather
quite a lot of information about my machine, including seeing that I
have a machine whose mainboard is from MSI.

The utility seems to be called cpu-z and I can post the results if
needed. I am also willing to go through any lenghty test marathon to
get things supported on this Intel machine.

Just as a reminder, I still have this problem since the 2.6.24 days.


Thanks for your contact, Rog
Comment 41 ykzhao 2009-03-30 05:55:46 UTC
Hi, Rogerio
    Will you please do the test as required in comment #38 on the latest stable kernel and confirm whether the issue still exists?
   Thanks.
Comment 42 ykzhao 2009-06-09 02:28:04 UTC
Since there is no response for more than two months, the bug will be rejected.
If the issue still exists, please reopen it again and do the test as required in comment #38.
Thanks.
Comment 43 Rogério Brito 2009-06-09 04:51:59 UTC
Hi.

The notebook just got back from repair (the DVD drive had died). I am able to continue with the tests.

Unfortunately, it seems that I am unable to reopen the bug (the only options available to me are resolved and rejected). Please, do open this bug, as I still see the problem (just tested yesterday with a recent 2.6.30-rc8 kernel).

Regarding:

>     Will you please use the command of "echo mem > /sys/power/state; dmesg
> >dmesg_after; sync; reboot"?

Right. I didn't do the dmesg thing. I will do that now.

>    After the system enters the sleeping state, please press the power button.

Just to make it clear, the system shuts it off again. I can reproduce it with another video, just in case.
 
>    After the system is rebooted again, please check whether there exists the
> file of "dmesg_after".
>    If yes, please attach the output of dmesg_after. 

I will do that now, but I'm not really sure if there is any activity after the "echo mem > /sys/power/state".

BTW, I even tried the userland command s2ram (maintained by Rafael and Pavel) with the invocation:

s2ram -f -a 3

But it didn't work (read: the same results as earlier).
 
>    It is noted that you should kill the process which is using the
> /proc/acpi/event. 

OK, no problems killing anything that is using /proc/acpi/event. I will do that now. Let's see if we can get speedier now.


Regards, Rogério Brito.
Comment 44 Rogério Brito 2009-06-10 07:25:57 UTC
ykzhao,

Just followed the instructions in comment #38 and I'm left with *no* dmesg on my system.

Of course, nothing was using /proc/acpi/event (lsof reported acpid, which I killed and checked later to see if there was anything left).

I can proceed with any tests. Perhaps I can just film the computer again (this time, with a closer zoom) and show you people the weird behaviour that it has? I'm willing to do anything to get this box working fine under Linux.

Regards, Rogério Brito.
Comment 45 Rogério Brito 2009-06-10 07:29:00 UTC
ykzhao, I'm just resending this since it seems that you have not
received my earlier e-mails.

Please let me know if you did.

Regards.

On 6/10/09, bugzilla-daemon@bugzilla.kernel.org
<bugzilla-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11717
>
>
>
>
>
>
> --- Comment #44 from Rogério Brito <rbrito@ime.usp.br>  2009-06-10 07:25:57 ---
>  ykzhao,
>
>  Just followed the instructions in comment #38 and I'm left with *no* dmesg on
>  my system.
>
>  Of course, nothing was using /proc/acpi/event (lsof reported acpid, which I
>  killed and checked later to see if there was anything left).
>
>  I can proceed with any tests. Perhaps I can just film the computer again (this
>  time, with a closer zoom) and show you people the weird behaviour that it has?
>  I'm willing to do anything to get this box working fine under Linux.
>
>  Regards, Rogério Brito.
>
>
>  --
>  Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
>  ------- You are receiving this mail because: -------
>  You are on the CC list for the bug.
>  You reported the bug.
>
Comment 46 Rogério Brito 2009-06-16 10:36:17 UTC
Hi there.

Any news? Any further information that I can provide?

I still have an installation of Windows Vista in this notebook and I learned about a program called cpu-z that displays a lot of information about the hardware. I can provide that if desired.

I would sincerely welcome help with this notebook. There are some other minor issues that, collectively, with this suspend problem make me think that this was not a wise choice in getting an ICH8-based notebook. :-(

Anyway, it would be quite nice to have Linux working flawlessly on this computer, so that I can erase Windows (as I have no use for it).

If more information or tests are wanted, just let me know.

Please, help.


Regards, Rogério Brito.
Comment 47 Rogério Brito 2009-06-16 11:02:27 UTC
Oh, if it helps, I can put here the DSDT blob. Actually, I can do any amount of things.

Thanks in advance, Rogério Brito.
Comment 48 Rogério Brito 2009-06-22 17:44:45 UTC
Hi.

Since it seems that my reports are going nowhere, I have included some extra e-mails to the notification of this long-lasting bug. :-(

Regards, Rogério Brito.
Comment 49 Rogério Brito 2009-06-22 17:45:36 UTC
I am including some extra data here to speed up this debugging process.

Thanks.
Comment 50 Rogério Brito 2009-06-22 17:46:35 UTC
Created attachment 22047 [details]
Contents from /proc/acpi
Comment 51 Rogério Brito 2009-06-22 17:47:36 UTC
Created attachment 22048 [details]
New dmesg of the machine
Comment 52 Rogério Brito 2009-06-22 17:48:17 UTC
Created attachment 22049 [details]
output of dmidecode
Comment 53 Rogério Brito 2009-06-22 17:49:59 UTC
Created attachment 22050 [details]
original dsdt from the notebook
Comment 54 Rogério Brito 2009-06-22 17:50:30 UTC
Created attachment 22051 [details]
output from lshw
Comment 55 Rogério Brito 2009-06-22 17:51:04 UTC
Created attachment 22052 [details]
output from lsmod
Comment 56 Rogério Brito 2009-06-22 17:51:39 UTC
Created attachment 22053 [details]
a more verbose lspci output
Comment 57 Rogério Brito 2009-06-22 17:52:14 UTC
Created attachment 22054 [details]
output from uname -a
Comment 58 Rogério Brito 2009-06-28 11:53:03 UTC
Hi, people.

Is there anything further that I can report here? As always, I am willing to perform any sort of tests, even though the information that I put here is somewhat abundant (I think).

Thanks, Rogério Brito.
Comment 59 ykzhao 2009-07-20 14:33:22 UTC
Hi, Rogerio
    Sorry for the late response.
    Will you please enable the "CONFIG_DRM_I915_KMS" in kernel configuration and try the following test on the latest kernel(2.6.31-rc3)?
    a. boot the system into the console mode
    b. kill the proces using /proc/acpi/event(use the command of "lsof /proc/acpi/event" to get the process ID)
    c. echo mem > /sys/power/state; dmesg >dmesg_after; sync;
    d. press the power button and see whether the box can be resumed.
    e. if it can't be resumed, please reboot the box and see whether there file of dmesg_after.
    Thanks.
Comment 60 Rogério Brito 2009-07-22 06:59:58 UTC
Hi, ykzhao.

OK. I'm just git pulling Linus's tree and recompiling the kernel. I will enable the KMS option now (I'm selecting the options at this moment) and I will test whatever you want me to.

BTW, did you see the dstd data of this notebook, that I just sent? Does it help?

Thanks, Rogério Brito.
Comment 61 ykzhao 2009-07-22 07:53:30 UTC
(In reply to comment #60)
> Hi, ykzhao.
> 
> OK. I'm just git pulling Linus's tree and recompiling the kernel. I will enable
> the KMS option now (I'm selecting the options at this moment) and I will test
> whatever you want me to.
> 
Ok. thanks.
> BTW, did you see the dstd data of this notebook, that I just sent? Does it
> help?
The acpidump is already attached. 
Thanks.
> Thanks, Rogério Brito.
Comment 62 Rogério Brito 2009-07-22 08:37:32 UTC
Hi again.

OK, I just followed the instructions literally and I got no success. :-(

The notebook didn't resume *AND* there was *no* dmesg dump after I rebooted the system (would it really be able to generate a dmesg dump after "echo mem > /sys/power/state" is executed and the machine goes to sleep?).

Anyway, I can generate a better video than the one that I did the past year (it's sad that this bug is soon completing 1 year). Anyway, I can zoom the video so that it will be easier to see what I am doing and, more importantly, what is the result that I get.

Roughly, the result is as follows:

* the machine goes to sleep, staying with the light on the power button blinking;
* if I press the button, the notebook gives all symptoms of resuming;
* just when you think that it will wake up, it turns itself off;
* after 1 or 2 seconds, "powered off", it turns itself on again (yes, "out of the blue");
* after that, it hangs and the caps lock and scroll lock are both blinking, which leads me to think that this is a kernel panic (is that right?)

Any suggestions so that we can put an end to this story?

Unfortunately, this notebook goes to sleep perfectly well with the Windows Vista that is installed (and comes from sleep also reliably), but the fact is that I don't even know how to use Windows (I've been using one kind or another of Unix for the past decade and a half, at least).

Thanks for any help, Rogério Brito.
Comment 63 Rogério Brito 2009-07-22 08:44:46 UTC
Sorry, ykzhao.

I didn't understand your comment about the acpidump being available. Did you mean that it is enough to have it?

Oh, I don't know if this is related or not, but I see one other issue when I'm using this notebook:

Even though the pcspkr module is loaded, there are no beeps (contrary to, say, another Dell notebook that I have). The notebook seems to have only two loudspeakers and nothing else, but the alsa drivers don't show any control of the speaker.

Thanks for your help, Rogério Brito.
Comment 64 Rogério Brito 2009-07-22 08:48:07 UTC
Sorry, please disregard the last comment about alsa not showing the control of the speaker.

On the other hand, even if I remove the pcspkr module, the beeps with alsa seem to occur.

Regards, Rogério Brito.
Comment 65 ykzhao 2009-07-22 09:15:35 UTC
Hi, Rogerio
    Thanks for the info.
    >What I said in comment #61 is that you have already attached the output of acpidump. So it is unnecessary to attach it again.
   
    From your test it seems that the box can't be resumed from BIOS. 
    And if the BIOS is skipped by using "echo core > /sys/power/pm_test", it can be resumed.
    And now I have no idea to fix it.
    Thanks.
Comment 66 Rogério Brito 2009-08-12 04:06:07 UTC
Hi, people (and Zhao in particular).

I'm adding a CC to the people in linux-kernel as we may, perhaps, get  
some ideas of how to debug this year long bug.

On Jul 22, 2009, at 9:15 AM, ykzhao <yakui.zhao@intel.com> wrote:
>
>     From your test it seems that the box can't be resumed from BIOS.

Pardon me as I'm not sure how many ways to resume a box are. I'm not  
familiar with hardware matters.

>     And if the BIOS is skipped by using "echo core > /sys/power/ 
> pm_test", it
> can be resumed.

Well, this didn't work the last time I tested. Actually, just to  
recap, I have never gotten Linux to resume this notebook at all. With  
kernel modesetting, without, just booting with /bin/bash as init etc.

The unfortunate fact is that its warranty has just run out. I am  
really interested in getting it working, as I do need this for some  
development.

The sad thing is that Windows Vista that came pre-installed with it  
supports both suspend-to-ram and suspend-to-disk without any problems  
at all, but I'm not sure what to do, as I don't know how to use  
Windows (and I'm not really willing to learn a non-Unix Operating  
System). :-/

>     And now I have no idea to fix it.

I made sure that I bought a notebook with an intel chipset, but it  
seems that this isn't exactly sufficient to get a machine properly  
working with the kernel.

That being said, while I am not willing to learn how to work with  
Windows Vista, I am open to trying some, perhaps, invasive tests  
under Linux.

Well, actually, if there is any debugger/tracer/whatever that I could  
run under Windows Vista and that can reveal important information,  
then I'm ready to go.

Any ideas, anyone?


Thanks, Rogério Brito.
Comment 67 Rogério Brito 2009-08-12 04:11:38 UTC
Hi, Pavel and other people.

I'm just resurrecting this old bug (and everybody that was involved  
with it), as it's been quite some time now and I still have the exact  
same problems, unfortunately. :-(

(I wrote the comments below in the past year, but they are still valid).

On Nov 10 2008, Pavel Machek wrote:
>> FWIW, running radeon and s2ram
>> gives me a successful wakeup,
>> no delays only bluetooth-applet fails
>> to show back up as eye candy.

It seems that s2disk doesn't hang here, from a limited test, but I will
stress test this thing a bit further to see what is happening.

> So 2.6.28-rc3 actually works for you? Good ;-).

You were replying to Justin, just to make sure. :-) The attributions are
now completely messed up. :-)

Funnily, Ubuntu's intrepid doesn't have s2ram (I think that I'll grab it
from Debian for further testing).

(...)

If anybody has any idea on how to proceed, I would be thankful.


Thanks, Rogério Brito.

-- 
Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8
http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org
Comment 68 Justin P. Mattock 2009-08-12 04:31:14 UTC
Rogério Brito wrote:
> Hi, Pavel and other people.
>
> I'm just resurrecting this old bug (and everybody that was involved 
> with it), as it's been quite some time now and I still have the exact 
> same problems, unfortunately. :-(
>
> (I wrote the comments below in the past year, but they are still valid).
>
> On Nov 10 2008, Pavel Machek wrote:
>>> FWIW, running radeon and s2ram
>>> gives me a successful wakeup,
>>> no delays only bluetooth-applet fails
>>> to show back up as eye candy.
>
> It seems that s2disk doesn't hang here, from a limited test, but I will
> stress test this thing a bit further to see what is happening.
>
>> So 2.6.28-rc3 actually works for you? Good ;-).
>
> You were replying to Justin, just to make sure. :-) The attributions are
> now completely messed up. :-)
>
> Funnily, Ubuntu's intrepid doesn't have s2ram (I think that I'll grab it
> from Debian for further testing).
>
> (...)
>
> If anybody has any idea on how to proceed, I would be thankful.
>
>
> Thanks, Rogério Brito.
>
Sh^t forgot about this...
Anyways at the moment seems
the powerbutton does shutdown the system, and closing the
lid suspends the machine.(in the exception for an erb error from
bluetoooth which might be causing the delay(not sure yet)
works as is(kernel= latest git a week or so old).

At the moment I'm using acpid for these functions to work.
(keep in mind /etc/acpi/has my own commands in them
not any from a dist).
As for the suspend button I did e-mail the acpid maintainer, and
it seems their might not be a sleep button on the keyboard for
a macbook(143 or whatever the number is).  but you can adjust acpid to
react accordingly.

In response to the bug your just not getting a reaction to the keyboard
while its sleeping?(maybe the s* state needs to be changed for that,
but then again I could be wrong).

Justin P. Mattock
Comment 69 Rogério Brito 2009-08-20 02:54:11 UTC
Dear Zhang, and other people.

On Nov 11 2008, Rogério Brito wrote:
> Zhang Rui wrote:
> > let's focus on the suspend/resume problem in this bug entry.
> > So please stop using suspend button or lid button to do suspend/resume
> > test.
> > You can use "echo mem > /sys/power/state" to suspend and use power button
> > to resume to see how suspend/resume works on your laptop.
> 
> What I get when I use this is that the notebook goes to suspend state and
> the only button that it has (power button) has a blue light that starts
> blinking.

Zhang, you mentioned that you thought that my notebook could resume if
the BIOS is skipped, right?

Setting 

# echo 1 > /sys/power/pm_trace

I tested all the variations of:

# echo ??? > /sys/power/pm_test
# echo mem > /sys/power/state

that could be put into /sys/power/pm_test, but the notebook always
"resumed" ("woke up" from "sleep").

On the other hand, if I do a real sleep (say, putting none into
pm_test), then:

* the notebook goes to sleep;
* when I press the power button, the machine power itself off;
* a few seconds after that, it powers itself on again.

Unfortunately, at this point, *everything* is black in the monitor and
there are no responses (not even Magic SysRq).

The range of kernels tested was: 2.6.24 to 2.6.31-rc5.

As can be obviously seen from the kernels and the original report date,
this bug is more than one year old (it was filed with bugzilla on
2008-10-07).

Please, help.


Thanks, Rogério Brito.
Comment 70 ykzhao 2009-08-31 14:06:23 UTC
thanks for the test.
From the test it seems that the suspend/resume can work well if the BIOS is skipped by using "echo core/processors/devices > /sys/power/pm_test".
But it can't be resumed if the box is put to the suspended state.

Maybe this is related with the BIOS.

Now we have no idea about this bug. And this bug will be marked as the duplicate of bug11255.

thanks.

*** This bug has been marked as a duplicate of bug 11255 ***
Comment 71 Rafael J. Wysocki 2010-01-04 22:48:51 UTC
Rogerio, your machine contains an Intel graphics, so I'd like to check if that's related to the graphics.

Would you be able to test the 2.6.33-rc2 kernel (or better the current Linus' tree) with the KMS enabled in the graphics driver?
Comment 72 Rogério Brito 2010-01-05 03:18:40 UTC
Hi, Rafael.

On 01/04/2010 08:48 PM, bugzilla-daemon@bugzilla.kernel.org wrote:
> --- Comment #71 from Rafael J. Wysocki<rjw@sisk.pl>   2010-01-04 22:48:51 ---
> Rogerio, your machine contains an Intel graphics, so I'd like to check if
> that's related to the graphics.

Yes, exactly, an ICH8/965 graphics.

> Would you be able to test the 2.6.33-rc2 kernel (or better the current Linus'
> tree) with the KMS enabled in the graphics driver?

Sure. I'm git cloning his tree right now and will report back the results with 
both KMS on and off.


Thanks, Rogério Brito.
Comment 73 Rogério Brito 2010-01-06 00:10:55 UTC
Hi, Rafael.

I'm sorry for the delay in the response, but I had a network outage. :-(

Anyway, as I said earlier, I recompiled a kernel from Linus's git tree and enabled KMS with the i915 driver. I still can't wake the notebook.

I am attaching the dmesg of this boot and the configuration file that I'm using (please keep in mind that I just got Ubuntu's default configuration and stripped it down, but some of the options may not make sense, since I just disabled the bulkier parts---OK, that's peripheral, but I would like to keep things tidy). :-)

Anyway, I am going to reboot with KMS disabled now and I will report it after a new test.


Thanks, Rogério Brito.
Comment 74 Rogério Brito 2010-01-06 00:13:18 UTC
Created attachment 24456 [details]
dmesg of kernel 2.6.33-rc2
Comment 75 Rogério Brito 2010-01-06 00:15:54 UTC
Created attachment 24457 [details]
My current 2.6.33-rc2 config

This is the configuration that I'm using.

I can, of course, remove some features for the purpose of testing and narrowing it down.

Regards, Rogério Brito.
Comment 76 Rogério Brito 2010-01-06 21:26:25 UTC
Created attachment 24474 [details]
dmesg with KMS disabled

Hi, Rafael.

This is a dmesg of the machine with KMS disabled. It still doesn't work. :-(

Would it be a good thing to ask some people in the LKML to look at this issue, for some extra ideas?

Thanks, Rogério.
Comment 77 Rafael J. Wysocki 2010-01-06 22:27:56 UTC
(In reply to comment #76)
> Would it be a good thing to ask some people in the LKML to look at this issue,
> for some extra ideas?

I'm not sure if that's going to help, although someone may recall something I'm not aware of.

Please try to boot with acpi_sleep=sci_force_enable, that's known to make resume work on a number of boxes.
Comment 78 Rogério Brito 2010-01-06 22:37:10 UTC
Hi, Rafael.

(I'm sending it as a CC to your account, since I'm getting very long
delays with kernel.org's bugzilla---please let me know if this is a
problem with your).

On Wed, Jan 6, 2010 at 8:27 PM,  <bugzilla-daemon@bugzilla.kernel.org> wrote:
> --- Comment #77 from Rafael J. Wysocki <rjw@sisk.pl>  2010-01-06 22:27:56 ---
> (In reply to comment #76)
>> Would it be a good thing to ask some people in the LKML to look at this issue,
>> for some extra ideas?
>
> I'm not sure if that's going to help, although someone may recall something I'm
> not aware of.

OK, no problems then. Let's continue here dilligently.

> Please try to boot with acpi_sleep=sci_force_enable, that's known to make
> resume work on a number of boxes.

Right. I'm doing that now.

Thanks,

-- 
Rogério Brito : rbrito@{mackenzie,ime.usp}.br : GPG key 1024D/7C2CAEB8
http://www.ime.usp.br/~rbrito : http://meusite.mackenzie.com.br/rbrito
Projects: algorithms.berlios.de : lame.sf.net : vrms.alioth.debian.org
Comment 79 Rogério Brito 2010-01-06 23:03:36 UTC
Hi, Rafael.

(In reply to comment #77)
> Please try to boot with acpi_sleep=sci_force_enable, that's known to make
> resume work on a number of boxes.

OK. I just did that. I still did not help.

Just summarizing what I did with 2.6.33-rc2-00302-gc5974b8 (compiled the kernel with KMS enabled by default):

* booted with full Ubuntu userspace, with KMS enabled.
* booted with full Ubuntu userspace, with KMS disabled (i915.modeset=0).
* booted with minimal userspace (init=/bin/bash), with KMS enabled.
* booted with minimal userspace, with KMS enabled and acpi_sleep=sci_force_enable.

For each of these possibilities, when I pressed the sleep button or echo'ed mem to /sys/power/state, I got the system on a sleep state, but upon resuming with the powerbutton, the system was frozen, as in the video that I posted.

There possibilities above are not exaustive, and I can test other settings to. I'm keeping with kernel 2.6.33-rc2-00302-gc5974b8 for the time being, so that we don't use a moving target. (Of course, I can try any patch here that you might want me to).

(Gee, I wish that I had a way to ship this machine to you).

I will continue testing with the pm_trace things, now.


Thanks,
Comment 80 Rogério Brito 2010-01-06 23:33:07 UTC
Hi again, Rafael.

On Jan 06 2010, bugzilla-daemon@bugzilla.kernel.org wrote:
> There possibilities above are not exaustive, and I can test other settings to.
> I'm keeping with kernel 2.6.33-rc2-00302-gc5974b8 for the time being, so that
> we don't use a moving target. (Of course, I can try any patch here that you
> might want me to).

I just noticed that 2.6.33-rc3 was released. I don't see any changes in

,----
| git shortlog --no-merges c5974b8..v2.6.33-rc3
`----

that seem to be relevant here, but I can update it to use a known kernel
and to stay in sync with you. (I don't see any up to c6f7afae, either,
which seems to be the most recent).


Thanks again,
Comment 81 Rafael J. Wysocki 2010-01-07 00:00:47 UTC
PM_TRACE won't give you any additional information if it fails before resuming devices.

BTW, I get "404 Not Found" when trying to follow the link to your video in comment #35.
Comment 82 Rogério Brito 2010-01-07 00:13:38 UTC
Hi, Rafael.

On Jan 07 2010, bugzilla-daemon@bugzilla.kernel.org wrote:
> --- Comment #81 from Rafael J. Wysocki <rjw@sisk.pl>  2010-01-07 00:00:47 ---
> PM_TRACE won't give you any additional information if it fails before resuming
> devices.

Yes. There is something weird here. I wish that I could piggyback it
here (I'm not sure if a serial console would help me here).

> BTW, I get "404 Not Found" when trying to follow the link to your video in
> comment #35.

Ooops. Sorry. I had deleted that video. Please, try to see
http://rb.doesntexist.org/linux/defective.ogv instead.

(It may happen that the server cut the download in the middle---I don't
know why, but just resume it and it should be fine).


Thanks for your kind assistance,
Comment 83 Rafael J. Wysocki 2010-01-07 22:25:43 UTC
(In reply to comment #82)
...
> Ooops. Sorry. I had deleted that video. Please, try to see
> http://rb.doesntexist.org/linux/defective.ogv instead.

I don't seem to have a codec capable of playing this one installed here.

Could you just generate JPEGs out of this?
Comment 84 Rafael J. Wysocki 2010-12-29 23:55:08 UTC
Please test 2.6.37-rc8 and report back.
Comment 85 Zhang Rui 2011-04-19 07:44:46 UTC
bug closed as there is no response from the bug reporter.
please re-open it if the problem still exists in the latest upstream kernel.
Comment 86 Rogério Brito 2011-04-19 16:03:16 UTC
Hey, just a ping here would do wonders. :-)

The problem still exists with Linus' git tree. Do you want me to do another round of data collection?

Oh, just for the record, my wife has a subsequent model of this notebook (it's a notebook that her workplace has allowed her to use) and *that* computer sleeps without any problems.

BTW, after further use of this notebook, I have discovered many other power-related quirks. For instance, if I (accidentally or not) disconnect the power from the mains outlet, the notebook will get stuck with both CPU cores at the lowest frequency (in this case, 800MHz), despite me:

* changing the governor (ondemand, performance, powersave etc.---you name it, it won't put back the frequency to 2.0GHz);
* putting back the power won't do and I still only get 800MHz.

A simple reboot cures this problem. The (still existent) Windows Vista install doesn't have this problem, for whatever reason.

OK, I can give many details more, but I will answer upon you asking me for further information.


Thanks,
Rogério Brito.
Comment 87 Zhang Rui 2011-04-20 01:58:33 UTC
(In reply to comment #86)
> Hey, just a ping here would do wonders. :-)
> 
> The problem still exists with Linus' git tree. Do you want me to do another
> round of data collection?
> 
that would be great.

First, please build your kernel with CONFIG_ACPI_DEBUG set, and uncomment line 30, i.e. "/* #define DEBUG */", in drivers/acpi/ec.c,
and then run
echo core > /sys/power/pm_test
echo mem > /sys/power/state
in the new kernel, and attach the dmesg output after this test.

> Oh, just for the record, my wife has a subsequent model of this notebook (it's
> a notebook that her workplace has allowed her to use) and *that* computer
> sleeps without any problems.
> 
what's the model name of this notebook?
do they share the same BIOS image?
can you check if there is any BIOS update for your laptop?

> BTW, after further use of this notebook, I have discovered many other
> power-related quirks. For instance, if I (accidentally or not) disconnect the
> power from the mains outlet, the notebook will get stuck with both CPU cores at
> the lowest frequency (in this case, 800MHz), despite me:
> 
> * changing the governor (ondemand, performance, powersave etc.---you name it,
> it won't put back the frequency to 2.0GHz);
> * putting back the power won't do and I still only get 800MHz.
> 
> A simple reboot cures this problem. The (still existent) Windows Vista install
> doesn't have this problem, for whatever reason.
> 
this sounds a real problem.
please file a new bug report for this issue only.
and attach the output of
"grep . /sys/devices/system/cpu/cpu*/cpufreq/*" both before and after unplugging the AC adapter.
Comment 88 Rogério Brito 2011-04-22 09:45:30 UTC
Created attachment 55002 [details]
Output from acpidump

Just in case it is useful, I am including the compressed output of acpidump.
Comment 89 Rogério Brito 2011-04-22 09:47:21 UTC
Created attachment 55012 [details]
Compressed dmesg from before the test
Comment 90 Rogério Brito 2011-04-22 09:49:34 UTC
Created attachment 55022 [details]
Compressed dmesg from after the test

Here is the (compressed) dmesg log right after the test finishes.

I don't know if this is expected or not, but the notebook does come back after a test, but fails to do so with a real sleep.

If more information is needed, please let me know.
Comment 91 Zhang Rui 2011-04-25 08:50:52 UTC
what if you run "echo mem > /sys/power/state" to suspend and press the power button to wakeup? does the system still power down?
Comment 92 Rogério Brito 2011-04-28 05:41:06 UTC
Dear Zhang and others.

Sorry for not replying earlier. I will try to be speedier, so that we can kill this bug for good.

(In reply to comment #91)
> what if you run "echo mem > /sys/power/state" to suspend and press the power
> button to wakeup? does the system still power down?

Unfortunately, the tests work fine (read: they do come back normally), but the actual switch of stages (sleeping -> waking up) doesn't.

Just as further information, I took the time to create a video of what I see when I "echo mem > /sys/power/state" on my homepage. It is here:

    http://www.ime.usp.br/~rbrito/linux/itautec-n8320-sleep-problems.webm

I hope that this is illustrative of the problem that I am seeing. If any further information is needed, please let me know.

Oh, BTW, I still have this Windows Vista partition here (which I want to get rid of, since it is mostly useless to me, as I have not used DOS/Windows in the last 17 years and I don't see any value in that, aside of reverse-engineering it to make Linux work out of the box).

What all this means is that I am willing to install some development/debugging tools under Windows so that I can provide dumps, logs, etc. to get the Linux kernel to work even with quiky hardware (which is, unfortuately, not unheard of).

Unfortunately, Intel's http://biosbits.org/ (which, among other things, claims to be able to set the BIOS parameters to sane defaults before booting a kernel) says that my Core 2 Duo system is "unknown", which means that we have one fewer tool at our disposal.

Do you happen to have any contacts with (or are one of the) people from that project? I am willing to run many experiments here to get things straight on this system.

Please, note how many times I have used something like "I am willing to" in the paragraphs above. This does mean that I would like to put an end to this saga, as this is beginning to become uncomfortable.

I can even give a shot in the dark and try to see, say, FreeBSD's behaviour when it comes to suspend/resume, for comparison purposes.

OK, this was way longer than what you asked, but I hope that this gives a clearer picture of:

* the behaviour that I see since kernels circa. 2.6.24.
* my willingness to provide as much data as possible to solve this. It must be possible. It, after all, works under Windows Vista and that very same recipe should be appliable to other operating systems.

Oh, one last point. Perhaps disassembling the ACPI tables would be in order to debug? Unfortunately, I don't know the language that they are in, but could you help there?


Thanks in advance for any help,
Rogério Brito.
Comment 93 Rogério Brito 2011-05-06 01:47:49 UTC
Hi.

OK, I realize that I wrote a whole novel in comment #92, but if there is anything else that I could provide, I would be glad to help, as this bug limits somewhat my use of this notebook.

Thanks,

Rogério Brito.
Comment 94 Zhang Rui 2012-01-18 01:37:33 UTC
It's great that kernel bugzilla is back.

can you please verify if the problem still exists in the latest upstream kernel?
Comment 95 Thomas Mudrunka 2012-01-21 04:16:10 UTC
Well. isn't it better to use different key for waking up? I think this can cause regressions of such bugs:
https://bugzilla.kernel.org/show_bug.cgi?id=16512
Comment 96 Thomas Mudrunka 2012-01-21 04:20:26 UTC
BTW My laptop had suddenly woken up without a reason several times when i've been travelling which is not very comfortable. I'd prefer reliable suspend over having one more button to wake up the system (when i can use any other key to wake it up).
Comment 97 Alan 2012-11-20 17:12:25 UTC
Closing as obsolete, if this is still seen with modern kernels please re-open and update
Comment 98 Rogério Brito 2012-11-20 17:27:45 UTC
Hi, Alan.

(In reply to comment #97)
> Closing as obsolete, if this is still seen with modern kernels please re-open
> and update

This still happens, at least with kernel 3.6.6. This happens since 2.6.24, at least.

Running out of ideas, I even decided to install newer microcode for the processor and, sure enough, I still get the same behavior as before.

If there is any kind of information that you would like me to provide, please let me know.


Thanks,

Rogério Brito.
Comment 99 Aaron Lu 2013-02-28 04:08:50 UTC
Hi Rog,

Just some crazy thoughts:
What would happen after you press the power button while the system is running? Will it shut down? If so, can you please try WOL to resume the system? Thanks.
Comment 100 Rogério Brito 2013-02-28 04:29:16 UTC
Hi, Aaron.

On Thu, Feb 28, 2013 at 1:08 AM,  <bugzilla-daemon@bugzilla.kernel.org> wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=11717
> --- Comment #99 from Aaron Lu <aaron.lu@intel.com>  2013-02-28 04:08:50 ---
> Hi Rog,
>
> Just some crazy thoughts:
> What would happen after you press the power button while the system is running?
> Will it shut down? If so, can you please try WOL to resume the system? Thanks.

I will try that as soon as I get the notebook (I'm using my wife's at
this moment). I will report back.


Thanks for caring about this luser, :)

Rogério.

-- 
Rogério Brito : rbrito@{ime.usp.br,gmail.com} : GPG key 4096R/BCFCAAAA
http://rb.doesntexist.org/blog : Projects : https://github.com/rbrito/
DebianQA: http://qa.debian.org/developer.php?login=rbrito%40ime.usp.br
Comment 101 Aaron Lu 2013-07-05 01:17:35 UTC
Hi Rog,

Are you still bothered by this bug?
Comment 102 Rogério Brito 2013-07-05 10:38:06 UTC
Hi, Aaron,

On Thu, Jul 4, 2013 at 10:17 PM,  <bugzilla-daemon@bugzilla.kernel.org> wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=11717
>
> --- Comment #101 from Aaron Lu <aaron.lu@intel.com> ---
> Hi Rog,
>
> Are you still bothered by this bug?

Unfortunately, yes. Do you want me to test anything?


Thanks a lot,
Comment 103 Aaron Lu 2013-07-06 05:17:40 UTC
Yes, did you try wake on Lan?
Comment 104 Rogério Brito 2013-07-06 11:40:06 UTC
Hi, Aaron.

On Sat, Jul 6, 2013 at 2:17 AM,  <bugzilla-daemon@bugzilla.kernel.org> wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=11717
>
> --- Comment #103 from Aaron Lu <aaron.lu@intel.com> ---
> Yes, did you try wake on Lan?

No, I didn't try this specifically, but I think that the machine
enters a kernel panic with the screen being black and some leds
blinking. Do you want me to post a video on youtube, so that you can
see the behavior that I see?

Thanks,
Comment 105 Aaron Lu 2013-07-09 06:06:13 UTC
It's very difficult to dig useful information through 104 comments now, can you please file a new bug and provide all kinds of information like acpidump, dmesg, whether PM test works or not, the resume failure symptoms etc. there? Thanks.
Comment 106 Zhang Rui 2013-10-14 08:05:24 UTC
it seems that we need a ping here. :)
Rogério Brito,
can you please file a new bug report as request by Aaron?
thanks!
Comment 107 Rogério Brito 2014-03-23 11:54:36 UTC
Hi there.

I accidentaly discovered (after always using hibernation instead of sleep) that, with kernel 3.13, my notebook is able to come back from sleep. I suspect that this may have been fixed between, say, kernels 3.7 and 3.13, but I don't actually know what was the commit that fixed the problem.

Would it be of interest to know which commit fixed the problems that I had? If so, I think that I can spend a few hours compiling kernels and rebooting things.


Thanks,

Rogério.
Comment 108 Len Brown 2014-10-28 05:14:33 UTC
sounds like this bug went away at some point...
No, I don't think we need to know why, but thanks.

Note You need to log in before you can comment on or make changes to this bug.