Bug 11695 - USB disconnects every 30 seconds
USB disconnects every 30 seconds
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-10-04 10:49 UTC by Rafael J. Wysocki
Modified: 2008-10-05 15:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-10-04 10:49:38 UTC
Subject    : USB disconnects every 30 seconds (2.6.27-rc8)
Submitter  : Dave Hansen <dave@sr71.net>
Date       : 2008-10-03 17:45
References : http://marc.info/?l=linux-kernel&m=122305738430115&w=4
Handled-By : Alan Stern <stern@rowland.harvard.edu>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-10-05 15:21:44 UTC
On Sunday, 5 of October 2008, Dave Hansen wrote:
> On Sun, 2008-10-05 at 15:16 -0400, Alan Stern wrote:
> > That file is the usbmon log from back on Friday.  I need to see the
> > usbmon log you get with the timing fix installed.  Was that not clear?  
> > Without the log, I can't tell why the disconnects continue to occur
> > even though the timing fix should have eliminated them.
> 
> It looks like I didn't properly apply the timing fix when I said I did
> last time.  With Thomas/Hugh's fix applied, I don't see the disconnects
> any more.  I'll keep an eye out and let everyone know if they reappear.
> 
> Thanks for all the excellent debugging, everyone!


Note You need to log in before you can comment on or make changes to this bug.