Bug 11669 - when CPU hotplugging is disabled, nr_cpu_ids does not get set properly during boot
when CPU hotplugging is disabled, nr_cpu_ids does not get set properly during...
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-09-29 11:40 UTC by Chuck Ebbert
Modified: 2008-10-26 15:14 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc7-git5
Tree: Mainline
Regression: Yes


Attachments
Patch to revert commit 4a7017370aa0a94a00ae5b5705e9169cdcae5fb8 (942 bytes, patch)
2008-09-29 11:40 UTC, Chuck Ebbert
Details | Diff
Patch to fix the nr_cpu_ids problem properly (2.99 KB, patch)
2008-09-29 11:41 UTC, Chuck Ebbert
Details | Diff

Description Chuck Ebbert 2008-09-29 11:40:06 UTC
caused by commit 4a7017370aa0a94a00ae5b5705e9169cdcae5fb8, which was the wrong fix for a compile error

With NR_CPUS set to 512 and CPU hotplug disabled, nr_cpu_ids gets set to 512 during boot on a uniprocessor machine.

Patches to fix this follow.
Comment 1 Chuck Ebbert 2008-09-29 11:40:54 UTC
Created attachment 18105 [details]
Patch to revert commit 4a7017370aa0a94a00ae5b5705e9169cdcae5fb8

Patch 1/2
Comment 2 Chuck Ebbert 2008-09-29 11:41:53 UTC
Created attachment 18106 [details]
Patch to fix the nr_cpu_ids problem properly

Patch 2/2
Comment 3 Andrew Morton 2008-10-03 00:02:39 UTC
grump.  please don't send patches via bugzilla - they're a pita to
process.
Comment 4 Adrian Bunk 2008-10-08 05:14:11 UTC
Subject         : when CPU hotplugging is disabled, nr_cpu_ids does not get set properly during boot
Submitter       : Chuck Ebbert <cebbert@redhat.com>
References      : http://bugzilla.kernel.org/show_bug.cgi?id=11669
Handled-By      : Chuck Ebbert <cebbert@redhat.com>
Patch           : http://bugzilla.kernel.org/attachment.cgi?id=18105
                  http://bugzilla.kernel.org/attachment.cgi?id=18106
Comment 5 Rafael J. Wysocki 2008-10-26 15:14:00 UTC
Fixed by commit 14adf855baefad5ac3b545be23a64e6b61d6b74a.

Note You need to log in before you can comment on or make changes to this bug.