Bug 11664 - acpi errors and random freeze on sony vaio sr
Summary: acpi errors and random freeze on sony vaio sr
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: EC (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Alexey Starikovskiy
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-09-28 03:48 UTC by Giovanni Pellerano
Modified: 2008-12-13 10:49 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27 RC7
Tree: Mainline
Regression: Yes


Attachments
dmesg output (60.62 KB, text/plain)
2008-09-28 03:52 UTC, Giovanni Pellerano
Details
ACPI DSDT (280.71 KB, text/plain)
2008-09-28 04:07 UTC, Giovanni Pellerano
Details
Kernel 2.6.27 rc7 config (52.92 KB, text/plain)
2008-09-28 04:08 UTC, Giovanni Pellerano
Details
acpi dump output on sony vaio sr19xn (168.18 KB, application/octet-stream)
2008-11-02 11:38 UTC, Giovanni Pellerano
Details
Fix ACPI battery regression (1009 bytes, patch)
2008-12-04 15:12 UTC, Rafael J. Wysocki
Details | Diff

Description Giovanni Pellerano 2008-09-28 03:48:33 UTC
Latest working kernel version:
Earliest failing kernel version:
Distribution:
Hardware Environment:
Software Environment:
Problem Description:

Steps to reproduce:
Comment 1 Giovanni Pellerano 2008-09-28 03:52:42 UTC
Created attachment 18090 [details]
dmesg output
Comment 2 Rafael J. Wysocki 2008-09-28 04:01:27 UTC
Can you check if this is a regression from 2.6.26(.x), please?
Comment 3 Giovanni Pellerano 2008-09-28 04:04:03 UTC
ok sey to me wat versione to try;

linux-2.6.26.5 ?
Comment 4 Giovanni Pellerano 2008-09-28 04:07:49 UTC
Created attachment 18091 [details]
ACPI DSDT
Comment 5 Giovanni Pellerano 2008-09-28 04:08:51 UTC
Created attachment 18092 [details]
Kernel 2.6.27 rc7 config
Comment 6 Rafael J. Wysocki 2008-09-28 04:09:40 UTC
(In reply to comment #3)
> ok sey to me wat versione to try;
> 
> linux-2.6.26.5 ?

That will be fine.
Comment 7 Giovanni Pellerano 2008-09-28 04:29:41 UTC
ok i'm testing it now;

if it will work as in your opinion what i've to do? 

have i to give you some others output? what additional information are useful ? 
Comment 8 Giovanni Pellerano 2008-09-28 11:58:34 UTC
ok i've tested some hours and it seems a regression of the 2.6.27;

but what to do now to be sure and to individuate the exact problem ? 

give to me all the instructions you need.

thanks
Comment 9 Rafael J. Wysocki 2008-09-28 15:30:35 UTC
Thanks for testing, I'm adding this bug to the list of recent regressions.

If it's 100% reproducible, I think you can try to use git bisection to identify the commit that introduced the problem.
Comment 10 ykzhao 2008-10-03 05:25:04 UTC
Hi, Giovanni
    Do you mean that the box can work well on 2.6.26.5 kernel while it fails on 2.6.27-rc7 kernel? right?
    Will you please attach the output of acpidump?
    Will you please try the following boot option and see whether the system can work well?
    a. idle=poll
    b. processor.max_cstate=1(processor should be compiled as built-in kernel)
    c. nolapic_timer
    d. nohz=off(disable tickless feature)
    Thanks.
Comment 11 Giovanni Pellerano 2008-10-03 08:08:59 UTC
ok i will try in the week-end;

in the last week the problem seems solved automagically, but i dont think it so much cause of the random factor.

thanks
Comment 12 Zhang Rui 2008-10-29 19:25:35 UTC
giovanni, any update?
Comment 13 Giovanni Pellerano 2008-10-30 00:28:08 UTC
mmm ... now i'm using 2.6.28-rc2-git3 and i did not have any freeze... 


i did not have system freeze but sometimes the acpi stop to work with some errors like:

ACPI Exception (evregion-0419): AE_TIME, Returned by Handler for [EmbeddedControl] [20080926]
ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.BAT0._BST] (Node f701be40), AE_TIME
ACPI Exception (battery-0360): AE_TIME, Evaluating _BST [20080926]


or like

acpid: executing action "/etc/acpi/default.sh battery BAT0 00000080 00000001"
Oct 29 18:00:38 infectedsynapsis logger: ACPI event unhandled: battery BAT0 00000080 00000001
acpid: action exited with status 0
acpid: executing action "/etc/acpi/actions/lm_battery.sh battery BAT0 00000080 00000001"
ACPI: EC: missing confirmations, switch off interrupt mode.
Oct 29 18:00:39 infectedsynapsis ACPI Exception (evregion-0419): AE_TIME, Returned by Handler for [EmbeddedControl] [20080926]
ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.BAT0._STA] (Node f701be10), AE_TIME
ACPI Exception (battery-0310): AE_ERROR, Evaluating _STA [20080926]



can you give information about the test to do on this kernel?
what information do you need? 

thanks
Comment 14 Rafael J. Wysocki 2008-11-02 10:58:55 UTC
Please attach the output of acpidump as requested in comment #10.
Comment 15 Giovanni Pellerano 2008-11-02 11:38:12 UTC
Created attachment 18596 [details]
acpi dump output on sony vaio sr19xn
Comment 16 Alan Jenkins 2008-11-02 11:44:37 UTC
I think this latter issue is the same EC problem as reported by Darren Salt on the acpi-devel list.  It was confirmed fixed by

Patch: <http://marc.info/?l=linux-acpi&m=122514341319748&w=4>
Comment 17 Giovanni Pellerano 2008-11-15 05:57:24 UTC
no. :(

i'm using 2.6.28-rc4-git5 on a sony vaio sr19xn and the proplem persist :(

any assumption?
Comment 18 Rafael J. Wysocki 2008-11-16 11:03:31 UTC
Notify-Also : Zhang Rui <rui.zhang@intel.com>
Notify-Also : ykzhao <yakui.zhao@intel.com>
Comment 19 Giovanni Pellerano 2008-11-16 14:58:04 UTC
Rafael, what does this last post mean?

thanks
Comment 20 Rafael J. Wysocki 2008-11-16 17:20:34 UTC
This is for the tracking of regressions, who should be sent the automatically generated messages (in addition to the reporter etc.).
Comment 21 Giovanni Pellerano 2008-11-22 15:27:18 UTC
Any Update?

I continue to have the problem on 2.6.28-rc5-git4;

Can i help you doing some tests? 
Comment 22 Zhang Rui 2008-11-23 18:55:50 UTC
the problem still exists in the latest git tree?
I don't know the recent updates of ec driver.
re-assign to Alexey. :)
Comment 23 Rafael J. Wysocki 2008-12-03 16:14:59 UTC
Ignore-Patch : <http://marc.info/?l=linux-acpi&m=122514341319748&w=4>
Comment 24 Rafael J. Wysocki 2008-12-03 16:15:32 UTC
Giovanni, please check 2.6.28-rc7, it contains some important ACPI fixes.
Comment 25 Giovanni Pellerano 2008-12-04 08:53:50 UTC
Thanks Rafael. I'm testing this importans ACPI fixes.

At the moment i did not have the error, but instead I got a lot of other problem =) the battery indicator sometime says me i've 0.1hour of battery [when the battery is fully charges.. sometimes it says that i've 10h of autonomy [when i've 4h max]

do you need some information ? 
Comment 26 Rafael J. Wysocki 2008-12-04 15:12:42 UTC
Created attachment 19149 [details]
Fix ACPI battery regression

Please check if this patch on top of 2.6.28-rc7 fixes the ACPI battery times problem.
Comment 27 Giovanni Pellerano 2008-12-05 10:16:13 UTC
ok now i'm goin to test it.

with the git 3 i get always: 

ACPI: EC: GPE storm detected, transactions will use polling mode
ACPI: EC: missing confirmations, switch off interrupt mode.
Comment 28 Len Brown 2008-12-12 15:19:05 UTC
Giovanni,
Is this battery issue still present in 2.6.28-rc8?

Linus reverted some commits to battery.c for that release.
Comment 29 Giovanni Pellerano 2008-12-13 01:38:02 UTC
the remain battery information is now fixed [reverted]

but i always get this:

ACPI: EC: missing confirmations, switch off interrupt mode.
ACPI Exception (evregion-0419): AE_TIME, Returned by Handler for [EmbeddedControl] [20080926]
ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.BAT0._BST] (Node f701be40), AE_TIME
ACPI Exception (battery-0359): AE_TIME, Evaluating _BST [20080926]
Comment 30 Rafael J. Wysocki 2008-12-13 10:49:50 UTC
Please file another bug report for this issue.  I'm closing this one since the original problem appears to have been fixed.

Note You need to log in before you can comment on or make changes to this bug.