Bug 11660 - ACPI Error: No handler for Region, Method execution failed, hang on reboot
Summary: ACPI Error: No handler for Region, Method execution failed, hang on reboot
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: ykzhao
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-27 07:08 UTC by Eugeny Shkrigunov
Modified: 2008-10-27 19:19 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc7
Tree: Mainline
Regression: ---


Attachments
kernel config (56.50 KB, text/plain)
2008-09-27 07:10 UTC, Eugeny Shkrigunov
Details
output of acpitool -e (2.02 KB, text/plain)
2008-09-27 07:11 UTC, Eugeny Shkrigunov
Details
dmesg (29.13 KB, text/plain)
2008-09-27 07:11 UTC, Eugeny Shkrigunov
Details
output of dmidecode (12.95 KB, text/plain)
2008-09-27 07:11 UTC, Eugeny Shkrigunov
Details
output of acpidump (89.09 KB, text/plain)
2008-09-28 07:01 UTC, Eugeny Shkrigunov
Details
dmesg after patch from http://bugzilla.kernel.org/show_bug.cgi?id=11374#C6 (27.49 KB, text/plain)
2008-09-28 07:08 UTC, Eugeny Shkrigunov
Details

Description Eugeny Shkrigunov 2008-09-27 07:08:02 UTC
Distribution: CentOS 5.2
Hardware Environment: MSI PR210-052
Problem Description:
No battery status, hang on reboot

Steps to reproduce:
build kernel 2.6.27-rc7 and boot to it
Comment 1 Eugeny Shkrigunov 2008-09-27 07:10:38 UTC
Created attachment 18071 [details]
kernel config
Comment 2 Eugeny Shkrigunov 2008-09-27 07:11:03 UTC
Created attachment 18072 [details]
output of acpitool -e
Comment 3 Eugeny Shkrigunov 2008-09-27 07:11:29 UTC
Created attachment 18073 [details]
dmesg
Comment 4 Eugeny Shkrigunov 2008-09-27 07:11:44 UTC
Created attachment 18074 [details]
output of dmidecode
Comment 5 Andrew Morton 2008-09-27 15:20:39 UTC
Did any earlier kernel work OK?  If so, which version(s)?

Thanks.
Comment 6 ykzhao 2008-09-27 17:56:31 UTC
Will you please attach the output of acpidump?
thanks.
Comment 7 ykzhao 2008-09-27 18:06:14 UTC
Hi, Eugeny
    It seems that there exist two issues on your box:
    a. ACPI Error:
       This problem is related with the BIOS.
       Please try the patch in http://bugzilla.kernel.org/show_bug.cgi?id=11374#C6.
    
    b. hang on reboot:
       Can you confirm whether the box always hang while reboot on all the version kernel?
       Can you confirm whether the system can be rebooted normally on windows?
    
    thanks.

       
Comment 8 Eugeny Shkrigunov 2008-09-28 07:01:34 UTC
Created attachment 18094 [details]
output of acpidump
Comment 9 Eugeny Shkrigunov 2008-09-28 07:07:00 UTC
Seems there is no reboot problem, at list in runlevel 3.
I am try patch http://bugzilla.kernel.org/show_bug.cgi?id=11374#C6
and no error appear.
dmesg in the attachment
Thank you.
Comment 10 Eugeny Shkrigunov 2008-09-28 07:08:09 UTC
Created attachment 18095 [details]
dmesg after patch from http://bugzilla.kernel.org/show_bug.cgi?id=11374#C6
Comment 11 ykzhao 2008-10-05 19:29:05 UTC
Hi, Eugeny
    If there is no reboot problem in runlevel 3, it seems that "hang on reboot" is  not related with ACPI. 
    After the patch is applied, there is no warning message. In fact it is harmless but confusing. And the problem can be fixed by the patch in
    http://bugzilla.kernel.org/show_bug.cgi?id=11374#C6
    
    According to the problem description it seems that there exists another issue(No battery status).
    Can you confirm whether the problem still exists?
    Thanks.
Comment 12 Eugeny Shkrigunov 2008-10-06 10:22:42 UTC
It seems the problem with battery status does not disappear. Output of acpidump, acpitool the same as in attachments above.
Comment 13 ykzhao 2008-10-10 00:14:37 UTC
Please attach the output of "cat /proc/acpi/battery/*/* " after the system is booted.
Thanks.
Comment 14 Eugeny Shkrigunov 2008-10-10 10:51:49 UTC
Sorry, there is no such dir: /proc/acpi/battery, only
find /proc/acpi | sort
/proc/acpi
/proc/acpi/button
/proc/acpi/button/lid
/proc/acpi/button/lid/LID0
/proc/acpi/button/lid/LID0/info
/proc/acpi/button/lid/LID0/state
/proc/acpi/button/power
/proc/acpi/button/power/PWRB
/proc/acpi/button/power/PWRB/info
/proc/acpi/button/power/PWRF
/proc/acpi/button/power/PWRF/info
/proc/acpi/embedded_controller
/proc/acpi/embedded_controller/EC
/proc/acpi/embedded_controller/EC/info
/proc/acpi/power_resource
/proc/acpi/processor
/proc/acpi/processor/P001
/proc/acpi/processor/P001/info
/proc/acpi/processor/P001/limit
/proc/acpi/processor/P001/power
/proc/acpi/processor/P001/throttling
/proc/acpi/processor/P002
/proc/acpi/processor/P002/info
/proc/acpi/processor/P002/limit
/proc/acpi/processor/P002/power
/proc/acpi/processor/P002/throttling
/proc/acpi/thermal_zone
/proc/acpi/thermal_zone/THRM
/proc/acpi/thermal_zone/THRM/cooling_mode
/proc/acpi/thermal_zone/THRM/polling_frequency
/proc/acpi/thermal_zone/THRM/state
/proc/acpi/thermal_zone/THRM/temperature
/proc/acpi/thermal_zone/THRM/trip_points
/proc/acpi/wakeup
Comment 15 ykzhao 2008-10-24 00:41:24 UTC
From the dmesg it seems that there exists the following message:
    >ACPI: Battery Slot [BAT1] (battery present)
    
    It means that the battery is detected. The problem is that there is no battery status. Maybe it is related with the kernel configuration.
    Will you please enable the CONFIG_ACPI_PROCFS_POWER/CONFIG_ACPI_SYSFS_POWER in kernel configuration and see whether the issue about the battery status still exists?
    As OS reports that the battery is detected, IMO there exists the battery status if you enable the CONFIG_ACPI_PROCFS_POWER in kernel configuration.
    Thanks.
    
Comment 16 Len Brown 2008-10-24 23:20:42 UTC
shipped in linux-2.6.28-rc1:

commit 455c8793d2c49eaecad038c8de83dade9fc3759f
Author: Zhao Yakui <yakui.zhao@intel.com>
Date:   Mon Oct 6 10:31:36 2008 +0800

    ACPI: Enable EC device immediately after ACPI full initialization
Comment 17 Eugeny Shkrigunov 2008-10-25 02:34:41 UTC
(In reply to comment #15)
>     Will you please enable the
>     CONFIG_ACPI_PROCFS_POWER/CONFIG_ACPI_SYSFS_POWER

After CONFIG_ACPI_PROCFS_POWER enable(sorry, was disabled because "Deprecated power /proc/acpi directories" in kernel make menuconfig) /proc/acpi/battery apper and output of cat /proc/acpi/battery/*/*
alarm:                   unsupported
present:                 yes
design capacity:         5200 mAh
last full capacity:      4958 mAh
battery technology:      rechargeable
design voltage:          14800 mV
design capacity warning: 0 mAh
design capacity low:     0 mAh
capacity granularity 1:  1 mAh
capacity granularity 2:  1 mAh
model number:            MS-1222

serial number:

battery type:            LION

OEM info:                MSI Corp.

present:                 yes
capacity state:          ok
charging state:          charged
present rate:            0 mA
remaining capacity:      4928 mAh
present voltage:         16567 mV


Looks like all fine. Thank you very much. Problem with reboot seems related to ATI proprietary GPU driver. And with patch  http://bugzilla.kernel.org/show_bug.cgi?id=11374#C6 no more hang on booting with EC errors.
Comment 18 ykzhao 2008-10-26 22:12:29 UTC
Thanks for the test.
   Now it seems that the battery is also OK after the CONFIG_ACPI_PROCFS_POWER is enabled in kernel configuration. 
   And after applying the patch in comment #16, the warning message disappears.
   So the bug will be marked as resovled(CODE_FIX).
   Thanks.

Note You need to log in before you can comment on or make changes to this bug.