Bug 11656 - touchpad (and sometimes keyboard) stops working after suspend
touchpad (and sometimes keyboard) stops working after suspend
Status: RESOLVED DUPLICATE of bug 9226
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 23:55 UTC by Warren Turkal
Modified: 2012-05-22 14:38 UTC (History)
9 users (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: No


Attachments

Description Warren Turkal 2008-09-26 23:55:13 UTC
I've had this in issue 9772[1] for ages on my laptop. Currently I am running Ubuntu Intrepid beta updated to today.

Linux braindead 2.6.27-4-generic #1 SMP Wed Sep 24 01:30:51 UTC 2008 i686 GNU/Linux

My laptop is a Gateway CX2610.

wt@braindead:~$ lspci                                                                                  
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)                                                                                               
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)                                                                                             
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 AudioController (rev 04)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 04)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express (rev 11)
06:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
06:09.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:09.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
06:09.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
06:09.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller

wt@braindead:~$ sudo dmidecode 
# dmidecode 2.9                
SMBIOS 2.31 present.           
25 structures occupying 1263 bytes.
Table at 0x000E0010.               

Handle 0x0000, DMI type 0, 20 bytes
BIOS Information                   
        Vendor: Gateway            
        Version: 62.07.02          
        Release Date: 09/12/2006   
        Address: 0xE4040           
        Runtime Size: 114624 bytes 
        ROM Size: 1024 kB          
        Characteristics:           
                ISA is supported   
                PCI is supported   
                PC Card (PCMCIA) is supported
                PNP is supported             
                APM is supported             
                BIOS is upgradeable          
                BIOS shadowing is allowed    
                ESCD support is available    
                Boot from CD is supported    
                3.5"/720 KB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)         
                8042 keyboard services are supported (int 9h)      
                Serial services are supported (int 14h)            
                Printer services are supported (int 17h)           
                ACPI is supported                                  
                USB legacy is supported                            
                AGP is supported                                   
                Smart battery is supported                         
                BIOS boot specification is supported
... There is more if you want it.

Is there any other info I can give to help out?


[1]http://bugzilla.kernel.org/show_bug.cgi?id=7977

Thanks for looking into this,
wt
Comment 1 Warren Turkal 2008-09-26 23:55:57 UTC
Oops. I meant the issue in 7977. The link at the bottom is right.
Comment 2 Andrew Morton 2008-10-02 23:20:00 UTC
But 7977 was supposedly fixed.  Confused.
Comment 3 Zak Peirce 2008-10-03 07:18:40 UTC
7977 was closed with a solution, STR never worked on my laptop 7977 was a regression from 2.6.19 to 2.6.20.  STR never worked on my laptop so 7977 was not applicable to me.  I would say that a better bug to look at would be....

http://bugzilla.kernel.org/show_bug.cgi?id=9226
Comment 4 Alan 2012-05-22 14:38:23 UTC

*** This bug has been marked as a duplicate of bug 9226 ***

Note You need to log in before you can comment on or make changes to this bug.