Bug 116431 - Screen Flickering On Intel
Summary: Screen Flickering On Intel
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-15 17:09 UTC by Carlo Abelli
Modified: 2016-04-19 01:54 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.5.0
Tree: Mainline
Regression: No


Attachments

Description Carlo Abelli 2016-04-15 17:09:54 UTC
I have a Dell XPS 13 running Arch Linux. Updating to kernel version 4.5.0 has caused screen flickering (quick black flashes that come in bursts). Downgrading to 4.4.5 does fix this flickering. Not sure exactly what the issue is but it persists whether the xf86-video-intel driver is installed or not.

dmesg reports the following error when running kernel 4.5.0 but not 4.4.5:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Perhaps this is related. Here the thread on Arch Linux forums: https://bbs.archlinux.org/viewtopic.php?pid=1620382#p1620382
Comment 1 Carlo Abelli 2016-04-15 22:07:09 UTC
Booting with i915.enable_rc6=0 solves the issue; however this is just a temporary fix in my opinion.
Comment 2 Arthur 2016-04-17 22:52:39 UTC
I also have a Dell XPS 13 (9350 model with Skylake). I previously upgraded to a 4.5 kernel from the arch linux testing repo and noticed the same flickering mentioned by Carlo. I then downgraded back to 4.4.5 and the flickering went away. Now that 4.5 is out of testing, I pulled it down in my latest update, and the flickering has returned.

I do see the same message that Carlo mentions in dmesg output. It is the very last message in my output (see below with a little more context). It seems to be pretty consistent around that time at bootup regardless of how long I wait to login (but I have no idea if it's relevant - just confirming that I also see the message).

[    3.393442] IPv6: ADDRCONF(NETDEV_UP): wlp58s0: link is not ready
[    3.433790] IPv6: ADDRCONF(NETDEV_UP): wlp58s0: link is not ready
[    3.557638] IPv6: ADDRCONF(NETDEV_UP): wlp58s0: link is not ready
[   13.702477] IPv6: ADDRCONF(NETDEV_CHANGE): wlp58s0: link becomes ready
[   22.293947] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

Lastly, booting with the "i915.enable_rc6=0" option does make the flickering stop.
Comment 3 Jani Nikula 2016-04-18 08:23:55 UTC
Please file new drm/i915 bugs at the freedesktop.org bugzilla:
https://bugs.freedesktop.org/enter_bug.cgi?product=DRI&component=DRM/Intel
Comment 4 Carlo Abelli 2016-04-19 01:54:24 UTC
Filed here: https://bugs.freedesktop.org/show_bug.cgi?id=95010

Note You need to log in before you can comment on or make changes to this bug.