Bug 11622 - SATA DVD drive doesn't work
Summary: SATA DVD drive doesn't work
Status: RESOLVED DUPLICATE of bug 10743
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Tejun Heo
URL:
Keywords:
: 10137 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-09-22 12:34 UTC by Artem
Modified: 2008-10-01 02:57 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26
Tree: Mainline
Regression: ---


Attachments
kernel log (16.76 KB, text/plain)
2008-09-30 01:01 UTC, Ilya
Details

Description Artem 2008-09-22 12:34:14 UTC
Latest working kernel version:
Earliest failing kernel version:
Distribution: Arch Linux
Hardware Environment: Athlon, motherboard GA-K8VT800 VIA V8237R, NEC 7203S
Software Environment: kernel 2.6.26
Problem Description:
Hello,
When I burn a *.iso image onto a disk (cd or dvd) result fail.

The burned image equal's except first 0x20 bytes. (The size of burned DVD is
'iso_size'+0x20)

Here are 2 examples of the differences:

original image:

0000F940 23 00 00 00 00 00 00 23 00 08 00 00 00 00 08 00 6C 02 18 14 1C 13 00 02 00 00 01 00 00 01 08 43 #......#........l..............C 

0000F960 41 54 50 41 47 45 53 00 52 52 05 01 89 4E 4D 0D 01 00 63 61 74 70 61 67 65 73 50 58 24 01 6D 41 ATPAGES.RR...NM...catpagesPX$.mA 

burned image:

0000F940 00 00 00 00 54 46 1A 01 0E 6C 02 18 14 1C 13 00 6C 02 18 14 13 3A 00 6C 02 18 14 1C 13 00 7A 00 ....TF...l......l....:.l......z. 

0000F960 23 00 00 00 00 00 00 23 00 08 00 00 00 00 08 00 6C 02 18 14 1C 13 00 02 00 00 01 00 00 01 08 43 #......#........l..............C 

0000F980 41 54 50 41 47 45 53 00 52 52 05 01 89 4E 4D 0D 01 00 63 61 74 70 61 67 65 73 50 58 24 01 6D 41 ATPAGES.RR...NM...catpagesPX$.mA

other example of this bug - http://bugzilla.kernel.org/show_bug.cgi?id=10137

Steps to reproduce: burn any ISO image.
Comment 1 Tejun Heo 2008-09-28 19:01:48 UTC
Yeah, there was another report of this problem on linux-ide too.  Unfortunately, debugging wasn't successful.  Can you please post kernel boot log and the result of "hdparm -I /dev/sr0"?

Thanks.
Comment 2 Tejun Heo 2008-09-28 19:02:34 UTC
*** Bug 10137 has been marked as a duplicate of this bug. ***
Comment 3 Artem 2008-09-29 09:18:36 UTC
$ sudo hdparm -I /dev/sr0

/dev/sr0:

ATAPI CD-ROM, with removable media
        Model Number:       Optiarc DVD RW AD-7203S
        Firmware Revision:  1.05
Standards:
        Likely used CD-ROM ATAPI-1
Configuration:
        DRQ response: 50us.
        Packet size: 12 bytes
Capabilities:
        LBA, IORDY(cannot be disabled)
        DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
             Cycle time: min=120ns recommended=120ns
        PIO: pio0 pio1 pio2 pio3 pio4
             Cycle time: no flow control=120ns  IORDY flow control=120ns
Commands/features:
        Enabled Supported:
                Power Management feature set
                PACKET command feature set
                DEVICE_RESET command
                NOP cmd
           *    SATA-I signaling speed (1.5Gb/s)
           *    Host-initiated interface power management
           *    Phy event counters
                Device-initiated interface power management
           *    Software settings preservation
dmesg.log - http://www.filefactory.com/file/19327c/n/dmesg_log
Comment 4 Ilya 2008-09-30 01:01:36 UTC
Created attachment 18109 [details]
kernel log
Comment 5 Tejun Heo 2008-10-01 02:57:37 UTC
Marking as duplicate of 10743.  Can you please test the patch attached at the end of 10743?

Thanks.

*** This bug has been marked as a duplicate of bug 10743 ***

Note You need to log in before you can comment on or make changes to this bug.