Bug 11610 - Problem with kernel commit 664d080c41463570b95717b5ad86e79dc1be0877
Problem with kernel commit 664d080c41463570b95717b5ad86e79dc1be0877
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Config-Hotplug
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-09-21 12:38 UTC by Rafael J. Wysocki
Modified: 2008-10-27 20:15 UTC (History)
3 users (show)

See Also:
Kernel Version: commit 664d080c41463570b95717b5ad86e79dc1be0877
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-09-21 12:38:06 UTC
Subject    : Problem with kernel commit 664d080c41463570b95717b5ad86e79dc1be0877
Submitter  : "Michal 'vorner' Vaner" <vorner@ucw.cz>
Date       : 2008-09-21 17:35
References : http://marc.info/?l=linux-acpi&m=122201853409501&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-09-21 12:39:00 UTC
Reportedly caused by:

commit 664d080c41463570b95717b5ad86e79dc1be0877
Author: Holger Macht <hmacht@suse.de>
Date:   Tue Jun 3 20:27:59 2008 +0200

    [libata] ACPI: Properly handle bay devices in dock stations

    Signed-off-by: Holger Macht <hmacht@suse.de>
    Signed-off-by: Jeff Garzik <jgarzik@redhat.com>
Comment 2 Chuck Ebbert 2008-09-21 15:06:05 UTC
Not a regression from 2.6.26.
Comment 3 Rafael J. Wysocki 2008-09-21 15:08:48 UTC
Do you mean that commit 664d080c41463570b95717b5ad86e79dc1be0877 was present in 2.6.26?
Comment 4 Zhang Rui 2008-09-21 19:33:48 UTC
Shaohua has a patch set which fixed a lot of dock issue.
please give them a try. :)
http://marc.info/?l=linux-acpi&m=121988834907742&w=2

note that there are 11 patches in all.

BTW: seems like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=451399 
Comment 5 Michal Vaner 2008-09-23 12:33:52 UTC
I got a all-in-one patch by mail from Holger Macht (the author of the changes is Shaohua), so it should be the same patchset.

It fixes the issue, removing and inserting of the device work and the interrupts disappeared.

Should I test these patches too, or is this OK?

Thank you
Comment 6 Zhang Rui 2008-09-23 18:41:05 UTC
(In reply to comment #5)
> I got a all-in-one patch by mail from Holger Macht (the author of the changes
> is Shaohua), so it should be the same patchset.
> 
> It fixes the issue, removing and inserting of the device work and the
> interrupts disappeared.
> 
that's great.

> Should I test these patches too, or is this OK?
> 
then, you don't need to test these patches. :)

Mark this bug as PATCH_ALREADY_AVAILABLE.
cc Shaohua and Holger.
Comment 7 Len Brown 2008-10-16 13:00:08 UTC
this patch series is in the acpi-test tree, and thus linux next,
staged for 2.6.28-rc1
Comment 8 Len Brown 2008-10-27 20:15:34 UTC
shipped in linux-2.6.28-rc1
closed

Note You need to log in before you can comment on or make changes to this bug.