Bug 11600 - ATI integrated sound card on 690G fails to work beginning with 2.6.26
ATI integrated sound card on 690G fails to work beginning with 2.6.26
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-20 09:28 UTC by Soren Stoutner
Modified: 2009-04-15 02:27 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26
Tree: Mainline
Regression: Yes


Attachments

Description Soren Stoutner 2008-09-20 09:28:36 UTC
Latest working kernel version:  2.6.25
Earliest failing kernel version:  2.6.26
Distribution:  Debian
Hardware Environment:  AMD64
Software Environment:  KDE
Problem Description:

Beginning with 2.6.26, the integrated sound card in my Gigabyte GA-MA69GM-S2H doesn't work.  With 2.6.25, KMix lists two sound card options: HDA ATI SB and HDA ATI HDMI.  In 2.6.26 it only lists HDA ATI HDMI.  All packages are current Debian Testing.  Specifically:

alsa-base      1.0.17.dfsg-2  ALSA driver configuration files
alsa-utils     1.0.16-2       ALSA utilities

I can reproduce the problem with Debian Kernels 2.6.26-4 and 2.6.27~rc6-1~experimental.1~snapshot.12226.  When I boot back into Debian kernel 2.6.25-7 the sound works again.

This bug has been reported downstream with Debian Bug 499227 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=499227)

Steps to reproduce:
Comment 1 Robert Graeme Moonen 2008-09-22 00:06:06 UTC
This also applies to the ES1988 Allegro-1, sound on my laptop with integrated ES1988 stopped working since 2.6.24. I have had to revert to 2.6.22 for the sound to work again. It is an Asus L8400.

regards

Robert G. Moonen
Comment 2 Soren Stoutner 2009-04-15 02:27:08 UTC
This bug is fixed for me with the Debian Kernel 2.6.29-1 (linux-image-2.6.29-1-amd64, currently in unstable).

Note You need to log in before you can comment on or make changes to this bug.