Bug 11569 - Panic stop CPUs regression
Panic stop CPUs regression
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andi Kleen
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-09-14 21:59 UTC by Rafael J. Wysocki
Modified: 2010-10-07 18:40 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-09-14 21:59:44 UTC
Subject    : Don't complain about disabled irqs when the system has paniced
Submitter  : Andi Kleen <andi@firstfloor.org>
Date       : 2008-09-02 13:49
References : http://marc.info/?l=linux-kernel&m=122036356127282&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Andi Kleen 2008-10-05 22:55:17 UTC
Updating description.

The problem is actually worse than described in the original report.

panic() calls smp_call_function() which nows allocates memory and complains
about disabled interrupts. Allocating memory or not allowing panic 
from interrupt off regionss definitely not a good idea.

I ran into this because it broke machine checks panics.




Comment 2 Rafael J. Wysocki 2008-10-24 14:32:39 UTC
Andi, has this problem been fixed in mainline?
Comment 3 Andi Kleen 2008-10-24 23:43:19 UTC
No it's still broken
Comment 4 Rafael J. Wysocki 2008-11-16 10:56:01 UTC
Any change?
Comment 5 Andi Kleen 2008-11-22 15:00:04 UTC
Sorry it's definitely still broken. There have been also reports about this
about users hitting the problem. 
I haven't gotten around to fix it yet, but it's on my todo list.
Comment 6 Alan 2010-01-19 20:09:10 UTC
Ping on status Andi ?
Comment 7 Florian Mickler 2010-10-07 18:40:07 UTC
I guess this is fixed by

commit 4ef702c10b5df18ab04921fc252c26421d4d6c75
Author: Andi Kleen <andi@firstfloor.org>
Date:   Wed May 27 21:56:52 2009 +0200

    x86: fix panic with interrupts off (needed for MCE)
    
    For some time each panic() called with interrupts disabled
    triggered the !irqs_disabled() WARN_ON in smp_call_function(),
    producing ugly backtraces and confusing users.
[snip]


Please reopen, if this commit of yours does not fix your issue.

Note You need to log in before you can comment on or make changes to this bug.