Bug 115671 - bluetooth no longer connects
Summary: bluetooth no longer connects
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Bluetooth (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: linux-bluetooth@vger.kernel.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-04-01 04:26 UTC by karoly
Modified: 2016-04-01 08:04 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.4.5
Tree: Mainline
Regression: Yes


Attachments

Description karoly 2016-04-01 04:26:12 UTC
When I try connect my Intel 7260 (8087:07dc) to my speaker the speaker LED never shows a successful connection and bluetoothctl disconnects pretty soon:

connect 00:1D:DF:D4:4F:33
Attempting to connect to 00:1D:DF:D4:4F:33
[CHG] Device 00:1D:DF:D4:4F:33 Connected: yes
Connection successful
[CHG] Device 00:1D:DF:D4:4F:33 Connected: no

Here's what btmon says about the disconnect:

> HCI Event: Disconnect Complete (0x05) plen 4                                 
>                                                             [hci0] 29.110388
        Status: Success (0x00)
        Handle: 256
        Reason: Connection Timeout (0x08)
@ Device Disconnected: 00:1D:DF:D4:4F:33 (0) reason 1

hcitool:

2016-03-31 21:12:17.490512 > HCI Event: Command Status (0x0f) plen 4
    Set Connection Encryption (0x01|0x0013) status 0x00 ncmd 1
2016-03-31 21:12:17.561514 > HCI Event: Encrypt Change (0x08) plen 4
    status 0x00 handle 256 encrypt 0x01
2016-03-31 21:12:17.563509 > HCI Event: Command Complete (0x0e) plen 7
    Read Encryption Key Size (0x05|0x0008) ncmd 1
    0000: 00 00 01 07                                       ....
2016-03-31 21:12:39.286297 > HCI Event: Disconn Complete (0x05) plen 4
    status 0x00 handle 256 reason 0x08
    Reason: Connection Timeout

This is always reproducible and I already did a factory reset on the speakers.

More logs available on request, just tell me what do you need. If necessary, I can read strace and have very very basic gdb experience as well.
Comment 1 karoly 2016-04-01 04:27:33 UTC
This worked in 4.3.3.
Comment 2 karoly 2016-04-01 05:29:12 UTC
After trying to downgrade to 4.3.3 (no change), pulseaudio (8.0 -> 7.1) I have tried to downgrade bluez from 5.38 to 5.37. That helped!! 

I am not sure where to report bluez bugs.

Note You need to log in before you can comment on or make changes to this bug.