Bug 11559 - 2.6.27-rc6: nohz + s2ram = need to press keys to get progress
2.6.27-rc6: nohz + s2ram = need to press keys to get progress
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: Thomas Gleixner
:
Depends on:
Blocks: 7216 10482
  Show dependency treegraph
 
Reported: 2008-09-12 12:09 UTC by Rafael J. Wysocki
Modified: 2008-09-21 12:56 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27-rc6
Tree: Mainline
Regression: Yes


Attachments
Broadcast tick fix (430 bytes, patch)
2008-09-16 12:08 UTC, Jens Axboe
Details | Diff
The real fix (4.45 KB, patch)
2008-09-16 15:35 UTC, Thomas Gleixner
Details | Diff
Patch that fixes resume on HP nx6325 (489 bytes, patch)
2008-09-20 13:52 UTC, Rafael J. Wysocki
Details | Diff

Description Rafael J. Wysocki 2008-09-12 12:09:51 UTC
Subject    : 2.6.27-rc6: nohz + s2ram = need to press keys to get progress
Submitter  : Pavel Machek <pavel@suse.cz>
Date       : 2008-09-12 8:31
References : http://marc.info/?l=linux-kernel&m=122121384705262&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-09-14 16:43:00 UTC
Not a regression from 2.6.26, apparently.

References : http://marc.info/?l=linux-kernel&m=122141369710750&w=4
Comment 2 Lukas Hejtmanek 2008-09-15 01:07:47 UTC
I can see this problem as well. I don't see it in 2.6.27-rc5. I have ThinkPad T61.
Comment 3 Pavel Machek 2008-09-15 02:13:51 UTC
> I can see this problem as well. I don't see it in 2.6.27-rc5. I have ThinkPad
> T61.

Hmm, so while 2.6.26 is broken for me, 2.6.27-rc5 works here. So I
guess I have separate problem that breaks 2.6.26 resume, and there's
indeed a regression from 2.6.27-rc5 to rc6.

									Pavel

Comment 4 Lukas Hejtmanek 2008-09-15 07:43:35 UTC
However, Pavel, I see the same symptoms, hitting several times the keyboard makes the resume proceed but the system is 'sleepy' and while not typing, CPUs are loaded by system up to 100% (only one of the two CPUs). No particular process seems to be eating the CPUs.
Comment 5 Jens Axboe 2008-09-16 12:07:53 UTC
Thomas debugged this one, I'll attach the temporary diff and let Thomas himself write up a real patch description :-)
Comment 6 Jens Axboe 2008-09-16 12:08:54 UTC
Created attachment 17811 [details]
Broadcast tick fix
Comment 7 Thomas Gleixner 2008-09-16 15:35:14 UTC
Created attachment 17817 [details]
The real fix
Comment 8 Pavel Machek 2008-09-16 15:49:32 UTC
> Created an attachment (id=17817)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=17817&action=view)
> The real fix

Your previous patch worked okay for me... will test this one tommorow.

									Pavel
Comment 9 Pavel Machek 2008-09-17 00:19:48 UTC
On Wed 2008-09-17 00:50:50, Pavel Machek wrote:
> 
> > Created an attachment (id=17817)
> >  --> (http://bugzilla.kernel.org/attachment.cgi?id=17817&action=view)
> > The real fix
> 
> Your previous patch worked okay for me... will test this one tommorow.

Tested, and seems to work ok.

Tested-by: Pavel Machek <pavel@suse.cz>
									Pavel
Comment 10 Rafael J. Wysocki 2008-09-19 16:33:01 UTC
(In reply to comment #7)
> Created an attachment (id=17817) [details]
> The real fix

Bad new here.  This patch breaks resume from RAM on my HP nx6325.  Sorry. :-(
Comment 11 Rafael J. Wysocki 2008-09-20 13:52:27 UTC
Created attachment 17917 [details]
Patch that fixes resume on HP nx6325

Of course this also defeats the purpose of the patch at http://bugzilla.kernel.org/attachment.cgi?id=17817&action=edit .
I tried some other things, but none of them worked. :-(
Comment 12 Rafael J. Wysocki 2008-09-21 11:32:48 UTC
After some more debugging I can say that the patch from comment #7 breaks CPU hotplugging on my machine.  More specifically, CPU1 can be offlined, but every attempt to online it causes the box to crash.  I guess that's what breaks resume.
Comment 13 Rafael J. Wysocki 2008-09-21 12:56:41 UTC
Created bug #11611 to follow the issue described in comment #12, since the patch from comment #7 is in the mainline.

Closing this one.

Note You need to log in before you can comment on or make changes to this bug.