Bug 11557 - Controlling backlight on thinkpad x60
Controlling backlight on thinkpad x60
Status: CLOSED DUPLICATE of bug 11647
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-12 12:04 UTC by Rafael J. Wysocki
Modified: 2008-10-16 13:16 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-09-12 12:04:15 UTC
Subject    : Controlling backlight on thinkpad x60
Submitter  : Pavel Machek <pavel@suse.cz>
Date       : 2008-09-08 15:10
References : http://marc.info/?l=linux-kernel&m=122088987319698&w=4
Handled-By : Matthew Garrett <mjg59@srcf.ucam.org>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-09-14 17:22:18 UTC
Apparently, this is not a regression from 2.6.26.
Comment 2 Rafael J. Wysocki 2008-09-14 17:22:23 UTC
On Sunday, 14 of September 2008, Pavel Machek wrote:
> On Sat 2008-09-13 16:13:30, Matthew Garrett wrote:
> > I don't think this is a regression. The correct way to drive this 
> > hardware has always been through the ACPI video driver. The fact that 
> > thinkpad-acpi would also attempt to drive it was a bug.
> 
> I'm pretty sure thinkpad-acpi is older then ACPI-video. So yes, I
> believe this is a regression, but it may be pretty old one.

Comment 3 Zhang Rui 2008-09-17 18:46:28 UTC
hmm, it's not unusual that a laptop has duplicate video devices.
but it's interesting that both of them can control the backlight.

Paval,
can you attach the acpidump output please?
Comment 4 Zhang Rui 2008-09-25 18:12:55 UTC
there are two problems here.
1. backlight control from thinkpad_acpi is not enabled by default any longer. this is why it's marked as a regression.
2. duplicate functional ACPI backlight devices on this platform. this should be fixed by thomas/matthew video patches which are in Andi's acpi test tree now.

1 should not be an issue any more if the new patches are applied. i.e. there should be one ACPI backlight device under /sys/class/backlight/, instead of the thinkpad one.
mark this as a duplicate of bug 11647.

*** This bug has been marked as a duplicate of bug 11647 ***

Note You need to log in before you can comment on or make changes to this bug.