Bug 11555 - rmmod ide-cd_mod: tried to init an initialized  object, something is seriously wrong.
Summary: rmmod ide-cd_mod: tried to init an initialized  object, something is seriousl...
Status: CLOSED CODE_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Block Layer (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jens Axboe
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-09-12 11:55 UTC by Rafael J. Wysocki
Modified: 2008-09-26 16:10 UTC (History)
0 users

See Also:
Kernel Version: 2.6.27-rc5-00132-gb380b0d
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-09-12 11:55:55 UTC
Subject    : 2.6.27-rc5-mm1: rmmod ide-cd_mod: tried to init an initialized object, something is seriously wrong.
Submitter  : Mariusz Kozlowski <m.kozlowski@tuxland.pl>
Date       : 2008-07-16 2:22
References : http://marc.info/?l=linux-ide&m=122061839713526&w=4
Handled-By : Jens Axboe <jens.axboe@oracle.com>
Patch      : http://marc.info/?l=linux-kernel&m=122095622602315&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-09-12 11:56:38 UTC
Caused by:

commit abf5439370491dd6fbb4fe1a7939680d2a9bc9d4
Author: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Date:   Sat Aug 16 14:10:05 2008 +0900

    block: move cmdfilter from gendisk to request_queue

    Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
    Signed-off-by: Jens Axboe <jens.axboe@oracle.com>
Comment 2 Rafael J. Wysocki 2008-09-26 16:08:33 UTC
On Sunday, 21 of September 2008, Mariusz Kozlowski wrote:
> Hi,
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> 
> It was present in 2.6.27-rc6. A day or two later I checked mainline and
> it was gone. I will recheck this and notify if needed.
> 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=11555
> > Subject             : rmmod ide-cd_mod: tried to init an initialized
> =C2=A0object, something is s= eriously wrong.
> > Submitter   : Mariusz Kozlowski <m.kozlowski@tuxland.pl>
> > Date                : 2008-07-16 2:22 (68 days old)
> > References  : http://marc.info/?l=linux-ide&m=122061839713526&w=4
> > Handled-By  : Jens Axboe <jens.axboe@oracle.com>
> > Patch               :
> http://marc.info/?l=linux-kernel&m=122095622602315&w=4

Note You need to log in before you can comment on or make changes to this bug.