Bug 11487 - No sound with snd-hda-intel
Summary: No sound with snd-hda-intel
Status: CLOSED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-09-02 17:57 UTC by Ben Gamari
Modified: 2008-09-04 14:31 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Ben Gamari 2008-09-02 17:57:06 UTC
Latest working kernel version: 2.6.26 (I believe)
Earliest failing kernel version: 2.6.27-rc5 (as far as I have tested)
Distribution: Fedora Rawhide
Hardware Environment: Dell Latitude D830
Software Environment: 
Problem Description:
Despite all mixers at 100% and unmuted, the speakers and headphone jacks produce no output.


Steps to reproduce:
Boot; try playing audio; enjoy sweet silence
Comment 1 Ben Gamari 2008-09-02 17:57:57 UTC
dmesg shows the following upon modprobing snd-hda-intel:

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
HDA Intel 0000:00:1b.0: setting latency timer to 64
ALSA sound/pci/hda/hda_intel.c:2083: chipset global capabilities = 0x4401
ALSA sound/pci/hda/hda_intel.c:758: codec_mask = 0x3
ALSA sound/pci/hda/hda_codec.c:2350: hda_codec: model 'dell-m43' is selected for config 1028:1fe (Dell Precision)
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 0a pin config 0321101f
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 0b pin config 03a11020
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 0c pin config 90a70330
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 0d pin config 90170310
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 0e pin config 400000fe
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 0f pin config 400000ff
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 14 pin config 400000fd
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 16 pin config 40f000f9
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 17 pin config 400000fa
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 18 pin config 400000fc
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 21 pin config 0144131f
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 22 pin config 40c003f8
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 1f pin config 00000000
ALSA sound/pci/hda/patch_sigmatel.c:1845: hda_codec: pin nid 20 pin config 00000000
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0xb, fmic=0xc, line=0x0, fline=0x0, cd=0x0, aux=0x0
ALSA sound/pci/hda/patch_sigmatel.c:2254: stac92xx_add_dyn_out_pins: total dac count=2
ALSA sound/pci/hda/patch_sigmatel.c:2376: dac_nids=1 (0x10/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Surround Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Center Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave LFE Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Side Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Headphone Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Headphone Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Speaker Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave External Speaker Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Speaker2 Playback Volume, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Surround Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Center Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave LFE Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Side Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Headphone Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Headphone Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Speaker Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave External Speaker Playback Switch, skipped
ALSA sound/pci/hda/hda_codec.c:1127: Cannot find slave Speaker2 Playback Switch, skipped
ALSA sound/pci/hda/hda_intel.c:1404: azx_pcm_prepare: bufsize=0x10000, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x12, stream=0x1, channel=0, format=0x4011
ALSA sound/pci/hda/hda_intel.c:1404: azx_pcm_prepare: bufsize=0x10000, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x12, stream=0x1, channel=0, format=0x4011
ALSA sound/pci/hda/hda_intel.c:1404: azx_pcm_prepare: bufsize=0x10000, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x1f, stream=0x5, channel=0, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x10, stream=0x5, channel=0, format=0x4011
ALSA sound/pci/hda/hda_intel.c:1404: azx_pcm_prepare: bufsize=0x10000, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x1f, stream=0x5, channel=0, format=0x4011
ALSA sound/pci/hda/hda_codec.c:716: hda_codec_setup_stream: NID=0x10, stream=0x5, channel=0, format=0x4011
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x12
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x12
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x10
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x1f
ALSA sound/pci/hda/hda_codec.c:728: hda_codec_cleanup_stream: NID=0x10
Comment 2 Takashi Iwai 2008-09-02 22:27:50 UTC
The kernel message looks OK.  All these are just information, neither errors nor warnings.

Could you try to run alsa-info.sh with --no-upload option on both working and non-working kernels, and attach the generated files to here?
The script is found in
    http://www.alsa-project.org/alsa-info.sh
Comment 3 Ben Gamari 2008-09-03 08:45:36 UTC
Strangely, after rebooting last night I've been unable to reproduce the issue. I've even tried suspending and resuming and the problem still has come up. Sorry about the noise. Closing for now but I'll let you know if I manage to reproduce it again.

Note You need to log in before you can comment on or make changes to this bug.