Bug 11485 - 2.6.27-rc xen pvops regression?
Summary: 2.6.27-rc xen pvops regression?
Status: CLOSED CODE_FIX
Alias: None
Product: Virtualization
Classification: Unclassified
Component: Xen (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: virtualization_xen
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-09-02 13:46 UTC by Rafael J. Wysocki
Modified: 2008-09-20 02:51 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-09-02 13:46:38 UTC
Subject    : 2.6.27-rc xen pvops regression?
Submitter  : Bernhard Schmidt <berni@birkenwald.de>
Date       : 2008-08-31 17:18
References : http://marc.info/?l=linux-kernel&m=122020367015025&w=4
Handled-By : Alex Nixon <alex.nixon@citrix.com>
Handled-By : Jeremy Fitzhardinge <jeremy@goop.org>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jeremy Fitzhardinge 2008-09-02 14:15:20 UTC
Workaround is to build SMP kernel.
Comment 2 Rafael J. Wysocki 2008-09-10 15:57:08 UTC
On Thursday, 11 of September 2008, Bernhard Schmidt wrote:
> On Sat, Sep 06, 2008 at 11:30:44PM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=11485
> > Subject             : 2.6.27-rc xen pvops regression?
> > Submitter   : Bernhard Schmidt <berni@birkenwald.de>
> > Date                : 2008-08-31 17:18 (7 days old)
> > References  : http://marc.info/?l=linux-kernel&m=122020367015025&w=4
> > Handled-By  : Alex Nixon <alex.nixon@citrix.com>
> >               Jeremy Fitzhardinge <jeremy@goop.org>
> 
> Regression is still there in 2.6.27-rc6.
Comment 3 Jeremy Fitzhardinge 2008-09-12 14:19:06 UTC
Should be fixed by http://lkml.org/lkml/2008/9/3/145
Comment 4 Rafael J. Wysocki 2008-09-12 14:53:04 UTC
Handled-By : Alex Nixon <alex.nixon@citrix.com>
Patch : http://lkml.org/lkml/2008/9/3/145
Comment 5 Bernhard Schmidt 2008-09-12 16:07:01 UTC
Confirmed, patched kernel works without SMP
Comment 6 Adrian Bunk 2008-09-20 02:51:56 UTC
fixed by commit 5132895f14a57607152f7865dc862fb076ce2585

Note You need to log in before you can comment on or make changes to this bug.