Bug 114661 - Elantech ETPS/2 touchpad doesn't work after suspend
Summary: Elantech ETPS/2 touchpad doesn't work after suspend
Status: RESOLVED DUPLICATE of bug 107971
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-15 16:18 UTC by Jacek Sowiński
Modified: 2016-05-19 16:32 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.4.4
Tree: Fedora
Regression: No


Attachments

Description Jacek Sowiński 2016-03-15 16:18:42 UTC
Initially reported on RedHat's bug-tracker: https://bugzilla.redhat.com/show_bug.cgi?id=1243609

I have a laptop with Elantech ETPS/2 Touchpad (hardware version 4 with firmware version 0x381f00 according do dmesg). It'is recognized with both libinput or synaptics (latter with /usr/share/X11/xorg.conf.d/90-libinput.conf commented out or deleted) and works flawlessly without any hiccups. Unfortunately after resuming from suspend touchpad is "dead":

- It's absent in `xinput list` output
- dmesg doesn't say anything about it on resume
- Xorg removes it after resume with message in Xorg.0.log:

> config/udev: removing device ETPS/2 Elantech Touchpad
> UnloadModlue: "synaptics"

- objects present before suspend in /sys/devices/platform/i8042/serio1/ (like reg_07 for instance) are absent after resume.

Steps to Reproduce:
1. power on, use touchpad with no problems
2. suspend (mem sleep)
3. resume

Actual results:
Touchpad is dead.


Expected results:
Touchpad should work without any problems, just like before suspend.
Comment 1 Jacek Sowiński 2016-05-19 16:32:22 UTC

*** This bug has been marked as a duplicate of bug 107971 ***

Note You need to log in before you can comment on or make changes to this bug.