Bug 11436 - ixgbe: fix vlan filtering
ixgbe: fix vlan filtering
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-27 13:58 UTC by Rafael J. Wysocki
Modified: 2008-08-30 13:59 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27-rc4-git
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-27 13:58:50 UTC
Subject    : ixgbe: fix vlan filtering
Submitter  : Jeff Kirsher <jeffrey.t.kirsher@intel.com>
Date       : 2008-08-27 1:30
References : http://marc.info/?l=linux-netdev&m=121980061622847&w=4
Handled-By : Alexander Duyck <alexander.h.duyck@intel.com>
Patch      : http://marc.info/?l=linux-netdev&m=121980061622847&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-27 13:59:55 UTC
Reportedly caused by:

commit 746b9f0228a1c607b3db67c80da1c2a963321926
Author: Patrick McHardy <kaber@trash.net>
Date:   Wed Jul 16 20:15:45 2008 -0700

    netdrv intel: disable VLAN filtering in promiscous mode

    Signed-off-by: Patrick McHardy <kaber@trash.net>
    Acked-by: Jeff Kirsher <jeffrey.t.kirsher@intel.com>
    Acked-by: Peter P Waskiewicz Jr <peter.p.waskiewicz.jr@intel.com>
    Signed-off-by: David S. Miller <davem@davemloft.net>

Note You need to log in before you can comment on or make changes to this bug.