Bug 11435 - oops due to smp_call_function_single changes
oops due to smp_call_function_single changes
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-27 13:52 UTC by Rafael J. Wysocki
Modified: 2008-08-31 04:28 UTC (History)
2 users (show)

See Also:
Kernel Version: commit cc7a486cac78f6fc1a24e8cd63036bae8d2ab431
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-27 13:52:51 UTC
Subject    : oops due to smp_call_function_single changes
Submitter  : Avi Kivity <avi@qumranet.com>
Date       : 2008-08-24 16:41
References : http://marc.info/?l=linux-kernel&m=121959612027162&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-27 13:53:45 UTC
Caused by:

commit cc7a486cac78f6fc1a24e8cd63036bae8d2ab431
Author: Nick Piggin <nickpiggin@yahoo.com.au>
Date:   Mon Aug 11 13:49:30 2008 +1000

    generic-ipi: fix stack and rcu interaction bug in smp_call_function_mask()

Signed-off-by: Ingo Molnar <mingo@elte.hu>
Comment 2 Avi Kivity 2008-08-31 01:27:52 UTC
Appears to be fixed in v2.6.27-rc5-6-gbef69ea.
Comment 3 Rafael J. Wysocki 2008-08-31 04:28:57 UTC
Closing the bug now, please reopen if you see it again.

Note You need to log in before you can comment on or make changes to this bug.