Bug 11424 - Same keycode using HP-WMI
Same keycode using HP-WMI
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-25 09:48 UTC by Michel Filipe
Modified: 2008-08-26 06:22 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.26
Tree: Mainline
Regression: ---


Attachments
Debug patch (880 bytes, patch)
2008-08-25 10:40 UTC, Matthew Garrett
Details | Diff
Add proper support for hotkeys (1.28 KB, application/octet-stream)
2008-08-25 14:16 UTC, Matthew Garrett
Details

Description Michel Filipe 2008-08-25 09:48:39 UTC
Distribution: 
Gentoo Linux

Hardware Environment: 
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
08:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
08:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
08:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
08:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
08:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 01)
Bus 002 Device 002: ID 046d:c00e Logitech, Inc. M-BJ69 Optical Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001
Bus 001 Device 001: ID 1d6b:0002
Bus 003 Device 001: ID 1d6b:0001
Bus 004 Device 001: ID 1d6b:0001
Bus 005 Device 002: ID 03f0:171d Hewlett-Packard
Bus 005 Device 001: ID 1d6b:0001
At http://files.milk-it.net/michel has many debug files of my laptop.

Software Environment:
Linux benita 2.6.26 #8 SMP Sun Aug 24 19:29:21 BRT 2008 i686 Genuine Intel(R) CPU T2050 @ 1.60GHz GenuineIntel GNU/Linux

Problem Description:
I'm using the HP-WMI Misc Driver. With some buttons are send the same keycode of Help Button.

Steps to reproduce:
When I press "DVD Button" or "Media Button", they send the same keycode of "Help Button" (fn+f1). The xbindkeys can't handle these keys, but KDE4.1 can handle these keys, because it opens KDEHelper. 

My HP WMI is running at /class/input/input5.
Comment 1 Matthew Garrett 2008-08-25 10:40:13 UTC
Created attachment 17438 [details]
Debug patch

Can you apply the following patch and let me know what dmesg says when you press each of the keys?
Comment 2 Michel Filipe 2008-08-25 11:41:31 UTC
Hi Matthew!

When I press "DVD Button", it returns: Got 20e6
When I press "Media Button", it returns: Got 2142
When I press "Help Button" (fn+f1), it returns nothing.
Comment 3 Matthew Garrett 2008-08-25 14:16:34 UTC
Created attachment 17445 [details]
Add proper support for hotkeys

Ok, can you give this one a go instead of the debug one? I'll need to look into Fn+F1 support, it looks like that's a different pathway.
Comment 4 Michel Filipe 2008-08-26 06:19:37 UTC
Thanks Matthew! Your patch works fine! :)

I think that I was unclear. The Fn+F1 always works, but with your driver the DVD Button and Media Button are starting the generate keycode - before they dont' generate nothing -, but the same keycode of Fn+F1.
Comment 5 Matthew Garrett 2008-08-26 06:22:02 UTC
Excellent! I'll send this upstream.

Note You need to log in before you can comment on or make changes to this bug.