Bug 11415 - Dell Latitude LS freezes after second supend to RAM
Dell Latitude LS freezes after second supend to RAM
Status: REJECTED INVALID
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-08-24 04:11 UTC by Lavrentiy
Modified: 2009-03-23 02:14 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.26
Tree: Mainline
Regression: ---


Attachments
Required dmesg output after first s2ram. (15.11 KB, text/plain)
2008-08-24 21:56 UTC, Lavrentiy
Details
Dell Latitude LS acpidump output (56.06 KB, text/plain)
2008-08-24 22:29 UTC, Lavrentiy
Details
customized DSDT (102.57 KB, application/octet-stream)
2008-08-26 02:15 UTC, Zhang Rui
Details
After a second s2r using echo mem > /po... (23.63 KB, text/plain)
2008-08-26 05:46 UTC, Lavrentiy
Details
Third s2r from Gnome (27.96 KB, text/plain)
2008-08-26 05:48 UTC, Lavrentiy
Details
test the debug patch (2.17 KB, patch)
2008-08-28 20:14 UTC, ykzhao
Details | Diff
patch: use 32 bit wakeup vector (5.29 KB, patch)
2008-09-09 19:09 UTC, Zhang Rui
Details | Diff

Description Lavrentiy 2008-08-24 04:11:06 UTC
+++ This bug was initially created as a clone of Bug #6749 +++

Most recent kernel where this bug did not occur: 2.6.26-ARCH
Distribution: ArchLinux
Hardware Environment: Dell Latitude LS 400 i686 Pentium III (Coppermine)
Software Environment: ArchLinux 
Problem Description: After second supend to ram comp freeze. FANs are rotating, the screen is blank. 

Steps to reproduce: press Lid switch two times
Kernel parameters (according to Ubuntu and ArchLinux wiki): acpi=off apm=power_off noapic nolapic.

APMd daemon is working. Please help.
Comment 1 Zhang Rui 2008-08-24 19:20:57 UTC
(In reply to comment #0)
> +++ This bug was initially created as a clone of Bug #6749 +++
> 
> Most recent kernel where this bug did not occur: 2.6.26-ARCH
do you mean it works well in the kernel earlier than 2.6.26?
 
> 
> Steps to reproduce: press Lid switch two times
what if you use "echo mem > /sys/power/state" rather than pressing the Lid switch?

> Kernel parameters (according to Ubuntu and ArchLinux wiki): acpi=off
> apm=power_off noapic nolapic.

You mean you are running s2ram with "acpi=off"?

Please attach the dmesg output after the first s2ram.
Please attach the acpidump output.
Comment 2 Lavrentiy 2008-08-24 21:51:13 UTC
1) I'm really sorry, the kernel where this bug DID occur is the most recent Arch kernel - 2.6.26.

2) echo mem > /sys/power/state
-bash: echo: write error: No such device.

But there IS a file /sys/power, owned by root, permissions are 644.

3) I press power button (set in BIOS) or lid buton for suspend to ram function. It works for the first time well. Parameters for the kernel are: acpi=off apm=power_off noapic nolapic, I took them from http://wiki.archlinux.org/index.php/Dell_Latitude_LS and from https://wiki.ubuntu.com/LaptopTestingTeam/DellLatitudeLS.

So YES, I perform S2Ram with acpi=off.
Comment 3 Lavrentiy 2008-08-24 21:56:16 UTC
Created attachment 17425 [details]
Required dmesg output after first s2ram.
Comment 4 Lavrentiy 2008-08-24 22:29:14 UTC
Created attachment 17426 [details]
Dell Latitude LS acpidump output

After 1st S2RAM and before are the same (diff result).
Comment 5 Zhang Rui 2008-08-24 23:37:11 UTC
why do you need acpi=off?
Please re-test with ACPI enabled, or else we'll close this bug as we don't support APM any more.
Comment 6 Lavrentiy 2008-08-24 23:55:00 UTC
Cause Latitude LS does not support ACPI. It is denoted in FAQ. 

Please let me know exact parameters. Do I need to run acpid?


Just tried with acpi=on apm=power_off noacpi nolapic. Power button -> nothing. Lid button -> just turns off the screen (no other acrion).

# echo mem > /sys/power/state -> Black screen (like it's going to suspend after sync) and the fan is on maximum, that's all. So it does not even go to sleep correctly in case of acpi=on.

# /etc/rc.d/acpid start:
acpid: can't open /proc/acpi/event: Device or resource busy

With no related kernel parameters at all:

ACPId is able to start, but the result of mem > /sys/power/state is the same: sync, blank screen, fan on maximum.
Comment 7 Zhang Rui 2008-08-25 00:10:46 UTC
(In reply to comment #6)
> Cause Latitude LS does not support ACPI. It is denoted in FAQ. 
> 
I googled Dell Latitude LS 400 and found that it's a pretty old laptop.
so you're right that ACPI is not supported on this laptop

> 
> With no related kernel parameters at all:
> 
> ACPId is able to start, but the result of mem > /sys/power/state is the same:
> sync, blank screen, fan on maximum.
> 

As this is a pretty old laptop that doesn't support ACPI, I have to say that we'll reject this bug as we won't fix it in Linux kernel.
Sorry that we can't help you.
Please check if upgrading the BIOS helps.
Comment 8 Lavrentiy 2008-08-25 00:21:17 UTC
But closed source OS works very well. As I understood, Linux does not support hardware well and has buggy kernel. Ok, I understand.
Comment 9 Lavrentiy 2008-08-25 00:22:42 UTC
So your kernel has apm support, it has bug, but you will leave bug inside the kernel so the kernel will be buggy. OK.
Comment 10 Zhang Rui 2008-08-25 01:03:31 UTC
(In reply to comment #8)
> But closed source OS works very well. As I understood, Linux does not support
> hardware well and has buggy kernel.
You're wrong.
Many hardware/BIOS are released without any tests under Linux. They are thought to be working if they runs well in Windows, even if it's actually broken (violate the hardware spec, etc).
We've spent a lot of time on this kind of bugs in Linux.
But this one is too old and I'm afraid no one is working on APM any more.

(In reply to comment #9)
> So your kernel has apm support, it has bug, but you will leave bug inside the
> kernel so the kernel will be buggy. OK.
> 
well. that's a problem.
I can't answer this question.
cc len and rafael.
Comment 11 Lavrentiy 2008-08-25 08:45:52 UTC
Oh may I report new circumstances?

I installed Ubuntu, default installation. And I put "acpi=off" parameters to kernel - the same "bad" behavior.

But when there is no any parameters then:

# echo mem >/sys/power/state gives GOOD S2R anytime and many many times.

$ uname -a
Linux my-desktop 2.6.24-19-generic #1 SMP .....

So I don't know what to say else...
There is also some kind of "Suspend" in Ubuntu, which takes some longer time, but it works also.

So, here are my conclusions:

1) Thank you for your kind dialogue;

2) 2.6.24-19-Ubuntu seems to work, 2.6.26-Arch seems to not work, I don't know where I should think about distro or about the kernel itself.
Comment 12 Zhang Rui 2008-08-25 20:46:16 UTC
(In reply to comment #11)
> Oh may I report new circumstances?
> 
> I installed Ubuntu, default installation. And I put "acpi=off" parameters to
> kernel - the same "bad" behavior.
> 
> But when there is no any parameters then:
> 
> # echo mem >/sys/power/state gives GOOD S2R anytime and many many times.
> 
so you mean S3 works with acpi enabled?
valuable findings. as this is an ACPI issue rather than APM, re-open this bug.

> $ uname -a
> Linux my-desktop 2.6.24-19-generic #1 SMP .....
> 
> So I don't know what to say else...
> There is also some kind of "Suspend" in Ubuntu, which takes some longer time,
> but it works also.
please attach the dmesg output after suspend to ram twice.

> 
> 2) 2.6.24-19-Ubuntu seems to work, 2.6.26-Arch seems to not work, I don't know
> where I should think about distro or about the kernel itself.
> 
will you please try to get the latest kernel source code and check if you can reproduce the problem in the mainline kernel?
Comment 13 Zhang Rui 2008-08-26 02:15:16 UTC
Created attachment 17456 [details]
customized DSDT

please try to recompile the kernel with this customized DSDT, if the latest mainline kernel still fails.
how to use a customized DSDT can be found at:
http://www.lesswatts.org/patches/linux_acpi/
Comment 14 Lavrentiy 2008-08-26 05:46:17 UTC
Created attachment 17461 [details]
After a second s2r using echo mem > /po...

Linux my-desktop 2.6.24-19-generic #1 SMP Wed Aug 20 22:56:21 UTC 2008 i686 GNU/Linux

Ubuntu 8.04.1.
Comment 15 Lavrentiy 2008-08-26 05:48:16 UTC
Created attachment 17462 [details]
Third s2r from Gnome
Comment 16 Lavrentiy 2008-08-26 05:54:52 UTC
But how can it work with ACPI, if Latitude LS does not support ACPI?

Anyway... I need to spend some time to learn how to compile the kernel and install it, it will take 3-4 days I think.

Also sometimes notebook still does not wake with Ubuntu 8.04.1 2.6.24-19 built-in kernel - the situation is the same as I mentioned earlier: black screen, maximum fan speed. I have met this situation one or two times, but now I cant make it "unwoken" even if I try (mentally).

So now I will try to compile in next few days and report here.
Comment 17 Zhang Rui 2008-08-27 02:17:17 UTC
(In reply to comment #16)
> But how can it work with ACPI, if Latitude LS does not support ACPI?
> 
"not support ACPI" doesn't mean that it can never work with ACPI enabled. 
It may work but with all kinds of problems. ACPI highly relies on the hardware/BIOS, if anything is wrong, we can not fix it in software. :(

> Anyway... I need to spend some time to learn how to compile the kernel and
> install it, it will take 3-4 days I think.
okay.
You can download the source code from
http://www.eu.kernel.org/pub/linux/kernel/v2.6/
look for "linux-2.6.26.tar.gz" and click the link to download it.

> 
> Also sometimes notebook still does not wake with Ubuntu 8.04.1 2.6.24-19
> built-in kernel - the situation is the same as I mentioned earlier: black
> screen, maximum fan speed.
so suspend to ram is still not stable in ubuntu kernel, right
Comment 18 Lavrentiy 2008-08-27 02:27:40 UTC
> You can download the source code from

I will look for the kernel, I had done it long time ago, I just need some time - few days. And pretty much time to compile it on this book!


> still not stable in ubuntu kernel, right
It is pretty much stable. Very stable, I would said. No more hangs, but since bug submitted Ubunutu offered me to update kernel two times (and did it). Still 2.6.24-2x.

Anyway for now, as I understand, without my next step it's of no use to bother you with this problem. May be I should have addressed it to Arch team, but I found in Google that it's mostly kernel problem. So I will test and report. Thanks.
Comment 19 ykzhao 2008-08-28 20:14:48 UTC
Created attachment 17518 [details]
test the debug patch

Will you please try the debug patch and see whether the problem still exists?

Thanks.
Comment 20 Zhang Rui 2008-09-09 19:09:58 UTC
Created attachment 17703 [details]
patch: use 32 bit wakeup vector

please try this patch instead of the patch Yakui attached above. :)
Comment 21 Zhang Rui 2008-09-22 00:59:46 UTC
any update?
Comment 22 Zhang Rui 2008-09-26 19:47:48 UTC
ping Lavrentiy 
Comment 23 Lavrentiy 2008-09-27 00:25:18 UTC
I'm sorry, please wait! Sorry, sorry!
Comment 24 Rafael J. Wysocki 2008-09-27 06:11:15 UTC
I've recently got another similar report: http://marc.info/?l=linux-kernel&m=122191225721924&w=4

Please don't close this bug without contacting me first, thanks.
Comment 25 Lavrentiy 2008-10-18 11:11:13 UTC
Zhang Rui, I hoped for arrival of new memory, but I failed with it. So the notebook has 128 mb of memory and I can't compile new kernel with patches.

But I installed Ubuntu Interpid (putting Latitude's HDD into USB of usual computer without Linux) and tried with that (kernel 2.6.27) and the situation is even worse. But in the lack of memory I don't know is it worth of trying or it would be better to throw it in a recycle bin.

Should I gather new information and new debug data or not?
Comment 26 Zhang Rui 2008-10-30 01:41:20 UTC
well, to be honest, as this is a quite old machine, I don't have much confidence to make ACPI work well on it. :(

You said that suspend works on Ubuntu kernel but fails on arch-linux,
you also mentioned that acpi can be enabled on Ubuntu kernel but it must be disabled on arch-linux, right?

I'm sorry but for this bug, I don't know what to do next.
as we only cares for the Upstream & ACPI bug here. and all the fixes are shipped to the upstream kernel.
In order to verify if this is a mainline kernel bug, you need to test the upstream kernel with ACPI enabled first, but ... :(

My opinion is to close this bug as we can not get enough info now.

but we can still wait for the update of http://marc.info/?l=linux-kernel&m=122191225721924&w=4 first. :p

re-assign to Rafael.
Comment 27 Lavrentiy 2008-10-30 04:35:58 UTC
"you also mentioned that acpi can be enabled on Ubuntu kernel"

No, on Ubuntu 8.04 suspend (ACPI) works out-of-the-box.
On 8.10 RC, it does not work, even echo mem >/sys/...

I'm ready to test whatever you wish, but I cannot compile it. Couldn't you provide kernel image or it's too hard? Or please give me a hint where to obtain it.

Thanks anyway.
Comment 28 Zhang Rui 2009-01-04 00:54:13 UTC
Hi, Rafael,
any idea on this problem?
Comment 29 Rafael J. Wysocki 2009-01-04 11:29:46 UTC
Unfortunately not.

I have no access to any piece of affected hardware and it's hard to say what's up without that.

Quite a few people are reporting this issue, but there are no clues.

I suspect some interrupt handling oddness, but it could be anything else as well.
Comment 30 Zhang Rui 2009-01-04 19:20:13 UTC
hi, Lavrentiy,
> on Ubuntu 8.04 suspend (ACPI) works out-of-the-box.
Sorry my English is not good.
do you mean that S3 can or can not work on this laptop with Ubuntu 8.04?
if it can, does this work w/ or w/o ACPI enabled?
Comment 31 Lavrentiy 2009-01-04 22:43:14 UTC
I'm sorry, I don't use neither Linux or Dell Latitude anymore.

Note You need to log in before you can comment on or make changes to this bug.