Bug 11414 - Random crashes with 2.6.27-rc3 on PPC
Random crashes with 2.6.27-rc3 on PPC
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-32
All Linux
: P1 normal
Assigned To: platform_ppc-32
:
Depends on:
Blocks: 10492
  Show dependency treegraph
 
Reported: 2008-08-23 12:05 UTC by Rafael J. Wysocki
Modified: 2008-09-03 22:36 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-23 12:05:25 UTC
Subject    : Random crashes with 2.6.27-rc3 on PPC
Submitter  : Michael Buesch <mb@bu3sch.de>
Date       : 2008-08-23 14:10
References : http://marc.info/?l=linux-kernel&m=121950076812616&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Michael Buesch 2008-08-23 14:20:00 UTC
Please don't flag this as a regression from 2.6.26 too soon. I just reproduced it with 2.6.26. It could also be related to some kconfig options that I never enabled/disabled in the past. So the kernel where it not happens (2.6.25) does actually have a slightly different config than the crashing ones. For example, it has highmem enabled. Which the crashing kernels don't. There are more differences in the config...

I'm still running tests. Unfortunately testing is very time consuming...
Comment 2 Rafael J. Wysocki 2008-08-24 05:54:35 UTC
OK, let's mark it as a regression from 2.6.25, then.
Comment 3 Michael Buesch 2008-08-24 06:10:04 UTC
It turns out that this is possibly related to a -fno-omit-frame-pointer gcc miscompilation that already hit other people. I'm still testing...
So it's not strictly a linux regression at all.

However, it affects 2.6.26 and 2.6.27 at least. I didn't try 2.6.25 with -fno-omit-frame-pointer.
Comment 4 Michael Buesch 2008-08-24 07:11:25 UTC
http://marc.info/?l=linux-kernel&m=121956265019318&w=4
Comment 5 Michael Buesch 2008-08-24 07:12:34 UTC
whoops, didn't want to post this one :( Sorry for the noise.
Comment 6 Michael Buesch 2008-08-24 07:36:44 UTC
Workaround for PowerPC (possibly breaks other archs):

http://marc.info/?l=linux-kernel&m=121958694215835&w=4
Comment 7 Adrian Bunk 2008-09-03 22:36:32 UTC
fixed by commit 7563dc64585324f443f5ac107eb6d89ee813a2d2

Note You need to log in before you can comment on or make changes to this bug.