Bug 11413 - get_rtc_time() triggers NMI watchdog in hpet_rtc_interrupt()
Summary: get_rtc_time() triggers NMI watchdog in hpet_rtc_interrupt()
Status: CLOSED CODE_FIX
Alias: None
Product: Timers
Classification: Unclassified
Component: Realtime Clock (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: timers_realtime-clock
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-23 12:00 UTC by Rafael J. Wysocki
Modified: 2008-08-30 14:03 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-23 12:00:26 UTC
Subject    : [BUG] get_rtc_time() triggers NMI watchdog in hpet_rtc_interrupt()
Submitter  : Mikael Pettersson <mikpe@it.uu.se>
Date       : 2008-08-23 9:48
References : http://marc.info/?l=linux-kernel&m=121948503224161&w=4
Handled-By : Ingo Molnar <mingo@elte.hu>
Patch      : http://marc.info/?l=linux-kernel&m=121950734922457&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 David Brownell 2008-08-23 12:22:43 UTC
See also Bug #11153 and its patch ... the short version of the story is that the "HPET Emulation" of RTC interrupts really should not be used.  The real RTC interrupts are routed through SCI, which seems to give *TWO* ways to get them without emulation:  (a) through ACPI's somewhat flakey IRQ delegation scheme, although that bypasses genirq; and (b) by hanging the RTC irq handler off SCI, along with ACPI.  The virtue of (a) is that it needs to be done anyway to have RTC events wake from system sleep states like S3 and S4.

Note You need to log in before you can comment on or make changes to this bug.