Bug 11406 - patch "x86: MOVE PCI IO ECS code to x86/pci" breaks CPU hotplug
patch "x86: MOVE PCI IO ECS code to x86/pci" breaks CPU hotplug
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: Robert Richter
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-22 14:59 UTC by Rafael J. Wysocki
Modified: 2008-08-25 14:13 UTC (History)
3 users (show)

See Also:
Kernel Version: commit 3a27dd1ce5de08e21e0266ddf00e6f1f843bfe8b
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-22 14:59:31 UTC
Subject    : patch "x86: MOVE PCI IO ECS code to x86/pci" breaks CPU hotplug
Submitter  : "Jan Beulich" <jbeulich@novell.com>
Date       : 2008-08-21 12:59
References : http://marc.info/?l=linux-kernel&m=121932366326572&w=4
Handled-By : Ingo Molnar <mingo@elte.hu>
Handled-By : Robert Richter <robert.richter@amd.com>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-22 15:00:34 UTC
Caused by:

commit 3a27dd1ce5de08e21e0266ddf00e6f1f843bfe8b
Author: Robert Richter <robert.richter@amd.com>
Date:   Thu Jun 12 20:19:23 2008 +0200

    x86: Move PCI IO ECS code to x86/pci
    
    "Form follows function". Code is now where it belongs to.
    
    Signed-off-by: Robert Richter <robert.richter@amd.com>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>
Comment 2 Robert Richter 2008-08-25 02:26:18 UTC
Has been fixed with this patch:

http://marc.info/?l=linux-kernel&m=121965501429621&w=4

-Robert
Comment 3 Ingo Molnar 2008-08-25 02:31:54 UTC
(reopened the bug - we only close it once we know the upstream SHA1 of the commit.)
Comment 4 Rafael J. Wysocki 2008-08-25 04:13:27 UTC
On Monday, 25 of August 2008, bugme-daemon@bugzilla.kernel.org wrote:
> ------- Comment #3 from mingo@elte.hu  2008-08-25 02:31 -------
> (reopened the bug - we only close it once we know the upstream SHA1 of the
> commit.)

In fact you could leave it as 'resolved', that doesn't affect the list of regressions.

However, the bug should only be marked as 'closed' if the commit name (SHA1)
of the patch in the Linus' tree is known.


Note You need to log in before you can comment on or make changes to this bug.