Bug 11405 - 2.6.27-rc3 segfault on cold boot; not on warm boot.
2.6.27-rc3 segfault on cold boot; not on warm boot.
Status: CLOSED OBSOLETE
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-22 14:56 UTC by Rafael J. Wysocki
Modified: 2012-05-22 13:48 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc3
Tree: Mainline
Regression: No


Attachments

Description Rafael J. Wysocki 2008-08-22 14:56:24 UTC
Subject    : Regression? 2.6.27-rc3 segfault on cold boot; not on warm boot.
Submitter  : David Greaves <david@dgreaves.com>
Date       : 2008-08-21 9:45
References : http://marc.info/?l=linux-kernel&m=121931198904777&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 David Greaves 2008-08-29 14:03:02 UTC
It turns out I made a config change - I had a problem recently with a CDROM drive and I was pointed at the libata pata drivers. So I did CONFIG_IDE=n

When I do CONFIG_HAVE_IDE=y the segfault on coldboot no longer seems to be appearing on 2.6.27-rc4

It's not a regression though - I went back to  2.6.25.14 to find a safe place to start the bisect and had the coldboot segfault
(I'm not authorised to untick regression)
Comment 2 Thomas Gleixner 2008-09-04 14:19:02 UTC
So the segfaults and XFS oddities only happen with CONFIG_IDE=n ?

I reassign that to the storage folks.
Comment 3 Bartlomiej Zolnierkiewicz 2008-09-04 15:39:34 UTC
Re-assigning to the right folks for CONFIG_IDE=n.
Comment 4 Alan 2008-09-04 16:35:09 UTC
Doubt its the right place but we shall see

Please build a kernel with 8K stacks and report if that behaves

Note You need to log in before you can comment on or make changes to this bug.