Bug 11402 - skbuff bug?
Summary: skbuff bug?
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jeff Garzik
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-22 14:30 UTC by Rafael J. Wysocki
Modified: 2008-08-27 14:30 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-22 14:30:30 UTC
Subject    : skbuff bug?
Submitter  : "Yinghai Lu" <yhlu.kernel@gmail.com>
Date       : 2008-08-21 3:56
References : http://marc.info/?l=linux-kernel&m=121929102707658&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-22 14:31:13 UTC
Reportedly caused by

commit f8d59f7826aa73c5e7682fbed6db38020635d466
Author: Bruce Allan <bruce.w.allan@intel.com>
Date:   Fri Aug 8 18:36:11 2008 -0700

    e1000e: test for unusable MSI support

    Some systems do not like 82571/2 use of 16-bit MSI messages and some
    other systems claim to support MSI, but neither really works.  Setup a
    test MSI handler to detect whether or not MSI is working properly, and
    if not, fallback to legacy INTx interrupts.

    Signed-off-by: Bruce Allan <bruce.w.allan@intel.com>
    Signed-off-by: Jeff Kirsher <jeffrey.t.kirsher@intel.com>
    Signed-off-by: Jeff Garzik <jgarzik@redhat.com>
Comment 2 Yinghai Lu 2008-08-22 14:43:56 UTC
On Fri, Aug 22, 2008 at 2:31 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11402
>
>
> rjw@sisk.pl changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |bruce.w.allan@intel.com
>

change msleep(50) to msleep(100) seems fix the problem.

YH
Comment 3 Rafael J. Wysocki 2008-08-27 14:29:12 UTC
On Tuesday, 26 of August 2008, Yinghai Lu <yhlu.kernel@gmail.com> wrote:
> On Tue, Aug 26, 2008 at 3:17 AM, Jeff Kirsher
> <jeffrey.t.kirsher@intel.com> wrote:
> > On Tue, Aug 26, 2008 at 2:17 AM, Evgeniy Polyakov <johnpol@2ka.mipt.ru>
> wrote:
> >> Hi.
> >>
> >> On Thu, Aug 21, 2008 at 04:46:49PM -0700, Yinghai Lu
> (yhlu.kernel@gmail.com) wrote:
> >>> it seems caused by
> >>>
> >>> commit f8d59f7826aa73c5e7682fbed6db38020635d466
> >>> Author: Bruce Allan <bruce.w.allan@intel.com>
> >>> Date:   Fri Aug 8 18:36:11 2008 -0700
> >>>
> >>>     e1000e: test for unusable MSI support
> >>
> >> Intel folks seems to be on vacations or whatever else without access to
> >> the mail. Can you confirm that bug still exists in the latest tree and
> >> reverting this commit fixes the problem?
> >>
> >> --
> >>        Evgeniy Polyakov
> >> --
> >
> > We are looking into the issue, I am sorry there has been no response until
> now.
> >
> > I am still curious if you still see the issue with all the recent
> > changes.  Please provide the device id you are using and system info
> > so that we can try and reproduce the issue, if the issue persists with
> > the latest git tree.
> 
> can not duplicate any more...

Note You need to log in before you can comment on or make changes to this bug.