Bug 11394 - ath9k do not support wpa2
ath9k do not support wpa2
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 11459
  Show dependency treegraph
 
Reported: 2008-08-21 15:03 UTC by Alexey Kuznetsov
Modified: 2008-09-13 15:19 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27.rc4
Tree: Mainline
Regression: ---


Attachments
ath9k (1.94 KB, application/octet-stream)
2008-08-21 15:04 UTC, Alexey Kuznetsov
Details
madwifi (6.81 KB, application/octet-stream)
2008-08-21 15:04 UTC, Alexey Kuznetsov
Details
config-2.6.25.14-108.fc9.i686 (84.45 KB, text/plain)
2008-08-22 13:55 UTC, Alexey Kuznetsov
Details
config 2.6.27.rc4 (86.44 KB, text/plain)
2008-08-23 00:47 UTC, Alexey Kuznetsov
Details
ath9k-seqno.patch (2.51 KB, patch)
2008-09-03 16:07 UTC, John W. Linville
Details | Diff

Description Alexey Kuznetsov 2008-08-21 15:03:46 UTC
i have macbook pro with AR5418, and DWL-700AP access point. I try two driverd madwifi (trunk 3844) and ath9k driver from 2.6.27.rc4.
Comment 1 Alexey Kuznetsov 2008-08-21 15:04:36 UTC
Created attachment 17365 [details]
ath9k

wireshark
Comment 2 Alexey Kuznetsov 2008-08-21 15:04:55 UTC
Created attachment 17366 [details]
madwifi

wireshark
Comment 3 Luis R. Rodriguez 2008-08-22 11:46:24 UTC
ath9k *does support WPA2*. Can you describe a little more in depth your current setup? How are you trying to connect to the Access Point? Do you use Network Manager?
Comment 4 Alexey Kuznetsov 2008-08-22 13:54:50 UTC
i have fedora 9 + git kernel 2.6.27.rc4 with fedora kernel config (config-2.6.25.14-108.fc9.i686 finely loaded by make xconfig).

After reboot my machine i got NetworkManager notify about new network, and he try autoconnect to network called "wifi.tax.local".

wifi.tax.local is DWL-700AP configured as access point with WPA2-PSK authentication.

With madwifi driver (trunk version) i have well worked wifi connection with same kernel 2.6.27.rc4. After i switch to ath9k driver he only show persist of network but no possible to connect.

ath9k dmesg output:

wlan0: authenticate with AP 00:1c:f0:bd:01:06
wlan0: authenticate with AP 00:1c:f0:bd:01:06
wlan0: authenticated
wlan0: associate with AP 00:1c:f0:bd:01:06
wlan0: RX AssocResp from 00:1c:f0:bd:01:06 (capab=0x11 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: disassociating by local choice (reason=3)
wlan0: authenticate with AP 00:1c:f0:bd:01:06
wlan0: authenticate with AP 00:1c:f0:bd:01:06
wlan0: authenticate with AP 00:1c:f0:bd:01:06
wlan0: authentication with AP 00:1c:f0:bd:01:06 timed out
wlan0: no IPv6 routers present
sky2 eth0: Link is down.
sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
wlan0: authenticate with AP 00:1c:f0:bd:01:06
wlan0: authenticate with AP 00:1c:f0:bd:01:06
wlan0: authenticated
wlan0: associate with AP 00:1c:f0:bd:01:06
wlan0: RX AssocResp from 00:1c:f0:bd:01:06 (capab=0x11 status=0 aid=1)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
[axet@axet-laptop ~]$ 





[axet@axet-laptop ~]$ iwlist  scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:1C:F0:BD:01:06
                    ESSID:"wifi.tax.local"
                    Mode:Master
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=79/100  Signal level:-44 dBm  Noise level=-95 dBm
                    Encryption key:on
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=000000084c58d1b1
                    Extra: Last beacon: 74ms ago

pan0      Interface doesn't support scanning.

virbr0    Interface doesn't support scanning.

[axet@axet-laptop ~]$ 

Comment 5 Alexey Kuznetsov 2008-08-22 13:55:16 UTC
Created attachment 17378 [details]
config-2.6.25.14-108.fc9.i686
Comment 6 Alexey Kuznetsov 2008-08-22 13:58:57 UTC
In packet sniffing utility you can see madwifi driver have successfully connected packets. And for ath9k sniff packets you can see ath9k try to send key, but access point do not accept.

When i try to set my access point as Open Network. I have other strange effect. Connection well established and i can sniff it by command 'tcpdump -i wlan0'. In tcpdump output i can see all broadcast packets from my server (iip, samba and other). But i still can't get ip address by dhcpd driver! Look like packets from my machine do not leave hosts...
Comment 7 John W. Linville 2008-08-22 16:31:10 UTC
FWIW, that kernel doesn't have ath9k.
Comment 8 Alexey Kuznetsov 2008-08-23 00:47:44 UTC
Created attachment 17380 [details]
config 2.6.27.rc4

with ath9k
Comment 9 Alexey Kuznetsov 2008-08-23 00:49:54 UTC
config-2.6.25.14-108.fc9.i686 - original config to load trough make xconfig;

.config - result config, after i change checkbox.
Comment 10 Nicolas Reinecke 2008-08-25 11:42:29 UTC
I use ath9k on a macbook pro 2.2 and it works with wpa2-psk aes (not tryed other settings).
I use ubuntu intrepid with 2.6.27-rc4 + ath9k patches form wireless mailinglist
you can get them here:
http://w1.fi/wireless-testing/   (11. & 14.Aug)
Comment 11 Alexey Kuznetsov 2008-08-25 12:38:46 UTC
I tried booth git-kerenl 2.6.27-rc4 and fedora 2.6.27-rc4 build. Same issues.

Can you provide more details about?
Comment 12 Alexey Kuznetsov 2008-08-25 12:44:27 UTC
as i konw wireless-testing already merged to -rc4 kernel.
Comment 13 Nicolas Reinecke 2008-08-26 04:55:39 UTC
I use the linux-2.6 git kernel and NetworkManager.

This patches are not merged to wireless-testing.
http://w1.fi/wireless-testing/series
I applied the patches from 11 & 14.Aug to linux-2.6 git.
Comment 14 Alexey Kuznetsov 2008-08-26 10:44:23 UTC
yep, these paches help me also. thx

when they wille be available in linux-2.6 git ?
Comment 15 Luis R. Rodriguez 2008-08-26 11:24:32 UTC
Not sure exactly what patch would have fixed this.. as WPA2 *was* and *has* been working. I can't say for sure on Power Book as I wasn't testing on that. But I'd be curious as to exactly what patch fixed it.

Alexey, if you have time can you bisect the patches to see which one fixes it? Whatever fixed it should be pushed for sure onto 2.6.27-rcx.

Comment 16 Alexey Kuznetsov 2008-08-26 12:03:41 UTC
All of these patches applied to ath9k/ directory and signed by @atheros.com team. Probably all of them must be applied.


[axet@axet-laptop linux-2.6]$ git checkout
M	drivers/net/wireless/ath9k/ath9k.h
M	drivers/net/wireless/ath9k/beacon.c
M	drivers/net/wireless/ath9k/core.c
M	drivers/net/wireless/ath9k/core.h
M	drivers/net/wireless/ath9k/hw.c
M	drivers/net/wireless/ath9k/hw.h
M	drivers/net/wireless/ath9k/main.c
M	drivers/net/wireless/ath9k/phy.h
M	drivers/net/wireless/ath9k/rc.c
M	drivers/net/wireless/ath9k/recv.c
M	drivers/net/wireless/ath9k/xmit.c
M	include/linux/ieee80211.h
[axet@axet-laptop linux-2.6]$ 
Comment 17 Luis R. Rodriguez 2008-08-26 12:09:43 UTC
Yeah the Atheros team is doing a great job with patching ath9k :)

I am curious though if you have some free time, can you try just a few patches to see which one may have fixed your issue?
Comment 18 Alexey Kuznetsov 2008-08-26 12:57:04 UTC
I will try to look first, then to apply. Each build take about 40 min.
Comment 19 Alexey Kuznetsov 2008-08-26 15:52:04 UTC
I tried apply paches in this sequince:

first 	
cat sujith-1-*

second

cat sujith-2-0* | patch -p1
cat ath9k-beacon.patch  | patch -p1

then

cat ath9k-txctl.patch  | patch -p1

then

cat ath9k-tx-status.patch | patch  -p1

then

cat ath9k-seqnum.patch  | patch -p1

bingo!!

after, i tried just last one and by hand solve rejection in core.* files. then i ignore beacon.* rej files.

and also have success. but i have problem with insert/remove modules to kernel. after trid time of intert/remove i got my pc stucked.
Comment 20 John W. Linville 2008-09-03 16:07:55 UTC
Created attachment 17605 [details]
ath9k-seqno.patch

Could you try this patch alone on top of the current wireless-2.6 tree?

   git://git.kernel.org/pub/scm/linux/kernel/git/linville/wireless-2.6.git

Does that also resolve the issue?
Comment 21 Nicolas Reinecke 2008-09-04 03:34:09 UTC
works for me against linux-2.6 git.
Comment 22 Alexey Kuznetsov 2008-09-04 04:40:27 UTC
wireless-2.6.git + ath9k-seqno.patch work fine... and look like more better then just comment 19 patch. wireless build catchup wifi connection from first attempt.
Comment 23 Adrian Bunk 2008-09-13 15:19:04 UTC
fixed by commit 69da6b87fcb270f758fe75141c32e041f8db510c

Note You need to log in before you can comment on or make changes to this bug.