Bug 113891 - [radeon] Display jitter
Summary: [radeon] Display jitter
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-07 14:29 UTC by Jean Delvare
Modified: 2016-07-18 08:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.4.4, 4.5-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Jean Delvare 2016-03-07 14:29:01 UTC
Since updating to kernel v4.4.4 (from v4.4.3), I get vertical jitter on my display with almost every boot. The picture moves up and down with black horizontal stripes. This makes the system pretty much unusable.

I bisected it to the following commit:

http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?h=linux-4.4.y&id=a83b349814dee660caff0a40a22ac2f166c94a8b

drm/radeon/pm: adjust display configuration after powerstate

I am now running v4.4.4 with this commit reverted and so far so good. My hardware:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670] [1002:6758] (Sapphire HD 6670)
Comment 1 Jean Delvare 2016-03-08 08:46:29 UTC
Kernel v4.5-rc7 is affected too.
Comment 2 Alex Deucher 2016-03-08 16:33:20 UTC
I'll just revert it for now.  Sorry for the breakage.
Comment 3 Jean Delvare 2016-03-09 09:42:00 UTC
OK, thanks Alex.

Note You need to log in before you can comment on or make changes to this bug.