Bug 113831 - Suspend fails - 11,4 and 11,5 Macbook Pros
Summary: Suspend fails - 11,4 and 11,5 Macbook Pros
Status: CLOSED DUPLICATE of bug 103211
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Chen Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-06 15:53 UTC by rockon999
Modified: 2016-05-16 21:18 UTC (History)
16 users (show)

See Also:
Kernel Version: 4.4.1
Tree: Mainline
Regression: No


Attachments

Description rockon999 2016-03-06 15:53:14 UTC
While this issue has been discussed in Bug 101681, this report was meant for the 12,1 and the issues are obviously different as the solutions for the 12,1 do not work for 11,4 and 11,5.

When the laptop attempts to suspend the screen goes black, the fans speed up, and the laptop becomes extremely hot.

I'm willing to provide any additional needed information.
Comment 1 Naftuli Tzvi Kay 2016-03-13 21:52:11 UTC
Poweroff and suspend do not work on 11,4 and 11,5 models. This appears to be fixed in 12,1 models with a recent kernel, but since 11,4 and 11,5 have different hardware, the bug is still present.
Comment 2 Chen Yu 2016-05-11 07:45:36 UTC
The suspend failure is of the same reason as poweroff, in which case the pci re-assignment has broken the acpi region. So please move to https://bugzilla.kernel.org/show_bug.cgi?id=103211

*** This bug has been marked as a duplicate of bug 103211 ***

Note You need to log in before you can comment on or make changes to this bug.