Bug 113751 - Can not wake up from suspend - MacBook Pro 15 inch (Mid 2015)
Summary: Can not wake up from suspend - MacBook Pro 15 inch (Mid 2015)
Status: CLOSED DUPLICATE of bug 103211
Alias: None
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Chen Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-05 07:03 UTC by hamza
Modified: 2016-05-18 06:42 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.4.4
Tree: Mainline
Regression: No


Attachments
acpidump output (347.88 KB, text/plain)
2016-05-11 18:44 UTC, hamza
Details
dmesg output (68.03 KB, text/plain)
2016-05-11 18:44 UTC, hamza
Details
wakeup output (476 bytes, text/plain)
2016-05-11 18:44 UTC, hamza
Details
pm-suspend log (7.72 KB, text/x-log)
2016-05-11 18:45 UTC, hamza
Details

Description hamza 2016-03-05 07:03:50 UTC
I have installed Arch Linux (Testing) on my Macbook Pro 15 inch laptop and suspend does not work. When closing the lid or issuing suspend from the command line, it appears to suspend, but does not allow the machine to wake up. The only way to get it back is to hold down the power to force a shutdown.  

Steps to Reproduce
Close lid or type systemctl suspend

Expected Results:
Suspend and allow to resume

Actual Results: 
Does not allow to resume from suspend

Additional Information:
There are related bugs that have been filed. But they are a mixed bag of issues and none mentioned the 15 inch Macbook (just the 12 inch).

I have also tried with disabling wifi drivers before trying to suspend, which had no effect. 

Please let me know if you need any logs. I have looked at them and it says it is suspending correctly, so I assume the problem is with handling the wakeup request.

Thanks
Hamza
Comment 1 Chen Yu 2016-05-11 07:50:59 UTC
Please provide
cat /proc/acpi/wakeup
and 
# acpidump > acpidump.txt
$ dmesg > dmesg.txt

thanks.
Comment 2 hamza 2016-05-11 18:44:00 UTC
Created attachment 215951 [details]
acpidump output
Comment 3 hamza 2016-05-11 18:44:30 UTC
Created attachment 215961 [details]
dmesg output
Comment 4 hamza 2016-05-11 18:44:56 UTC
Created attachment 215971 [details]
wakeup output
Comment 5 hamza 2016-05-11 18:45:15 UTC
Created attachment 215981 [details]
pm-suspend log
Comment 6 hamza 2016-05-11 18:47:36 UTC
Hi Chen Yu.

Thanks for looking into this problem. This is the only thing that is stopping me moving from OSX.

I have attached all the files you requested. Anything else please let me know.

Thanks.

Kind Regards
Hamza Khan-Cheema
Comment 7 Chen Yu 2016-05-18 02:06:47 UTC
Is your mac of this type:
MacBook Pro (Retina, 15-inch, Mid 2015)?
So it is a MacbookPro 11,4 or MacbookPro 11,5, which is already tracked at:
https://bugzilla.kernel.org/show_bug.cgi?id=103211
suspend and poweroff does not work on this platform yet, I'm trying to spend some time to continue do some investigation on this.
Comment 8 Chen Yu 2016-05-18 02:08:38 UTC
https://support.apple.com/en-us/HT201300
Comment 9 hamza 2016-05-18 06:37:42 UTC
Hi Chen Yu

Yes it is a Macbook Pro 11,4 model. 

Is the problem with suspend and power off the same? I thought they might be different which is why I filed a new bug report. If you think they are the same issue, please feel free to mark this as a duplicate and close.

Thanks for looking into this, much appreciated.  

Let me know if you need me to do any debugging.

Kind Regards
Hamza
Comment 10 Chen Yu 2016-05-18 06:42:09 UTC
(In reply to hamza from comment #9)
> Hi Chen Yu
> 
> Yes it is a Macbook Pro 11,4 model. 
> 
> Is the problem with suspend and power off the same? 
Yes, both the suspend and poweroff need to access the ACPI region to set the corresponding registers, however the ACPI io region has been broken by pci io reassignment during bootup. Please move to that thread, thanks.

*** This bug has been marked as a duplicate of bug 103211 ***

Note You need to log in before you can comment on or make changes to this bug.