Bug 11355 - Regression in 2.6.27-rc2 when cross-building the kernel
Summary: Regression in 2.6.27-rc2 when cross-building the kernel
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_i386
URL:
Keywords:
: 11501 (view as bug list)
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-16 12:33 UTC by Rafael J. Wysocki
Modified: 2008-09-22 15:01 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-16 12:33:42 UTC
Subject    : Regression in 2.6.27-rc2 when cross-building the kernel
Submitter  : Larry Finger <Larry.Finger@lwfinger.net>
Date       : 2008-08-16 2:38
References : http://marc.info/?l=linux-kernel&m=121885432118368&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-17 05:35:12 UTC
On Saturday, 16 of August 2008, Larry Finger wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=11355
> > Subject             : Regression in 2.6.27-rc2 when cross-building the
> kernel
> > Submitter   : Larry Finger <Larry.Finger@lwfinger.net>
> > Date                : 2008-08-16 2:38 (1 days old)
> > References  : http://marc.info/?l=linux-kernel&m=121885432118368&w=4
> 
> Yes, bug is still present.
Comment 2 Rafael J. Wysocki 2008-08-20 06:17:28 UTC
Handled-by: Sam Ravnborg <sam@ravnborg.org>
Handled-by: David Woodhouse <dwmw2@infradead.org>
Comment 3 Rafael J. Wysocki 2008-08-24 11:02:50 UTC
I'm seeing a related problem (again).

Namely, I build kernels on one box, with 'make O=<target>', then I mount <target> on another one over NFS, cd to it and try to install the kernel modules with 'make modules_install'.  This results in 'HOSTCC firmware/ihex2fw' and 'fatal error: ...: Read-only file system'.  Readily reproducible.
Comment 4 Rafael J. Wysocki 2008-08-24 11:25:51 UTC
Commenting out line 1130 of Makefile
("$(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modinst")
obviously helps.

David, could you fix Makefile.fwinst ASAP, please?
Comment 5 Rafael J. Wysocki 2008-08-24 14:27:20 UTC
Handled-By: Sam Ravnborg <sam@ravnborg.org>
Handled-By: David Woodhouse <dwmw2@infradead.org>
Comment 6 Rafael J. Wysocki 2008-08-27 05:42:01 UTC
OK, I know what happens in my case.

The 'target' box has a different system than the server (OpenSUSE 11.0 vs OpenSUSE 10.3) and .ihex2fw.cmd generated on the server contains dependencies on files that are not present on the 'target' client.

I can 'fix' the problem by manually removing the dependencies on GCC headers (there's a different version of GCC on the 'target' machine) and on the headers in /usr/include/asm-x86_64 from the target's .ihex2fw.cmd .  Still, it would have been nice if those dependencies had not been there at all. ;-)
Comment 7 Rafael J. Wysocki 2008-08-30 14:43:21 UTC
On Saturday, 30 of August 2008, Larry Finger wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=11355
> > Subject             : Regression in 2.6.27-rc2 when cross-building the
> kernel
> > Submitter   : Larry Finger <Larry.Finger@lwfinger.net>
> > Date                : 2008-08-16 2:38 (15 days old)
> > References  : http://marc.info/?l=linux-kernel&m=121885432118368&w=4
> > Handled-By  : Sam Ravnborg <sam@ravnborg.org>
> >               David Woodhouse <dwmw2@infradead.org>
> 
> Not fixed yet.
Comment 8 David Woodhouse 2008-09-01 03:09:55 UTC
Potential fix at http://lkml.org/lkml/2008/9/1/69 and in 
 git.infradead.org/users/dwmw2/random-2.6.git
Comment 9 Rafael J. Wysocki 2008-09-01 05:04:32 UTC
Patch : http://lkml.org/lkml/2008/9/1/69
Comment 10 Adrian Bunk 2008-09-02 12:41:04 UTC
fixed by commit 1cede1affb3cc5a9520fdbc75b3fbaa6432cbc5a
Comment 11 Rafael J. Wysocki 2008-09-22 15:01:49 UTC
*** Bug 11501 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.