Bug 11342 - Linux 2.6.27-rc3: kernel BUG at mm/vmalloc.c - bisected
Summary: Linux 2.6.27-rc3: kernel BUG at mm/vmalloc.c - bisected
Status: CLOSED CODE_FIX
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-14 09:13 UTC by Rafael J. Wysocki
Modified: 2008-08-25 14:45 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-14 09:13:22 UTC
Subject    : Linux 2.6.27-rc3: kernel BUG at mm/vmalloc.c - bisected
Submitter  : "Alan D. Brunelle" <Alan.Brunelle@hp.com>
Date       : 2008-08-13 23:03
References : http://marc.info/?l=linux-kernel&m=121866876027629&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-14 13:23:40 UTC
On Thursday, 14 of August 2008, Alan D. Brunelle wrote:
> Rafael J. Wysocki wrote:
> > On Thursday, 14 of August 2008, Alan D. Brunelle wrote:
> >> I ran into this trying 2.6.27-rc3 today:
> >>
> >> [6.461876] kernel BUG at mm/vmalloc.c:217!
> >>
> >> (full boot log attached)
> >>
> >> I bisected it to:
> >>
> >> git-bisect bad 1c89ac55017f982355c7761e1c912c88c941483d
> >>
> >> which is:
> >>
> >> commit 1c89ac55017f982355c7761e1c912c88c941483d
> >> Merge: 88fa08f... b1b135c...
> >> Author: Linus Torvalds <torvalds@linux-foundation.org>
> >> Date:   Tue Aug 12 08:40:19 2008 -0700
> >>
> >>     Merge
> >> git://git.kernel.org/pub/scm/linux/kernel/git/rusty/linux-2.6-for-linus
> > 
> > This is a merge commit that introduced several changes into the
> > kernel.  It would be helpful to search through these changes.
> 
> I came in this morning, and did a 'git bisect reset' and 'git pull'
> built, and everything booted fine. I don't know if some fix came in for
> something else, or if the problem got "hidden" (some sort of timing
> thing, so the problem still lurks).
Comment 2 Alan D. Brunelle 2008-08-19 08:00:16 UTC
As of 1fca25427482387689fa27594c992a961d98768f this problem has resurfaced. Backing out the previous bisected merge problem (1c89ac55017f982355c7761e1c912c88c941483d) the system does boot. 

If someone could give me directions as to how to break apart that single merge, I could try to narrow things down.
Comment 3 Rafael J. Wysocki 2008-08-22 15:18:53 UTC
Handled-By : Andrew Morton <akpm@linux-foundation.org>
Comment 4 Rafael J. Wysocki 2008-08-24 14:04:13 UTC
References : http://lkml.org/lkml/2008/8/23/161
Comment 5 Adrian Bunk 2008-08-25 14:44:58 UTC
fixed by commit d25e26b61d59370eee8b7f2634641eb0fa76e952

Note You need to log in before you can comment on or make changes to this bug.