Bug 11341 - 2.6.27-rc1 - ext4 e2fsck false prompting for fixing i_size of Inode
Summary: 2.6.27-rc1 - ext4 e2fsck false prompting for fixing i_size of Inode
Status: CLOSED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: ext4 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: fs_ext4@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-14 09:08 UTC by Rafael J. Wysocki
Modified: 2008-08-17 07:27 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: Yes


Attachments
Patch to fix e2fsck bug (1.35 KB, patch)
2008-08-17 06:47 UTC, Theodore Tso
Details | Diff

Description Rafael J. Wysocki 2008-08-14 09:08:18 UTC
Subject    : [BUG] 2.6.27-rc1 - ext4 e2fsck false prompting for fixing i_size of Inode
Submitter  : Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
Date       : 2008-08-13 6:56
References : http://marc.info/?l=linux-kernel&m=121861058720051&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Theodore Tso 2008-08-17 06:47:44 UTC
Created attachment 17281 [details]
Patch to fix e2fsck bug

This isn't a kernel bug, but thanks for calling it to my attention.  The fix has been checked into the e2fsprogs maint branch, and will be in e2fsprogs 1.41.1
Comment 2 Kamalesh Babulal 2008-08-17 07:27:50 UTC
Thanks,the patch from Theodore Tso fixes the e2fsck false prompting.

Note You need to log in before you can comment on or make changes to this bug.