Bug 113351 - i7-6500U CPU on Thinkpad X1 Yoga does not boot without intel_pstate=no_hwp
Summary: i7-6500U CPU on Thinkpad X1 Yoga does not boot without intel_pstate=no_hwp
Status: CLOSED DUPLICATE of bug 110941
Alias: None
Product: Power Management
Classification: Unclassified
Component: intel_pstate (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Chen Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-27 22:51 UTC by Mario Geiger
Modified: 2016-04-01 03:22 UTC (History)
7 users (show)

See Also:
Kernel Version: 4.4
Tree: Mainline
Regression: No


Attachments

Description Mario Geiger 2016-02-27 22:51:04 UTC
Does not boot until I put GRUB_CMDLINE_LINUX="intel_pstate=no_hwp" for grub parameter.
Comment 1 Jacek Bajor 2016-02-28 13:43:31 UTC
I am experiencing the same issue with kernel 4.5.0.rc4.
Comment 2 Chen Yu 2016-02-29 02:42:06 UTC
could you please test with:
boot kernel with intel_pstate=no_hwp


# modprobe msr

# rdmsr 0x770
0
# wrmsr 0x773 0
# rdmsr 0x773

# wrmsr ox770 1 

does it hang?

I suspect this is related to 
https://bugzilla.kernel.org/show_bug.cgi?id=110941
Comment 3 Jacek Bajor 2016-02-29 12:59:35 UTC
The machine did not hang right after executing command, but froze completely a minute later when I pressed the mute button.
Comment 4 Mario Geiger 2016-02-29 13:38:55 UTC
# modprobe msr
# rdmsr 0x770
0
# wrmsr 0x773 0
# rdmsr 0x773
0
# wrmsr 0x770 1 
[hang immediately]
Comment 5 Srinivas Pandruvada 2016-03-01 17:16:52 UTC
Can you try to boot with idle=nomwait and see if you can boot (without intel_pstate=no_hwp or intel_pstate=disable)?
Comment 6 Jacek Bajor 2016-03-02 00:11:12 UTC
I could not boot with idle=nomwait option.
Comment 7 Lubko 2016-03-09 10:27:04 UTC
most likely a duplicate of #110941
https://bugzilla.kernel.org/show_bug.cgi?id=110941
Comment 8 Chen Yu 2016-03-15 06:54:10 UTC

*** This bug has been marked as a duplicate of bug 110941 ***

Note You need to log in before you can comment on or make changes to this bug.