Bug 113161 - realtek wifi rtl8723bs (SDIO) not supported (out of tree module)
Summary: realtek wifi rtl8723bs (SDIO) not supported (out of tree module)
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 113151
  Show dependency tree
 
Reported: 2016-02-25 19:15 UTC by dan.g.tob
Modified: 2017-10-05 14:10 UTC (History)
8 users (show)

See Also:
Kernel Version: 4.11RC1
Tree: Mainline
Regression: No


Attachments

Description dan.g.tob 2016-02-25 19:15:09 UTC
code is currently out of tree
https://github.com/hadess/rtl8723bs?files=1
Comment 1 Larry Finger 2016-02-26 15:40:28 UTC
The driver in that tree only works with patches to the kernel that are included in that repo. So far, no one has taken the time to convert the vendor's peculiar code into the form necessary for the driver to meet even the low standards of the staging tree. You will need to clone that repo and build your own driver.
Comment 2 carlos.valin 2016-07-01 01:45:13 UTC
WORKAROUND: sudo apt-get install build-essential linux-headers-generic git
git clone https://github.com/hadess/rtl8723as.git
cd rtl8723as
make
sudo make install
sudo depmod -a
sudo modprobe r8723bs
Comment 3 Larry Finger 2016-11-09 15:29:29 UTC
I had forgotten that this bug was open. It should be closed as INVALID as it is not really a bug. Thus far, no one has done the work needed to get this really awful code into anything that could be merged, even in staging.

One additional problem is that the driver only works on devices attached to BayTrail processors. Most CherryTrail systems do not recognize the device.

The concern of the OP is real, but not having a driver in the kernel is a deficiency, not a bug.
Comment 4 dan.g.tob 2017-05-30 05:32:10 UTC
8723be wifi driver has been merged into staging for 4.12. currently very broken, but this bug is about merging only.
Comment 5 Mikhail Novosyolov 2017-10-05 14:10:09 UTC
it stopped working starting from 4.14 (regression) https://bugzilla.kernel.org/show_bug.cgi?id=197137

Note You need to log in before you can comment on or make changes to this bug.