Bug 11301 - Recent snapshots fail to build with CONFIG_ITCO_WDT but without CONFIG_ITCO_VENDOR_SUPPORT
Recent snapshots fail to build with CONFIG_ITCO_WDT but without CONFIG_ITCO_V...
Status: RESOLVED DUPLICATE of bug 11294
Product: Drivers
Classification: Unclassified
Component: Watchdog
All Linux
: P1 normal
Assigned To: drivers_watchdog@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-10 12:24 UTC by Ben Gamari
Modified: 2008-08-10 13:12 UTC (History)
1 user (show)

See Also:
Kernel Version: v2.6.27-rc2
Tree: Mainline
Regression: Yes


Attachments
A sample patch, almost certainly incorrect (611 bytes, patch)
2008-08-10 12:25 UTC, Ben Gamari
Details | Diff

Description Ben Gamari 2008-08-10 12:24:27 UTC
It seems that there should be an #ifdef CONFIG_ITCO_VENDOR_SUPPORT somewhere in iTCO_vendor_support.c as the defines in iTCO_vendor.h mess up the iTCO_vendor_*() declarations when CONFIG_ITCO_VENDOR_SUPPORT isn't defined.
Comment 1 Ben Gamari 2008-08-10 12:25:06 UTC
Created attachment 17170 [details]
A sample patch, almost certainly incorrect
Comment 2 Andrew Morton 2008-08-10 12:52:38 UTC
Can you please send a bug report, including the offending .config file
to linux-kernel@vger.kernel.org, cc'ing myself (akpm@linux-foundation.org)?

Thanks.
Comment 3 Adrian Bunk 2008-08-10 13:12:04 UTC

*** This bug has been marked as a duplicate of bug 11294 ***

Note You need to log in before you can comment on or make changes to this bug.