Bug 11293 - 2.6.27-rc2: MSI vs. ath5k suspend regression on EeePC
2.6.27-rc2: MSI vs. ath5k suspend regression on EeePC
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-09 14:44 UTC by Rafael J. Wysocki
Modified: 2008-08-20 12:14 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc2
Tree: Mainline
Regression: Yes


Attachments
Proposed fix (960 bytes, patch)
2008-08-11 08:47 UTC, Alan Jenkins
Details | Diff

Description Rafael J. Wysocki 2008-08-09 14:44:25 UTC
Subject    : 2.6.27-rc2: suspend regression on EeePC
Submitter  : Alan Jenkins <alan-jenkins@tuffmail.co.uk>
Date       : 2008-08-06 18:59
References : http://thread.gmane.org/gmane.linux.kernel.kernel-testers/701

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Alan Jenkins 2008-08-11 08:47:10 UTC
Created attachment 17179 [details]
Proposed fix

Mainline ath5k doesn't use MSI, but a patch slipped in which enabled it on resume.
Comment 2 John W. Linville 2008-08-14 10:43:23 UTC
commit 256b152b005e319f985f50f2a910a75ba0def74f
Author: Pavel Roskin <proski@gnu.org>
Date:   Fri Jul 18 12:56:59 2008 -0400

    ath5k: don't enable MSI, we cannot handle it yet
    
    MSI is a nice thing, but we cannot enable it without changing the
    interrupt handler.  If we do it, we break MSI capable hardware,
    specifically AR5006 chipset.
    
    Signed-off-by: Pavel Roskin <proski@gnu.org>
    Acked-by: Nick Kossifidis <mickflemm@gmail.com>
    Cc: stable <stable@kernel.org>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>
Comment 3 Alan Jenkins 2008-08-15 03:18:50 UTC
Wrong!  Testing confirms this regression is still present in 2.6.27-rc3.  Please re-read my problem description and proposed fix.

256b152b005e319f985f50f2a910a75ba0def74f only touches the probe/remove routines in base.c.  It missed the suspend/resume callbacks in hw.c which disable/re-enable MSI (which I believe is unnecessary anyway as this is done my the pci core).

Credit should go to Michael Karcher, who independently posted a similar patch on ath5k-devel several days before me.
Comment 4 John W. Linville 2008-08-15 06:21:14 UTC
Ah, sorry.  I'll pick-up that fix in the next round.

Note You need to log in before you can comment on or make changes to this bug.