Bug 11283 - MSI patch blamed for T60p not coming out of suspend to ram
Summary: MSI patch blamed for T60p not coming out of suspend to ram
Status: CLOSED DUPLICATE of bug 11178
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_pci@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-07 16:07 UTC by Michael S. Tsirkin
Modified: 2008-08-11 16:09 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Michael S. Tsirkin 2008-08-07 16:07:46 UTC
Latest working kernel version: 2.6.26
Earliest failing kernel version: 2.6.27-rc1
Distribution: ubuntu gutsy
Hardware Environment: T60p
Software Environment: gutsy install with full disk encryption
Problem Description:

Starting 2.6.27-rc1, my laptop won't come out of
suspend to ram: it blinks the crescent a couple of times,
and hangs.
I bisected the problem to the following merge:

bad: [1d9b9f6a53d77ed801ba875f937d6dabbfc381ce] Merge branch 'for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/jbarnes/pci-2.6

I then played with rebase (rebase instead of merge)and got to this commit:

commit ce6fce4295ba727b36fdc73040e444bd1aae64cd
Author: Matthew Wilcox <matthew@wil.cx>
Date:   Fri Jul 25 15:42:58 2008 -0600

    PCI MSI: Don't disable MSIs if the mask bit isn't supported

    David Vrabel has a device which generates an interrupt storm on the INTx
    pin if we disable MSI interrupts altogether.  Masking interrupts is only
    a performance optimisation, so we can ignore the request to mask the
    interrupt.

    Signed-off-by: Matthew Wilcox <willy@linux.intel.com>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>

Reverting ce6fce4295ba727b36fdc73040e444bd1aae64cd
fixes resume from suspend to RAM for me.

Steps to reproduce:

Press Fn-F4 to suspend, press Fn to resume.
This works on 2.6.26, hangs on vanilla 2.6.27-rc1
and 2.6.27-rc2, works on 2.6.27-rc2 with reverted ce6fce..
Comment 1 Michael S. Tsirkin 2008-08-07 16:26:26 UTC
I'd like to clarify the note about rabases above: 
12c0b20fa4afb5c8a377d6987fb2dcf353e1dce1
by itself resumed for me once, and hung once.
The problem seems to be more pronounced (easier to reproduce)
when applied on top of a3ad7f128c637b7612ebeacb1f85fec933bb1195.
Comment 2 Jesse Barnes 2008-08-07 17:22:42 UTC
This sounds like http://bugzilla.kernel.org/show_bug.cgi?id=11178, can you check?
Comment 3 Kevin Mitchell 2008-08-11 02:29:40 UTC
Looks like http://bugzilla.kernel.org/attachment.cgi?id=17043&action=view indeed fixes it. Had the same issue with a T60. Thanks Jesse.
Comment 4 Rafael J. Wysocki 2008-08-11 16:09:13 UTC

*** This bug has been marked as a duplicate of bug 11178 ***

Note You need to log in before you can comment on or make changes to this bug.