Bug 11279 - 2.6.27-rc0 Power Bugs with HP/Compaq Laptops
2.6.27-rc0 Power Bugs with HP/Compaq Laptops
Status: CLOSED DUPLICATE of bug 11418
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: Thomas Gleixner
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-07 13:59 UTC by Rafael J. Wysocki
Modified: 2008-09-05 03:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27-rc0
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-07 13:59:17 UTC
Subject    : 2.6.27-rc0 Power Bugs with HP/Compaq Laptops
Submitter  : "Matt Parnell" <mparnell@gmail.com>
Date       : 2008-08-07 14:57
References : http://marc.info/?l=linux-kernel&m=121812108031685&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-18 14:25:43 UTC
On Monday, 18 of August 2008, Matt Parnell wrote:
> Yep. Still needs listed. Not even -tip is working for me. 2.6.26 works
> like a charm, though.
> 
> On Sat, Aug 16, 2008 at 12:02 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=11279
> > Subject         : 2.6.27-rc0 Power Bugs with HP/Compaq Laptops
> > Submitter       : Matt Parnell <mparnell@gmail.com>
> > Date            : 2008-08-07 14:57 (10 days old)
> > References      : http://marc.info/?l=linux-kernel&m=121812108031685&w=4

Comment 2 Rafael J. Wysocki 2008-08-22 15:15:55 UTC
On Friday, 22 of August 2008, Matt Parnell wrote:
> I think that the problem is narrowed down now to something with
> hrtimers. I believe they may be using a faulty clocksource, in which
> case they should be using hpet.
> -Matt Parnell

Comment 3 Rafael J. Wysocki 2008-08-23 03:18:56 UTC
On Saturday, 23 of August 2008, Matt Parnell wrote:
> Arrgh...I spoke too soon. It'll boot if I disable hrtimers, but I also
> have to make it use jiffies as the clocksource...so I guess we're back
> to square one. If i have hrtimers enabled, with or without
> clocksource=jiffies, I end up getting segfaults...so, I'm pretty much
> not sure what to do at this point, but relay this message to the pros.

Comment 4 Rafael J. Wysocki 2008-08-30 15:06:37 UTC
On Sunday, 31 of August 2008, Matt Parnell wrote:
> I've narrowed it down to the clocksource. I have to use
> clocksource=jiffies for anything to work.
> 
> On Sat, Aug 30, 2008 at 12:50 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=11279
> > Subject         : 2.6.27-rc0 Power Bugs with HP/Compaq Laptops
> > Submitter       : Matt Parnell <mparnell@gmail.com>
> > Date            : 2008-08-07 14:57 (24 days old)
> > References      : http://marc.info/?l=linux-kernel&m=121812108031685&w=4

Comment 5 Thomas Gleixner 2008-09-04 12:21:09 UTC
Handled-by: me
Comment 6 Rafael J. Wysocki 2008-09-04 12:24:29 UTC
Handled-By : Thomas Gleixner <tglx@linutronix.de>
Comment 7 Thomas Gleixner 2008-09-05 03:45:02 UTC
Matt just confirmed that this is solved by the patch in BZ11418. Marking this one as a duplicate.


*** This bug has been marked as a duplicate of bug 11418 ***

Note You need to log in before you can comment on or make changes to this bug.