Bug 11277 - BUG kmalloc-64: Object already free
Summary: BUG kmalloc-64: Object already free
Status: CLOSED CODE_FIX
Alias: None
Product: Memory Management
Classification: Unclassified
Component: Slab Allocator (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-07 13:50 UTC by Rafael J. Wysocki
Modified: 2008-08-14 06:06 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc1-00156-g94ad374
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-07 13:50:58 UTC
Subject    : BUG kmalloc-64: Object already free
Submitter  : "Justin Mattock" <justinmattock@gmail.com>
Date       : 2008-08-06 21:21
References : http://marc.info/?l=linux-kernel&m=121805862910241&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Andrew Morton 2008-08-07 14:20:36 UTC
This should be fixed by -mm's isight_firmware-fix-a-leak-and-double-kfree.patch
Comment 2 Rafael J. Wysocki 2008-08-07 14:23:34 UTC
Handled-By : Parag Warudkar <parag.warudkar@gmail.com>
Patch : http://marc.info/?l=linux-kernel&m=121814402609514&w=4
Comment 3 Justin P. Mattock 2008-08-07 14:27:22 UTC
On Thu, Aug 7, 2008 at 2:23 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11277
>
>
>
>
>
> ------- Comment #2 from rjw@sisk.pl  2008-08-07 14:23 -------
> Handled-By : Parag Warudkar <parag.warudkar@gmail.com>
> Patch : http://marc.info/?l=linux-kernel&m=121814402609514&w=4
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

Applied:
I'll let you know if I see anything.
Comment 4 Adrian Bunk 2008-08-14 01:09:10 UTC
fixed by commit ff1a4a7b14ae146142b1c93a001304caf662ae13
Comment 5 Justin P. Mattock 2008-08-14 01:30:35 UTC
On Thu, Aug 14, 2008 at 1:09 AM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11277
>
>
> bunk@kernel.org changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |bunk@kernel.org
>             Status|NEW                         |CLOSED
>         Resolution|                            |CODE_FIX
>
>
>
>
> ------- Comment #4 from bunk@kernel.org  2008-08-14 01:09 -------
> fixed by commit ff1a4a7b14ae146142b1c93a001304caf662ae13
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

Cool;
One quick question;
As a rookie to git, how do I
do a "git-pull" the proper way; since I have already commited this
patch. This way I don't cause a problem in the tree that I am using.
Comment 6 Adrian Bunk 2008-08-14 06:06:37 UTC
(In reply to comment #5)
> One quick question;
> As a rookie to git, how do I
> do a "git-pull" the proper way; since I have already commited this
> patch. This way I don't cause a problem in the tree that I am using.

Assuming you want to get rid of your local patch and do not have other local commits in your tree you want to keep:

git-reset --hard origin
git-pull
Comment 7 Justin P. Mattock 2008-08-14 08:03:05 UTC
On Thu, Aug 14, 2008 at 6:06 AM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11277
>
>
>
>
>
> ------- Comment #6 from bunk@kernel.org  2008-08-14 06:06 -------
> (In reply to comment #5)
>> One quick question;
>> As a rookie to git, how do I
>> do a "git-pull" the proper way; since I have already commited this
>> patch. This way I don't cause a problem in the tree that I am using.
>
> Assuming you want to get rid of your local patch and do not have other local
> commits in your tree you want to keep:
>
> git-reset --hard origin
> git-pull
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

As of right now the only patches I have plugged into
the kernel are for bug 11277, and for isight_firmware.
Thanks for the help, I'll do a google on the subject
and then do a git-pull.

Note You need to log in before you can comment on or make changes to this bug.