Bug 11270 - BUG when doing a cat /sys/devices/system/cpu/cpuidle/current_driver
Summary: BUG when doing a cat /sys/devices/system/cpu/cpuidle/current_driver
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Processor (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-processor
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-07 12:49 UTC by Rafael J. Wysocki
Modified: 2008-08-13 07:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc1-00649-gca5de40
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-07 12:49:17 UTC
Subject    : BUG when doing a cat /sys/devices/system/cpu/cpuidle/current_driver
Submitter  : Eric Sesterhenn <snakebyte@gmx.de>
Date       : 2008-08-05 12:33
References : http://marc.info/?l=linux-kernel&m=121793969102438&w=4
Handled-By : Rabin Vincent <rabin@rab.in>
Patch      : http://marc.info/?l=linux-kernel&m=121795955208618&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Justin P. Mattock 2008-08-07 13:08:47 UTC
On Thu, Aug 7, 2008 at 12:54 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11270
>
>
> rjw@sisk.pl changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                 CC|                            |justinmattock@gmail.com
>
>
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

here is the thread to the patch, that I had used to fix
this:
http://lkml.org/lkml/2008/8/5/314
thanks to rabin and Eric Sesterhenn
for bringing this into the open.
I would of never have seen this.
Comment 2 Zhang Rui 2008-08-10 19:06:05 UTC
Rafael,
can we close this bug now?
Comment 3 Justin P. Mattock 2008-08-10 20:12:47 UTC
On Sun, Aug 10, 2008 at 7:06 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11270
>
>
>
>
>
> ------- Comment #2 from rui.zhang@intel.com  2008-08-10 19:06 -------
> Rafael,
> can we close this bug now?
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

If the patch has been pushed
into the linus tree, Then yes
if not then leave it open until further notice.
Comment 4 Rafael J. Wysocki 2008-08-11 04:33:50 UTC
Please only close the bug _after_ the fix has been merged into the Linus' tree and please provide the SHA1 hash of the commit containing the fix.
Comment 5 Justin P. Mattock 2008-08-11 10:09:41 UTC
On Mon, Aug 11, 2008 at 4:33 AM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11270
>
>
>
>
>
> ------- Comment #4 from rjw@sisk.pl  2008-08-11 04:33 -------
> Please only close the bug _after_ the fix has been merged into the Linus'
> tree
> and please provide the SHA1 hash of the commit containing the fix.
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

O.k.
hate to ask this but, how do I create a SHA1 hash
for the commit?("never really messed around with that stuff")
Comment 6 Venkatesh Pallipadi 2008-08-11 10:13:17 UTC
You don't have to create one. Once the patch gets into git upstream, you will have a SHA1 associated with the patch. 
Comment 7 Justin P. Mattock 2008-08-11 10:18:29 UTC
On Mon, Aug 11, 2008 at 10:13 AM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11270
>
>
>
>
>
> ------- Comment #6 from venkatesh.pallipadi@intel.com  2008-08-11 10:13
> -------
>
> You don't have to create one. Once the patch gets into git upstream, you will
> have a SHA1 associated with the patch.
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

O.k.
but still I should do my homework in that
department, just so I know how to.

regards;
Comment 8 Rafael J. Wysocki 2008-08-11 13:55:12 UTC
On Monday, 11 of August 2008, Rabin Vincent wrote:
> On Sun, Aug 10, 2008 at 12:43:51AM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=11270
> > Subject             : BUG when doing a cat
> /sys/devices/system/cpu/cpuidle/current_driver
> > Submitter   : Eric Sesterhenn <snakebyte@gmx.de>
> > Date                : 2008-08-05 12:33 (5 days old)
> > References  : http://marc.info/?l=linux-kernel&m=121793969102438&w=4
> > Handled-By  : Rabin Vincent <rabin@rab.in>
> > Patch               :
> http://marc.info/?l=linux-kernel&m=121795955208618&w=4
> 
> Needs to be open.  The patch is in -mm, but is not yet in mainline.
Comment 9 Justin P. Mattock 2008-08-11 18:34:04 UTC
On Mon, Aug 11, 2008 at 1:55 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11270
>
>
>
>
>
> ------- Comment #8 from rjw@sisk.pl  2008-08-11 13:55 -------
> On Monday, 11 of August 2008, Rabin Vincent wrote:
>> On Sun, Aug 10, 2008 at 12:43:51AM +0200, Rafael J. Wysocki wrote:
>> > This message has been generated automatically as a part of a report
>> > of recent regressions.
>> >
>> > The following bug entry is on the current list of known regressions
>> > from 2.6.26.  Please verify if it still should be listed and let me know
>> > (either way).
>> >
>> >
>> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=11270
>> > Subject             : BUG when doing a cat
>> /sys/devices/system/cpu/cpuidle/current_driver
>> > Submitter   : Eric Sesterhenn <snakebyte@gmx.de>
>> > Date                : 2008-08-05 12:33 (5 days old)
>> > References  : http://marc.info/?l=linux-kernel&m=121793969102438&w=4
>> > Handled-By  : Rabin Vincent <rabin@rab.in>
>> > Patch               :
>> http://marc.info/?l=linux-kernel&m=121795955208618&w=4
>>
>> Needs to be open.  The patch is in -mm, but is not yet in mainline.
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

I agree
Comment 10 Shaohua 2008-08-12 22:43:36 UTC
the patch is in git tree now, close it.
Comment 11 Justin P. Mattock 2008-08-13 00:19:41 UTC
On Tue, Aug 12, 2008 at 10:43 PM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11270
>
>
> shaohua.li@intel.com changed:
>
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|NEW                         |CLOSED
>         Resolution|                            |PATCH_ALREADY_AVAILABLE
>
>
>
>
> ------- Comment #10 from shaohua.li@intel.com  2008-08-12 22:43 -------
> the patch is in git tree now, close it.
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

Cool,
bug is closed..
Comment 12 Rafael J. Wysocki 2008-08-13 07:12:13 UTC
(In reply to comment #10)
> the patch is in git tree now, close it.
> 

Which commit is that?
Comment 13 Justin P. Mattock 2008-08-13 09:42:54 UTC
On Wed, Aug 13, 2008 at 7:12 AM,  <bugme-daemon@bugzilla.kernel.org> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=11270
>
>
>
>
>
> ------- Comment #12 from rjw@sisk.pl  2008-08-13 07:12 -------
> (In reply to comment #10)
>> the patch is in git tree now, close it.
>>
>
> Which commit is that?
>
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.
>

This is the location:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=66198f36aac21533245a77aac4a8f7c8c509d8bd
and I think this is the commit:
f718cd4add5aea9d379faff92f162571e356cc5f

Note You need to log in before you can comment on or make changes to this bug.