Bug 11245 - acpi error on 2.6.27-rc1+ (ACPI Error (dsobject-0501))
acpi error on 2.6.27-rc1+ (ACPI Error (dsobject-0501))
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: BIOS
All Linux
: P1 normal
Assigned To: Lin Ming
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-03 14:51 UTC by Rafael J. Wysocki
Modified: 2008-08-18 02:56 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: ---


Attachments
full dmesg (11.38 KB, text/plain)
2008-08-04 09:23 UTC, Marcin Slusarz
Details
acpidump (20.17 KB, application/octet-stream)
2008-08-04 09:24 UTC, Marcin Slusarz
Details
change the ACPI_ERROR to ACPI_WARNING (519 bytes, patch)
2008-08-07 18:48 UTC, Lin Ming
Details | Diff

Description Rafael J. Wysocki 2008-08-03 14:51:48 UTC
Subject    : acpi error on 2.6.27-rc1+ (ACPI Error (dsobject-0501))
Submitter  : Marcin Slusarz <marcin.slusarz@gmail.com>
Date       : 2008-08-03 18:29
References : http://marc.info/?l=linux-kernel&m=121778823123488&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Zhang Rui 2008-08-03 18:32:55 UTC
Please attach the full dmesg output.
Please attach the acpidump output using the latest pmtools at:
http://www.lesswatts.org/patches/linux_acpi/
Comment 2 Zhang Rui 2008-08-03 18:34:14 UTC
Sounds like a BIOS/ACPICA problem.
Re-assign to Ming.
Comment 3 ykzhao 2008-08-03 18:51:20 UTC
Will you please confirm whether the system is affected by the warning message or the warning message is harmless?

From the acpidump it seems that this warning message is related with the BIOS. The package count of _PSS object is set to 0x03. But the BIOS give the incorrect package length.
  >   Name (_PSS, Package (0x03)
                        {
                            Package (0x06)
                            {
                                0x000007D0,
                                0x000105B8,
                                0x00000064,
                                0x00000007,
                                0xE020298C,
                                0x0000018C
                            }, 
                            Package (0x06)
                            {
                                0x00000708,
                                0x0000DAC0,
                                0x00000064,
                                0x00000007,
                                0xE0202A0A,
                                0x0000020A
                            },  
                            Package (0x06)
                            {
                                0x000003E8,
                                0x00005208,
                                0x00000064,
                                0x00000007,
                                0xE0202C82,
                                0x00000482
                            },

                            Zero,
                            Zero,
                            Zero,

    Thanks.
Comment 4 Lin Ming 2008-08-04 02:28:07 UTC
It's not a bug.
It just prints an error message because the declared package length does not match the actual length of the package.
Comment 5 Marcin Slusarz 2008-08-04 09:23:11 UTC
Created attachment 17086 [details]
full dmesg

on 2b12a4c524812fb3f6ee590a02e65b95c8c32229
Comment 6 Marcin Slusarz 2008-08-04 09:24:23 UTC
Created attachment 17087 [details]
acpidump
Comment 7 Marcin Slusarz 2008-08-04 09:38:59 UTC
(In reply to comment #3)
> Will you please confirm whether the system is affected by the warning message
> or the warning message is harmless?

I'm not sure if it's related but suspend to ram stopped working - my computer reboots on resume... (I noticed it today)
Comment 8 Rafael J. Wysocki 2008-08-07 15:32:23 UTC
Handled-By : Zhang Rui <rui.zhang@intel.com>
Handled-By : Zhao Yakui <yakui.zhao@intel.com>
Comment 9 Zhang Rui 2008-08-07 18:33:55 UTC
Ming, what's your plan of this bug?
do you think if an ACPI_ERROR is needed here?
The incorrect parameter is harmless in this bug.
change the ACPI_ERROR to ACPI_WARNING or ACPI_DB_INFO?

Marcin,
The s3 failure seems to be another bug.
Please file a new bug report about this. thanks. :)
Comment 10 Lin Ming 2008-08-07 18:48:24 UTC
Created attachment 17136 [details]
change the ACPI_ERROR to ACPI_WARNING

Close it since it's not a bug.

Change the ACPI_ERROR to ACPI_WARNING for this case.
Comment 11 Marcin Slusarz 2008-08-17 02:40:31 UTC
when will this patch hit mainline?
Comment 12 Rafael J. Wysocki 2008-08-17 03:18:43 UTC
Well, I guess when Andi picks it up.
Comment 13 Andi Kleen 2008-08-17 19:18:06 UTC
Lin Ming, please only close bugs when the patch has been merged. Otherwise we can lose track. Also please always add description and sign-off. Thanks

I'm not sure why this is tracked as a regression. Other than the harmless message
is there actually something broken?

I can merge the patch for test at least, but I'm not sure we really need it for .27

It's now 

commit 1371c893ff9de0d57fa5b5cf0255d66b8849e13d
Author: Ming Ling <ming.m.lin@intel.com>
Date:   Mon Aug 18 04:14:59 2008 +0200

    ACPI: Change package length error to warning

in test

Comment 14 Andi Kleen 2008-08-17 20:27:33 UTC
Rafael please take this off the regression list
Comment 15 Rafael J. Wysocki 2008-08-18 02:56:02 UTC
Done.

Note You need to log in before you can comment on or make changes to this bug.