Bug 11232 - Console Suspend - Resume Regression
Console Suspend - Resume Regression
Status: CLOSED DUPLICATE of bug 11178
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216 Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-02 10:56 UTC by Dionisus Torimens
Modified: 2008-08-02 13:11 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Dionisus Torimens 2008-08-02 10:56:50 UTC
Latest working kernel version: 2.6.26
Earliest failing kernel version: 2.6.27-rc1
Distribution: Ubuntu 8.04
Hardware Environment: Acer Extensa 5220
Software Environment: /bin/bash
Problem Description:
On resume it halts, the last thing shown is something about console suspend and it gives a kernel parameter to debug it. When I boot with that kernel parameter it boots further and hangs with disk access problems. 
Please let me know how I can help debugging this.
Comment 1 Rafael J. Wysocki 2008-08-02 12:02:34 UTC
Please test the current Linus' tree (2.6.27-rc1-git4 as of today).
Comment 2 Rafael J. Wysocki 2008-08-02 12:11:30 UTC
Please also check if the final patch from bug #11178 fixes the problem for you.
Comment 3 Dionisus Torimens 2008-08-02 12:54:52 UTC
The problems still occurs at the current head: commit 2b12a4c524812fb3f6ee590a02e65b95c8c32229. How do I find out what version that is? I only find -rc1.

no_console_suspend is the kernel ata cmdline that helps a bit.
With that I also get a hard disk revalidation error, I'll check the patch next.
Comment 4 Rafael J. Wysocki 2008-08-02 13:01:13 UTC
(In reply to comment #3)
> The problems still occurs at the current head: commit
> 2b12a4c524812fb3f6ee590a02e65b95c8c32229. How do I find out what version that
> is? I only find -rc1.

Just the commit name is the version.

> no_console_suspend is the kernel ata cmdline that helps a bit.
> With that I also get a hard disk revalidation error, I'll check the patch
> next. 

Thanks.
Comment 5 Dionisus Torimens 2008-08-02 13:06:08 UTC
The patch fixes the problem.
Comment 6 Rafael J. Wysocki 2008-08-02 13:11:36 UTC

*** This bug has been marked as a duplicate of bug 11178 ***

Note You need to log in before you can comment on or make changes to this bug.