Bug 11230 - Kconfig no longer outputs a .config with freshly updated defconfigs
Kconfig no longer outputs a .config with freshly updated defconfigs
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Configuration
All Linux
: P1 normal
Assigned To: Sam Ravnborg
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-02 10:15 UTC by Rafael J. Wysocki
Modified: 2008-10-06 08:56 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-02 10:15:41 UTC
Subject    : Kconfig no longer outputs a .config with freshly updated defconfigs
Submitter  : Josh Boyer <jwboyer@linux.vnet.ibm.com>
Date       : 2008-08-02 16:03
References : http://marc.info/?l=linux-kernel&m=121769306319391&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Adrian Bunk 2008-08-05 00:44:24 UTC
fixed by commit 22127f246dc37ed5bea0915f7860002ba6d87da7
Comment 2 Roman Zippel 2008-08-05 10:05:29 UTC
reopening because above commit causes a new regression, as .config is now even saved where it shouldn't. try:

touch .config
make
Comment 3 Adrian Bunk 2008-08-05 10:53:45 UTC
(In reply to comment #2)
> reopening because above commit causes a new regression, as .config is now even
> saved where it shouldn't. try:
> 
> touch .config
> make

In the past I always considered it confusing that after setting a leaf variable in .config to =n the .config was not written with "is not set" instead, so I'd claim this change is not a regression but an improvement.

Or is there any problem I miss?
Comment 4 Roman Zippel 2008-08-05 11:19:37 UTC
(In reply to comment #3)
> In the past I always considered it confusing that after setting a leaf variable
> in .config to =n the .config was not written with "is not set" instead, so I'd
> claim this change is not a regression but an improvement.

If you want to explicitely update the .config you can always call oldconfig, but other people keep their .config in a VCS, so if they restore a previous (valid) .config, a simple make would modify it (e.g. with a new timestamp).
Writing the new .config only if neccessary is also a good sign that something was wrong with the old config and one can check what changed. This is now lost.
Comment 5 Rafael J. Wysocki 2008-08-05 12:04:25 UTC
Since the problem in question is different from the original one, can you open a separate bugzilla entry for tracking it and close this one, please?
Comment 6 Rafael J. Wysocki 2008-08-10 05:42:34 UTC
On Sunday, 10 of August 2008, Sam Ravnborg wrote:
> On Sun, Aug 10, 2008 at 12:43:51AM +0200, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.26.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=11230
> > Subject		: Kconfig no longer outputs a .config with freshly updated defconfigs
> > Submitter	: Josh Boyer <jwboyer@linux.vnet.ibm.com>
> > Date		: 2008-08-02 16:03 (8 days old)
> > References	: http://marc.info/?l=linux-kernel&m=121769306319391&w=4
> 
> The originally reported issue is fixed,
> but the fix was bad.
> Roman have already posted a patch fixing it but I need time
> to review/test.

Comment 7 Adrian Bunk 2008-10-06 08:56:03 UTC
The other issue got fixed by commit 204c96f609045a8ce84d1dca3e758ee9b0b2a95c

Note You need to log in before you can comment on or make changes to this bug.