Bug 112261 - fail evaluating the _reg object of ec device
Summary: fail evaluating the _reg object of ec device
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: Intel Linux
: P1 blocking
Assignee: Aaron Lu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-10 13:06 UTC by martin.passard59
Modified: 2016-05-16 21:26 UTC (History)
4 users (show)

See Also:
Kernel Version: 4.X - amd64
Tree: Mainline
Regression: No


Attachments

Description martin.passard59 2016-02-10 13:06:57 UTC
HI, 
I recently made the acquisition of the MSI GP62 6QE Leopard pro   (CPU is i5-6300HQ (Quad-Core 2.3 GHz / 3.2 GHz Turbo - Cache 6 Mo)
Chipset: Mobile Intel HM170 Express)

I've installed on it a dual-boot with Win10 X64 & Debian

In order to made work a lot of devices, I've to upgrade the Kernel to a 4.X version. When I am in the 3.16.0-4-amd64 kernel of debian, the computer boot correctly without any error message except for the drivers, because I d'on't have audio, Wifi, and Ethernet drivers
When I use a 4.X version of the kernel, i have a bug: the boot says me:
ACPI: EC: fail in evaluating the _reg object of ec device.
and then, he stuck on "Loading please wait", or he continue booting, and before the start of the Gui, he tells me:

INFO: rcu_sched self-detected stall on CPU
#1 (5249 ticks this GP) idle=48f/140000000000001/0 softirq=2839/2839 fqs=5249
# (t=5250 jiffies g=1760 c=1759 q=937)
NMI watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [Xorg:849]

So, in order to see if it was or not the fault of the BIOS, i updated it to the last version from the manufacturer website, no changes at all. the only way to boot properly is to use acpi=off, acpi=ht don't work correctly. 

I've tried a lot of thing for what I don't remember, so, if you have a proposition to try to fix it, give it to me, I will try.

Sorry if my English is not perfect because I am French ;-)
Comment 1 martin.passard59 2016-02-10 13:22:53 UTC
With CPU C-states ON : The boot stuck with "Loading, please wait..."
Without: The boot start but get the message :  
[drm:finish_csr_load[i915]] *ERROR* failed to load firmware i915/sk1_dmc_ver1.bin (0)
[drm: intel_display_power_put [i915]] *ERROR* CSR firmware not ready

For theses aptempts, I used the version 4.3.0-0.bpo.1-amd64 (stable) directly came from the backport source.
Comment 2 martin.passard59 2016-02-10 13:39:38 UTC
Sorry for triple post but this post change during my research:

i remove "quiet" from start option and get thoses messages from when the boot stuck: nouveau 0000:01:00.0: Refused to change to power state, currently in D3
01.00.0 is My GPU  called as 3Dcontroller: NVIDIA Corporation Device 139a (rev a2)
Comment 3 Aaron Lu 2016-02-19 07:49:09 UTC
Is it possible to boot to console mode with the v4.x kernel?
For Fedora, that would be to add 3 to kernel cmdline, but debian may be different.
Comment 4 martin.passard59 2016-02-19 18:15:42 UTC
I will try what you said, but first I've found something that's looks be the same issue: https://bugzilla.kernel.org/show_bug.cgi?id=109081

I've installed Kali witch is a 4.3.0 Kernel, last update. For the moment, everything boot and looks Ok, but when I log myself the entire computer freeze (ver num for exemple is freeze, the mouse stop moving, and nothing respond...)

I will try what I've seen on the bug 109081 comments if it works, and then I will see if I can do what you told to me.
On the other Case, they are saying that this is due to the new skylake architecture. I will see if I can investigate more about it...

Thank you for helping me.
Comment 5 Lv Zheng 2016-04-13 06:17:51 UTC
This doesn't look like an EC related bug.
Let me reset the assignee.

Thanks
-Lv
Comment 6 Aaron Lu 2016-04-13 07:38:34 UTC
Bug 109081 is closed after a code fix, can you please try that patch to see if your problem is also solved? Kernels that are v4.6-rc1 or later should have the fix patch there.
Comment 7 Zhang Rui 2016-05-10 06:50:53 UTC
PING...
Comment 8 Zhang Rui 2016-05-16 06:48:47 UTC

*** This bug has been marked as a duplicate of bug 109081 ***

Note You need to log in before you can comment on or make changes to this bug.