Bug 11221 - 2.6.27-rc1 oops when plugging USB disk
Summary: 2.6.27-rc1 oops when plugging USB disk
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency tree
 
Reported: 2008-08-01 15:11 UTC by Rafael J. Wysocki
Modified: 2008-08-14 09:17 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.27-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-08-01 15:11:27 UTC
Subject    : 2.6.27-rc1 oops when plugging USB disk
Submitter  : Lukas Hejtmanek <xhejtman@ics.muni.cz>
Date       : 2008-08-01 13:35
References : http://marc.info/?l=linux-kernel&m=121759786223716&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Lukas Hejtmanek 2008-08-13 09:42:13 UTC
In 2.6.27-rc3, if I do modprobe usb_storage. the modprobe stucks.
the sysrq shows:
Aug 13 18:30:11 anubis klogd: [ 2490.460597] modprobe      D ffff880067bc9cf0     0 25525   6549
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  ffff880057ed9be8 0000000000000086 0000000000000000 ffff880057ed9b58
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  ffffffff806e2b80 ffff880057ef0b00 ffffffff80647340 ffff880057ef0d30
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  00000000fffffff4 000000010009d402 ffff880057ef0d30 0000000000000000
Aug 13 18:30:11 anubis klogd: [ 2490.460597] Call Trace:
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff802f6a9b>] create_dir+0x6b/0xc0
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff8050180d>] schedule_timeout+0x8d/0xd0
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff80347af1>] kobject_add_internal+0xf1/0x1f0
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff80347d7e>] kobject_init_and_add+0x6e/0x90
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff80502171>] __down+0x61/0xa0
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff80252136>] down+0x46/0x50
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff8021e9e0>] do_flush_tlb_all+0x0/0x40
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff803b8440>] __driver_attach+0x30/0x90
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff803b8410>] __driver_attach+0x0/0x90
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff803b7a9b>] bus_for_each_dev+0x5b/0x80
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff8029ef15>] kmem_cache_alloc+0x65/0xa0
Aug 13 18:30:11 anubis klogd: [ 2490.460597]  [<ffffffff803b7378>] bus_add_driver+0x1e8/0x260
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffff803b8679>] driver_register+0x69/0x150
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffff80404e89>] usb_register_driver+0xa9/0x120
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffffa000d000>] usb_stor_init+0x0/0x4d [usb_storage]
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffffa000d029>] usb_stor_init+0x29/0x4d [usb_storage]
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffff80209253>] do_one_initcall+0x43/0x190
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffff8025fdcf>] sys_init_module+0x17f/0x1b20
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffff80411de0>] usb_usual_set_present+0x0/0x40
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffff802a6fde>] sys_newfstat+0x2e/0x50
Aug 13 18:30:11 anubis klogd: [ 2490.460598]  [<ffffffff8020c4cb>] system_call_fastpath+0x16/0x1b
Aug 13 18:30:11 anubis klogd: [ 2490.460598] 
Comment 2 Alan Stern 2008-08-13 13:33:11 UTC
I need to see the dmesg long, with CONFIG_USB_DEBUG enabled.

For what it's worth, I just booted 2.6.27-rc3 on my machine.  When I loaded the usb-storage module, it worked perfectly.
Comment 3 Lukas Hejtmanek 2008-08-13 13:38:45 UTC
ah, forgot to say. I plugged the usb mass-storage device first, nothing happened. so I modprobed the device manually with the result above. I give a try tomorrow with USB_DEBUG.
Comment 4 Lukas Hejtmanek 2008-08-14 02:50:54 UTC
well, I'm unable to reproduce it with the current git head. Maybe this bug can be closed and I reopen it, if I see this bug again.

Note You need to log in before you can comment on or make changes to this bug.