Bug 11220 - Screen stays black after resume
Screen stays black after resume
Status: CLOSED DUPLICATE of bug 7225
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-08-01 15:00 UTC by Rafael J. Wysocki
Modified: 2008-11-09 13:22 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27-rc1-00555-g8f616cd
Tree: Mainline
Regression: Yes


Attachments
dmesg of dell inspiron waking up to blank screen and Xorg.0.log (151.23 KB, application/octet-stream)
2008-09-12 22:01 UTC, Justin P. Mattock
Details

Description Rafael J. Wysocki 2008-08-01 15:00:13 UTC
Subject    : Heavy suspend and io problems in 2.6.27-rc1-00156-g94ad374
Submitter  : Nico Schottelius <nico@schottelius.org>
Date       : 2008-07-31 21:05
References : http://marc.info/?l=linux-kernel&m=121753882422899&w=4
Handled-By : "Rafael J. Wysocki" <rjw@sisk.pl>

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-08-01 15:00:41 UTC
This may be a duplicate of bug #11178, but confirmation is needed.
Comment 2 Marek Lotke 2008-08-03 00:54:04 UTC
I've had the same symptoms: long delay when resuming with I/O errors. Patch http://bugzilla.kernel.org/attachment.cgi?id=17043 from bug #11178 fixed it.
Comment 3 Rafael J. Wysocki 2008-08-23 12:19:35 UTC
Not-Handled-By : "Rafael J. Wysocki" <rjw@sisk.pl>
Comment 4 Justin P. Mattock 2008-09-12 22:01:21 UTC
Created attachment 17757 [details]
dmesg of dell inspiron waking up to blank screen and Xorg.0.log

my dell inspiron wakes to a blank screen, not sure if this is kernel or xorg.conf
Comment 5 Shaohua 2008-09-23 19:28:44 UTC
>(II) I810(0): PIPEBCONF is 0x00000000
this means display isn't enabled. Can you please try a new xorg intel video driver?
Comment 6 Justin P. Mattock 2008-10-02 21:30:00 UTC
(In reply to comment #5)
> >(II) I810(0): PIPEBCONF is 0x00000000
> this means display isn't enabled. Can you please try a new xorg intel video
> driver?
> 

Thanks for the advice, I have never really setup intel graphics before:
So after looking into it, loading
the right modules; 3D is working now, and echo mem > /sys/power/state works
no delay, just starts right up.
 Now for the other situation
when doing the same with a macbook pro ATI chipset I did apply the patch from
#2 and was successful without any delays of over 30 secs. But that was a few weeks ago(noticed a change in that file), Now without adding any patches 
and keeping a clean kernel as possible suspend does work, but I'm waiting 
around over a minute or so. 
Comment 7 Rafael J. Wysocki 2008-10-03 05:11:34 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > >(II) I810(0): PIPEBCONF is 0x00000000
> > this means display isn't enabled. Can you please try a new xorg intel video
> > driver?
> > 
> 
> Thanks for the advice, I have never really setup intel graphics before:
> So after looking into it, loading
> the right modules; 3D is working now, and echo mem > /sys/power/state works
> no delay, just starts right up.

Good.

>  Now for the other situation
> when doing the same with a macbook pro ATI chipset I did apply the patch from
> #2 and was successful without any delays of over 30 secs. But that was a few
> weeks ago(noticed a change in that file), Now without adding any patches 
> and keeping a clean kernel as possible suspend does work, but I'm waiting 
> around over a minute or so. 

Did you change the kernel or is it the same kernel that worked well before?
Comment 8 Rafael J. Wysocki 2008-10-26 03:43:03 UTC
On Sunday, 26 of October 2008, Justin Mattock wrote:
> On Sat, Oct 25, 2008 at 2:07 PM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.26 and 2.6.27.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.26 and 2.6.27.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=11220
> > Subject         : Screen stays black after resume
> > Submitter       : Nico Schottelius <nico@schottelius.org>
> > Date            : 2008-07-31 21:05 (87 days old)
> > References      : http://marc.info/?l=linux-kernel&m=121753882422899&w=4
> 
> apologize for not responding,(tied up with debootstrap);
> after running ubuntu8.10 last week with the latest git
> suspend was resulting in a black screen on wakeup,
> (when using the latest radeon), maybe the video driver needs
> more time in the development stage. As for running the latest git
> today, suspend works without any delays. unfortunately I have to
> load a proprietary module for my system to be successful with suspend,
> that is until radeon becomes more mature in that area, or it is; I'm just not
> googling enough.

Comment 9 Rafael J. Wysocki 2008-11-09 13:22:48 UTC

*** This bug has been marked as a duplicate of bug 7225 ***

Note You need to log in before you can comment on or make changes to this bug.